MSC music device doesn't appear after intrepid upgrade

Bug #291810 reported by Ryan Fugger on 2008-10-31
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Intrepid
Low
Ubuntu Desktop Bugs

Bug Description

Device is Sansa Clip 4GB. Worked fine under Hardy, but now it doesn't appear in rhythmbox under Intrepid. It shows up if I enable the MTP plugin in rhythmbox, but all my songs are already transferred via MSC, so I can't see them. I can see the raw USB storage in the file browser just fine.

Related branches

Sebastien Bacher (seb128) wrote :

thank you for your bug report. what properties are listed for the device? could you run gvfs-mount -li and add the log to the bug?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Ryan Fugger (rfugger) wrote :
Ryan Fugger (rfugger) wrote :
Download full text (4.1 KiB)

I ran

rhythmbox -d file:///media/SANSA%20CLIP 2> rhythmbox.log

with the Sansa mounted and have attached the output, as well as the output from lshal below. From rhythmbox.log it appears that rhythmbox thinks my Sansa Clip is a Nokia 770??? Below is the pertinent section:

from rhythmbox.log:
---------------
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: unix-device = /dev/sdb
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: hal-udi = /org/freedesktop/Hal/devices/volume_uuid_F43C_C817
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: uuid = F43C-C817
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: label = SANSA CLIP
(15:31:03) [0x81fc408] [rb_removable_media_manager_add_volume] rb-removable-media-manager.c:593: Unhandled media
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: unix-device = /dev/sdb
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: hal-udi = /org/freedesktop/Hal/devices/volume_uuid_F43C_C817
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: uuid = F43C-C817
(15:31:03) [0x81fc408] [dump_volume_identifiers] rb-removable-media-manager.c:555: label = SANSA CLIP
(15:31:03) [0x81fc408] [hal_udi_is_nokia770] rb-nokia770-source.c:179: Nokia detection: info.parent=/org/freedesktop/Hal/devices/storage_serial_SanDisk_Sansa_Clip_4GB_ED0FFF0E3904B5870000000000000000_0_0
(15:31:03) [0x81fc408] [hal_udi_is_nokia770] rb-nokia770-source.c:184: Nokia detection: info.vendor=SanDisk
(15:31:03) [0x81fc408] [get_hal_udi_for_player] rb-generic-player-source.c:1356: searching for player udi from /org/freedesktop/Hal/devices/volume_uuid_F43C_C817
(15:31:03) [0x81fc408] [get_hal_udi_for_player] rb-generic-player-source.c:1365: parent of udi /org/freedesktop/Hal/devices/volume_uuid_F43C_C817: /org/freedesktop/Hal/devices/storage_serial_SanDisk_Sansa_Clip_4GB_ED0FFF0E3904B5870000000000000000_0_0
(15:31:03) [0x81fc408] [rb_generic_player_is_mount_player] rb-generic-player-source.c:829: Checking udi /org/freedesktop/Hal/devices/storage_serial_SanDisk_Sansa_Clip_4GB_ED0FFF0E3904B5870000000000000000_0_0
(15:31:03) [0x81fc408] [rb_generic_player_is_mount_player] rb-generic-player-source.c:837: device cannot be accessed via storage
(15:31:03) [0x81fc408] [free_dbus_error] rb-generic-player-source.c:1395: checking device access method: dbus error: No property portable_audio_player.access_method on device with id /org/freedesktop/Hal/devices/storage_serial_SanDisk_Sansa_Clip_4GB_ED0FFF0E3904B5870000000000000000_0_0
(15:31:03) [0x81fc408] [rb_removable_media_manager_add_mount] rb-removable-media-manager.c:654: Unhandled media
(15:31:03) [0x81fc408] [load_uri_args] main.c:368: examining argument file:///media/SANSA%20CLIP
(15:31:03) [0x81fc408] [local_load_uri] main.c:422: Using load_uri for file:///media/SANSA%20CLIP
(15:31:03) [0x81fc408] [rb_uri_could_be_podcast] rb-file-helpers.c:341: 'file:///media/SANSA%20CLIP' can't be a Podcast or OPML file, not the right scheme
(15:31:03) [0x81fc408] [rb_shell_load_uri] rb-shell.c:3329:...

Read more...

Ryan Fugger (rfugger) wrote :
Sebastien Bacher (seb128) wrote :

the log is useful and the issue is that it doesn't figure what access_method is used for the device, this svn change is likely to fix the bug you are having http://svn.gnome.org/viewvc/rhythmbox?view=revision&revision=5992, do you know how to rebuild a modifier package to try a change?

Changed in rhythmbox:
status: Incomplete → Fix Committed
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Ryan Fugger (rfugger) wrote :

I basically followed the directions at:

http://ubuntuforums.org/showthread.php?t=200762

applying the patch from the svn revision link above, installed the new package, and my player now shows up in rhythmbox. Thanks for your help.

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

intrepid-proposed package copied to jaunty.

Changed in rhythmbox:
status: Fix Committed → Fix Released
Ryan Fugger (rfugger) wrote :

Package in intrepid-proposed (0.11.6svn20081008-0ubuntu4.2) works OK for me.

Latest intrepid proposed (0.11.6svn20081008-0ubuntu4.2) fixed the bug for me as well (Creative ZEN Stone 1 GB)

Sorry for opening a duplicate bug, I did not search well in the existing ones.

Saivann Carignan (oxmosys) wrote :

Call me Ishmael : No, thank You for reporting your bugs. Your contribution is appreciated, and you can't find the right one every time ;)

Martin Pitt (pitti) wrote :

Copied to intrepid-updates.

Changed in rhythmbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers