Rhythmbox doesn't work well when I move the time slider several times

Bug #291556 reported by Ricardo Pérez López on 2008-10-31
2
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Steps to reproduce:

1. Open Rhythmbox.
2. Play a song. The song starts to play.
3. Move the time slider for around the middle of the song.
4. Again, move the time slider to another point.

Expected behavior: Rhythmbox starts to play the song from the point lastly selected on the slider.

Actual behavior: The song continues to play without been affected by the slider movement. After several slider movements, Rhythmbox crashes.

Sometimes I need to do that several times in order to get the fail.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.11.6svn20081008-0ubuntu4
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.27-7-generic i686

Ricardo Pérez López (ricardo) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a '.crash' file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

 If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

 If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

 If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.
 I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Invalid
Ricardo Pérez López (ricardo) wrote :

Thanks for your response, Sebastien. However, I'm unable to get Apport works. When Rhythmbox fails, its window get unresponsive (the window fades to grey, I'm using Compiz). I can only do one thing: to click on the Close window button, but when I do that, the window closes and nothing more happens.

Sebastien Bacher (seb128) wrote :

could you use gdb to get a stacktrace as explained on http://wiki.ubuntu.com/DebuggingProgramCrash?

Ricardo Pérez López (ricardo) wrote :

Backtrace using gdb.

Ricardo Pérez López (ricardo) wrote :

Reopened.

Changed in rhythmbox:
status: Invalid → New
Ricardo Pérez López (ricardo) wrote :

Strace output.

description: updated
description: updated
Sebastien Bacher (seb128) wrote :

do you use the crossfading option? does not using it workaround the issue?

Changed in rhythmbox:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

the issue is similar to bug #270700

Absolutely yes, Sebastien. I'm using the crossfading option. When I disable it, I can't reproduce the problem.

Sebastien Bacher (seb128) wrote :

closing as duplicate

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers