Rhythmbox freezes while seeking with crossfading backend enabled

Bug #284564 reported by Claudio de Oliveira on 2008-10-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Invalid
Unknown
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

After installing and upgrading the new Intrepid on my laptop, I tried to listen some FLAC songs with gapless playback (crossfading backend) enabled.

Playback works fine until I try so seek songs clicking on the time slider with mouse. If I do this, Rhythmbox simply jumps to the next song of, even more common, simply freezes.

Steps to reproduce this bug:

1) Open Rhythmbox and load some songs (I've tried only FLAC files);
2) Play one file;
3) Click the time slider to advance.

This is my first bug reporting here on Launchpad, sorry if I can't describe this bug in a better way.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.11.6svn20081008-0ubuntu3
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.27-7-generic x86_64

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Jef (jef-v) wrote :

I am also affected by this bug, not with FLAC files only, but alos with MP3, OGG. Rhythmbox freezes when I use the seek slider bar.

When cross-fade is disabled, there is no problem anymore.

Jef (jef-v) wrote :

I could not reproduice the freeze during backtrace recording. However, when I used the seek slider bar, the track jump at the correct time in the song but the slider became unresponsive :

- using the slider did nothing anymore
- the song time progression text on the right feezes

but, no freezing of the interface, jumping to the next track make rhythmbox working correctly again (until I use the slider bar)

Backtrace here included.

WillDyson (will-dyson) wrote :

I'm seeing this too. It is especially wonky on GVFS network files.

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in rhythmbox:
status: Incomplete → Fix Released
Changed in rhythmbox:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.