spaces are replaced by %20 when extract CD

Bug #282275 reported by Christian Göbel on 2008-10-12
2
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Testing intrepid I ran into the following bug that I observed when using rhythmbox to extract a music CD:
All the spaces in the Title, Song-title and so on are replaced by %20.
Example:
I the Musician is called: "Manu Chao" the corresponding folder will be namend: "Manu%20Chao".
This seems to be a regression compared to Hardy where this bug did no occur.

To reproduce:
a) insert a music CD
b) open rhythmbox
c) select extract
d) open /home/yourname/music to see that all spaces are replaced by %20 (also in subfolders) for the newly
extracted CD.

By the way: If you Choose Edit/Preferences/Music and you look at the example path then you should also see
that the spaces are replaced by %20.

I am using
rhythmbox
Version: 0.11.6svn20081008-0ubuntu2

Keep up the good work.
Christian

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the issue is known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=555767

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in rhythmbox:
status: Triaged → Fix Committed
Changed in rhythmbox:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.6svn20081008-0ubuntu3

---------------
rhythmbox (0.11.6svn20081008-0ubuntu3) intrepid; urgency=low

  * debian/patches/90_upstream_change_correct_cd_copy_naming.patch:
    - upstream svn change to fix filenames when copying cd songs (lp: #282275)

 -- Sebastien Bacher <email address hidden> Wed, 15 Oct 2008 10:13:23 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.