Cannot use playlists with files which are stored in a NFS mount

Bug #28205 reported by Mikael Olenfalk on 2006-01-08
18
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

I have a 55G MP3 NFS mount to my fileserver, when I create a new playlist and
drag'n'drop files from the Library into the playlist; the playlist get's
populated as expected and I can play my songs from the playlist.

When I restart rhythmbox, the UI freezes (bug#28204), while rhythmbox is
checking all my files in the library. After the UI has loaded; all my playlists
are empty; probably because the files in the playlists didn't exist at the time
when the playlists were loaded (I'm speculating here) but rather loaded later
during startup.

For now I am using smart playlists instead; which is somewhat crippling, when
you want to simulate a normal playlist.

This is rhythmbox version 0.9.2

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Is your NFS shared monted when you restart rhythmbox?

Changed in rhythmbox:
status: Unconfirmed → Needs Info
Sebastien Bacher (seb128) wrote :

No reply, bug closed. Feel free to reopen if you still get the issue

Changed in rhythmbox:
assignee: seb128 → desktop-bugs
status: Needs Info → Rejected

hmm, sorry I somehow missed the email with your reply; I will retest this at home and reopen if the problem still applies.

Btw, the NFS was mounted at the time I start Rhythmbox

Leon van der Ree (lvanderree) wrote :

I think I have a similar problem with rhythmbox in Gutsy.

Rhythmbox contains songs in its library from a mounted NFS share. Whenever I start Rhythmbox it is scanning all songs, and I can see them being added to the library, meanwhile I can search and play songs, but after some time the userinterface of Rhythmbox hangs, while the current playing song still continues to play. If this songs has ended Rhythmbox is (still) completely frozen.

Strange thing is, that if I start Rhythmbox with the argument -d (to show debug-output) it does not hang... (but it is considerably slower)

I haven't try to run gdm or anything on it, but if this can be useful please ask me.

Leon van der Ree (lvanderree) wrote :

I think I have a similar problem, see below

Changed in rhythmbox:
status: Invalid → New
Basilio Kublik (sourcercito) wrote :

Hi Leon
Could you please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Thanks in advance

Leon van der Ree (lvanderree) wrote :

Sorry I ment gdb of course, not gdm ;)

But I've done so, and rhythmbox again hang.

I've breaked the application in gdm when it hang.

Attached the output

I have a similar, but not identical, problem. I hope it's OK to post to the same bug report.

I also have an NFS mount with music files. I can play the files in Totem, Amarok, etc. But when I point my Rhythmbox library to the mount point, I only get errors under the "Import errors" tab:
Can't access file:///home/martin/Music/music%20on%20undertow/Mr%20Bungle/Backstrokin.mp3
... etc.

Does rhythmbox need write permission? Or could it be a problem with symlinks or spaces in file names? Or something else?

In my case, "/home/martin/Music/music on undertow" is a symlink to "/mnt/My Documents/My Music", and my NFS share is mounted at /mnt.

Basilio Kublik (sourcercito) wrote :

Hi there
Unfortunately the gdb log doesn't show much information due the fact that the packages containing the debugging symbols aren't installed, if you could install those packages and obtain a new backtrace,it would be of great help, this if you don't already have a related .crash file at /var/crash, case in which the preferred method is follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retarcer.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.
If you are using Kubuntu or Xubuntu you can file the crash using "/usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash" in a terminal - where _my_crash_report.crash is the crash you would like to report.

Thanks in advance.

Changed in rhythmbox:
status: New → Invalid
Basilio Kublik (sourcercito) wrote :

Martin
Could you please check if the problem remains when you import the files directly from /mnt instead of using a symlink?, i also use a NFS share to store my music files and don't have any issue, the write permission should only be needed when edit song tags or similar operations.

Thanks in advance

Changed in rhythmbox:
status: Invalid → Incomplete
Basilio Kublik (sourcercito) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thanks again!

Changed in rhythmbox:
assignee: desktop-bugs → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.