[SRU] unable to copy music from an MTP device

Bug #270777 reported by Saivann Carignan on 2008-09-16
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
kdepim (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Intrepid
Low
Ubuntu Desktop Bugs

Bug Description

Current rhythmbox in intrepid is unable to copy/read music from my MTP player. It is still able to list the content of my MTP device and to detect/eject the device but not to transfer music from device.

This is a regression that cause ubuntu users to suddenly be unable to use their music device in intrepid while it worked perfectly in gutsy and hardy.

This regression has been fixed in current rhythmbox trunk and the proposed patch import upstream fix to ubuntu. Since it only fix bad path and URI functions in rb-mtp-source.c, it cannot introduce other important regression in rhythmbox itself and it is very unlikely to cause regression in mtp plugin as well.

TEST CASE :

1. Open rhythmbox (if not enabled, enabled MTP plugin in plugins options).
2. Plug your MTP music device.
3. Try to copy one music file from your device to your music library.

Related branches

description: updated
Sebastien Bacher (seb128) wrote :

thank you for your bug report, I don't confirm this issue on my intrepid installation. could you get a rhythmbox --debug log? are you sure the device is not mounted by gvfs or an another software?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Saivann Carignan (oxmosys) wrote :

Running rhythmbox with --debug does not seem to give more information, still only the same warning about free space in /tmp appears in the --debug log at the moment I try to copy a music file from the MTP device.

However, I just found that it's still possible to copy one music from the computer to the MTP device, the only thing that doesn't work is copying to the computer, and it looks like it is caused by rhythmbox which is not able to write in /tmp folder. However I don't see why it is not able because I can do it without being root and /tmp permissions are the same as they were at initial installation.

The device is not mounted anywhere before rhythmbox start communicating with it. My MTP device shows a big icon when the computer is connected, and when there is communication with the computer and I only see that icon when rhythmbox starts.

Might or might not be related : rhythmbox used to work perfectly in the last weeks, but after some updates, MTP plugin was suddenly disabled. I re-enabled it, and since this I have this bug.

Saivann Carignan (oxmosys) wrote :

I was able to reproduce this problem on my laptop which is a clean intrepid alpha 5 install with all updates installed, so I doubt that this is something like a configuration problem. This laptop really has default ubuntu settings. Also, I'm able to access my MTP device without problems through gnomad2, so the device isn't the problem either.

Saivann Carignan (oxmosys) wrote :

The problem is reproducible directly in the intrepid alpha 5 LiveCD. Under hardy, Rhythmbox MTP plugin works perfectly.

Sebastien Bacher (seb128) wrote :
Changed in rhythmbox:
status: Incomplete → Triaged
Changed in rhythmbox:
status: Unknown → New
Brian Murray (brian-murray) wrote :

I tried this today using rhythmbox version 0.11.6svn20081008-0ubuntu3 and received a different error message:

wonderwoman:[~] rhythmbox
PTP: Opening session

(rhythmbox:26860): Rhythmbox-WARNING **: filesystem root apparently doesn't exist!

Martijn vdS (martijn) wrote :

It works for me, using a Samsung YP-U3, and rhytmbox 0.11.6svn20081008-0ubuntu3

When I try to play a song from the MPT device (zen vision M:) by adding it to the play que first, I see the following message (when rhythmbox is started through terminal:

(rhythmbox:16173): Rhythmbox-CRITICAL **: rb_player_gst_play: assertion `mp->priv->playbin != NULL' failed

When I try to transfer a song from MTP to /home folder, the progress bar gets stuck at 0%.
At my /home/music folder, a folder for Artist and a subfolder for Album are created, but no file is actually transfered.

Brian Murray (brian-murray) wrote :

I'm closing the kdepim task for this bug report since it seems to have been added in error.

Changed in kdepim:
status: New → Invalid
Saivann Carignan (oxmosys) wrote :

Ubuntu sponsor for main : Attached debdiff contains upstream fix for this bug released in today revision. Can you review and upload the patch before Intrepid Final Release?

Changed in rhythmbox:
milestone: none → ubuntu-8.10
Steve Langasek (vorlon) wrote :

suitable for SRU; not a blocker for final release.

Changed in rhythmbox:
milestone: ubuntu-8.10 → intrepid-updates
Saivann Carignan (oxmosys) wrote :

Steve Langasek : Should I use standard SRU procedure [1] or what I've done so far is enough for this bug?

[1] https://wiki.ubuntu.com/StableReleaseUpdates

Sebastien Bacher (seb128) wrote :

the bug needs to be updated to conform to the sru rules, if you don't do it somebody else will have to do the update

description: updated
Saivann Carignan (oxmosys) wrote :
Martin Pitt (pitti) wrote :

Sponsored upload, in intrepid-proposed queue now. Thanks!

Changed in rhythmbox:
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox:
milestone: intrepid-updates → none
status: In Progress → Fix Committed
Saivann Carignan (oxmosys) wrote :

I tested rhythmbox_0.11.6svn20081008-0ubuntu4.1 and the bug isn't reproducible anymore. I see no regression and it's possible to copy to/from the device without any problem.

Brian Murray (brian-murray) wrote :

Using rhythbox_9.11.6svn20081008-0ubuntu4.1 I was still unable to copy music from an MTP device (a Creative Zen Microphoto) to my system. Here is the hopefully relevant output of 'rhythmbox -d':

(09:55:16) [0x1228500] [impl_paste] rb-library-source.c:1236: pasting entry rb-mtp-455195
(rhythmbox:7515): Rhythmbox-WARNING **: filesystem root apparently doesn't exist!
(09:55:16) [0x1228500] [rb_shell_transfer_progress_cb] rb-shell.c:1890: transferred 0 tracks out of 1
(09:55:16) [0x1228500] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '1155 songs, 3 days, 17 hours and 11 minutes, 7.3 GB', '', 999.000000
(09:55:19) [0x1228500] [attach_output_pipeline] rb-encoder-gst.c:613: gio can't write to /home/bdmurray/Music/Propellerheads/Wipeout%20(PSX)/00%20-%20Lethal%20Cut.b-mtp-455195, so using whatever sink will work

(rhythmbox:7515): GStreamer-CRITICAL **: gst_element_make_from_uri: assertion `gst_uri_is_valid (uri)' failed
(09:55:19) [0x1228500] [error_cb] rb-removable-media-manager.c:990: Error transferring track to /home/bdmurray/Music/Propellerheads/Wipeout%20(PSX)/00%20-%20Lethal%20Cut.b-mtp-455195: Could not create a GStreamer sink element to write to /home/bdmurray/Music/Propellerheads/Wipeout%20(PSX)/00%20-%20Lethal%20Cut.b-mtp-455195
(09:55:19) [0x1228500] [rb_encoder_gst_emit_completed] rb-encoder-gst.c:213: couldn't get size of destination /home/bdmurray/Music/Propellerheads/Wipeout%20(PSX)/00%20-%20Lethal%20Cut.b-mtp-455195: Operation not supported
(09:55:19) [0x1228500] [completed_cb] rb-removable-media-manager.c:1012: completed transferring track to /home/bdmurray/Music/Propellerheads/Wipeout%20(PSX)/00%20-%20Lethal%20Cut.b-mtp-455195 (0 bytes)
(09:55:19) [0x1228500] [rb_shell_transfer_progress_cb] rb-shell.c:1890: transferred 1 tracks out of 1
(09:55:19) [0x1228500] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '1155 songs, 3 days, 17 hours and 11 minutes, 7.3 GB', '', 999.000000
(09:55:19) [0x1228500] [rb_shell_transfer_progress_cb] rb-shell.c:1890: transferred 0 tracks out of 0
(09:55:19) [0x1228500] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '1155 songs, 3 days, 17 hours and 11 minutes, 7.3 GB', '', 999.000000

(rhythmbox:7515): Rhythmbox-CRITICAL **: rb_encoder_gst_emit_completed: assertion `encoder->priv->completion_emitted == FALSE' failed
(09:55:19) [0x1228500] [rb_audioscrobbler_should_handshake] rb-audioscrobbler.c:820: No username set
(09:55:19) [0x1228500] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '1155 songs, 3 days, 17 hours and 11 minutes, 7.3 GB', '', 999.000000
(09:55:19) [0x1228500] [window_focus_cb] rb-mmkeys-plugin.c:142: window got focus, re-grabbing media keys
(09:55:21) [0x1228500] [window_focus_cb] rb-mmkeys-plugin.c:142: window got focus, re-grabbing media keys

Martin Pitt (pitti) wrote :

Copied intrepid-proposed version to jaunty.

Changed in rhythmbox:
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Testing again with rhythmbox version 0.11.6svn20081008-0ubuntu4.1 from Intrepid -proposed, after installing saivann's ppa version of rhythmbox and downgrading back to -proposed, I am able to copy files from my MTP device to my system. I consider the verification of the SRU to have passed.

dieterv (dieterv77) wrote :

I also installed the rhythmbox package from the proposed repository and verified that i'm able to play music from the mtp device, but i can't copy from the device to the computer. When i run with --debug, i get error messages very similar to those shown by Brian Murray above. I tried doing a purge/reinstall but that didn't make a difference.

This feature is not critical to me but i thought it might be helpful to have someone else testing. thanks to everyone involved in getting the proposed package uploaded.

Saivann Carignan (oxmosys) wrote :

dieterv : Are you sure that you are using the good version? What is the output of this command in a terminal? apt-cache policy rhythmbox

Saivann Carignan (oxmosys) wrote :

dieterv : Can you also make sure that your system is up to date? Specifically libmtp8

dieterv (dieterv77) wrote :

I did not check if there is a libmtp8 update in proposed, if so that could be the issue.

apt-cache policy output:
rhythmbox:
  Installed: 0.11.6svn20081008-0ubuntu4.1
  Candidate: 0.11.6svn20081008-0ubuntu4.1
  Version table:
 *** 0.11.6svn20081008-0ubuntu4.1 0
        100 /var/lib/dpkg/status
     0.11.6svn20081008-0ubuntu4 0
        500 http://hoegaarden intrepid/main Packages

libmtp8:
  Installed: 0.3.0-1ubuntu1
  Candidate: 0.3.0-1ubuntu1
  Version table:
 *** 0.3.0-1ubuntu1 0
        500 http://hoegaarden intrepid/main Packages
        100 /var/lib/dpkg/status

Saivann Carignan (oxmosys) wrote :

dieterv : You have latest versions, and if the rest of your system is up to date, I wonder where is the problem. Can you also post the outputs that you get in the terminal when running rhythmbox?

dieterv (dieterv77) wrote :

Here's what i see in the console (when running with --debug) after trying to drag something from the mtp device to my library :
(07:27:38) [0x8452408] [drop_received_cb] rb-sourcelist.c:550: drop recieved
(07:27:38) [0x8452408] [impl_receive_drag] rb-library-source.c:693: parsing uri list
(07:27:38) [0x8452408] [impl_paste] rb-library-source.c:1236: pasting entry rb-mtp-173

(rhythmbox:14283): Rhythmbox-WARNING **: filesystem root apparently doesn't exist!
(07:27:38) [0x8452408] [rb_shell_transfer_progress_cb] rb-shell.c:1890: transferred 0 tracks out of 1
(07:27:38) [0x8452408] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '2563 songs, 7 days, 6 hours and 16 minutes, 9.5 GB', '', 999.000000
(07:27:40) [0x8452408] [attach_output_pipeline] rb-encoder-gst.c:613: gio can't write to /home/dvandenbussche/Music/16%20Horsepower/16%20Horsepower%20EP/01%20-%20Haw.b-mtp-173, so using whatever sink will work

(rhythmbox:14283): GStreamer-CRITICAL **: gst_element_make_from_uri: assertion `gst_uri_is_valid (uri)' failed
(07:27:40) [0x8452408] [error_cb] rb-removable-media-manager.c:990: Error transferring track to /home/dvandenbussche/Music/16%20Horsepower/16%20Horsepower%20EP/01%20-%20Haw.b-mtp-173: Could not create a GStreamer sink element to write to /home/dvandenbussche/Music/16%20Horsepower/16%20Horsepower%20EP/01%20-%20Haw.b-mtp-173
(07:27:40) [0x8452408] [rb_encoder_gst_emit_completed] rb-encoder-gst.c:213: couldn't get size of destination /home/dvandenbussche/Music/16%20Horsepower/16%20Horsepower%20EP/01%20-%20Haw.b-mtp-173: Operation not supported
(07:27:40) [0x8452408] [completed_cb] rb-removable-media-manager.c:1012: completed transferring track to /home/dvandenbussche/Music/16%20Horsepower/16%20Horsepower%20EP/01%20-%20Haw.b-mtp-173 (0 bytes)
(07:27:40) [0x8452408] [rb_shell_transfer_progress_cb] rb-shell.c:1890: transferred 1 tracks out of 1
(07:27:40) [0x8452408] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '2563 songs, 7 days, 6 hours and 16 minutes, 9.5 GB', '', 999.000000
(07:27:40) [0x8452408] [rb_shell_transfer_progress_cb] rb-shell.c:1890: transferred 0 tracks out of 0
(07:27:40) [0x8452408] [rb_statusbar_sync_status] rb-statusbar.c:474: updating status with: '2563 songs, 7 days, 6 hours and 16 minutes, 9.5 GB', '', 999.000000

Saivann Carignan (oxmosys) wrote :

dieterv : What happens if you boot ubuntu 8.10 final release Live CD, update rhythmbox to 0.11.6svn20081008-0ubuntu4.1 and try to reproduce the bug again. Does that works?

Sebastien Bacher (seb128) wrote :

the issue could be due to an incorrect library location

Martin Pitt (pitti) wrote :

Copied to intrepid-updates, it was confirmed to work for some people.

Changed in rhythmbox:
status: Fix Committed → Fix Released
dieterv (dieterv77) wrote :

Saivann, i tried your suggestion and used the live cd and everything seemed to work fine.
I guess maybe one of these days i ought to do a clean install...

thanks and sorry for the trouble.

dieter

Saivann Carignan (oxmosys) wrote :

dieterv : No, thank YOU very much for your testing ;)

Hi, after upgrade from 8.04 to 8.10 rhythmbox does not longer shows my creative zen 1 GB when I plug It. The devices is correctly mounted by gnome, i can see the icon on the desktop and I get prompted if I want to open rhythmbox.

Is this a different bug or still related with this one?
Btw, I installed today's (nov 6th) updates, but no luck.

Thanks.

ps: if you need some debugging info,please let me know

Saivann Carignan (oxmosys) wrote :

Call me Ishmael : Indeed, this is a different bug since rhythmbox does not detect even seem to detect your device, which is a different behavior then the one described in this bug report. BTW, do you still have "MTP plugin" enabled in rhythmbox options? If yes, can you open a new bug report for rhythmbox? Thanks for your feedback!

Hi Saïvann
After the release upgrade MTP was not checked (it was in the 8.04, because I used rhythmbox to transfer files to the player)
I checked it but the Creative Zen is not detected. I have a 30GB Ipod (5th gen), which is correctly handled even in 8.10, but I know is taken by another plugin.
I'll file a new bug report, thanks!

Update, I found out that the bug has been already open: Bug #270203.
A fix has been already released but did not work for some guys, neither worked for me.
Let's wait :-)

Saivann Carignan (oxmosys) wrote :

Call me Ishmael : Mmh, bug #270203 status is set to fix released, I think you'd better open a new bug report with a mention about bug #270230 in your bug description. Also, the outputs of these commands in a terminal might be useful in that case :

lsusb
apt-cache policy rhythmbox

If I was you, I would also try to umount your MTP device before trying to access it through rhythmbox, just in case, because in my case, my MTP device is not mounted by GNOME and rhythmbox is the first thing that really communicates with it. In case you open a new bug report, please subscribe me (saivann) to the bug so I can maybe help you looking at this further. Thanks for your feedback!

Changed in rhythmbox:
status: New → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.