When connecting a portable player, RB should show its contents

Bug #270203 reported by David Prieto on 2008-09-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

I'm using the latest RB version on Intrepid. Whenever I plug in my portable mp3 player (creative zen stone plus) I get a dialogue asking me whether I want to open it in nautilus, in rhythmbox or do something else. If I choose to open it with RB, it launches the program but the music library -rather than the contents of the player- is shown.

If you opened RB because you connected a player, you probably want to listen to what you have on the player. So, it would make sense to show the contents of the player straight away.

Related branches

Sebastien Bacher (seb128) wrote :

thank you for your bug report, the bug is already fixed in the upstream svn and will be fixed in intrepid on next update

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Fix Committed
importance: Low → Medium
status: Fix Committed → Triaged
importance: Medium → Low
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.6svn20080916-0ubuntu1

---------------
rhythmbox (0.11.6svn20080916-0ubuntu1) intrepid; urgency=low

  * New upstream snapshot:
    - correctly select the device which triggered the rhythmbox start
      (lp: #270203)
    - don't try to import the portable player mountpoint to the library
      (lp: #270201)
    - convert the podcast download directory to an uri if required
      (lp: #268608)

 -- Sebastien Bacher <email address hidden> Tue, 16 Sep 2008 17:08:00 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Tarek Loubani (tareko) wrote :

I am currently using 0.11.6, and still experience this problem.

It actually does *not* seem to me that the music is imported, but rather that no action is taken at all.

In previous versions of RB, it used to be that the music player would be below. This no longer seems to be the case.

tarek : )

Tarek Loubani (tareko) wrote :

reopened, as still present

Changed in rhythmbox:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

the bug has not been fixed in 0.11.6 but in the svn snapshots which are in intrepid, don't reopen the bug

Changed in rhythmbox:
status: Confirmed → Fix Released
Call me Ishmael (callmeishmael) wrote :

Hi,
Ubuntu Intrepid with latest updates. I have a creative ZEN Stone (1 GB) not being shown in the RB tree. Gnome shows it in the desktop, ask whether I want to launch RB, and from Nautilus I can browse the device as usual.
Nevertheless I can't manage to have it shown and handled in RB. In 8.04 it worked just out of the box.
I have 0.11.6 version installed, if I understand well this version is still broken.
Do you know then the fixed version is expected to be released in the updates?
Thanks in advance

Call me Ishmael (callmeishmael) wrote :

If this can help:

apt-cache policy rhythmbox:
rhythmbox:
  Installato: 0.11.6svn20081008-0ubuntu4.1
  Candidato: 0.11.6svn20081008-0ubuntu4.1
  Tabella versione:
 *** 0.11.6svn20081008-0ubuntu4.1 0
        500 http://archive.ubuntu.com intrepid-updates/main Packages
        100 /var/lib/dpkg/status
     0.11.6svn20081008-0ubuntu4 0
        500 http://archive.ubuntu.com intrepid/main Packages

lsusb:
Bus 007 Device 005: ID 041e:4154 Creative Technology, Ltd
Bus 007 Device 004: ID 04f2:b015 Chicony Electronics Co., Ltd
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 0a5c:2101 Broadcom Corp. A-Link BlueUsbA2 Bluetooth
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 08ff:2580 AuthenTec, Inc. AES2501 Fingerprint Sensor
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 04d9:0499 Holtek Semiconductor, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Saivann Carignan (oxmosys) wrote :

Thanks for your feedback on this. In my case, my MTP device is not automatically mounted by nautilus and I can't browse it before opening rhythmbox. What happens if you umount the MTP device before opening rhythmbox? Because if the MTP device is still mounted and used by nautilus, that sounds logical that rhythmbox won't be able to communicate with the device.

Changed in rhythmbox:
status: Fix Released → Incomplete
Sebastien Bacher (seb128) wrote :

don't reopen a closed bug because you have a similar issue

Changed in rhythmbox:
status: Incomplete → Fix Released

I did not reopen the bug.
Just asking wheter I have to file a new bug or wait for an already planned fix.

Saivann Carignan (oxmosys) wrote :

Call me Ishmael : Since you reproduce a bug and that the current one seems fixed, filing a new bug report would be the most appropriate option here.

Ok, I'll file a new bug, just I wanted to be sure in order to avoid unnecessary bug duplication.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers