rhythmbox crashed with SIGSEGV in dbus_connection_dispatch()

Bug #263268 reported by Hew on 2008-08-31
38
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

I chose the eject option for my iPod on the gnome desktop. Rhythmbox was open and playing a song from my library (not the iPod). It mustn't have liked the iPod being ejected without being ejected from within rhythmbox first.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.6svn20080807-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: rhythmbox
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 ?? ()
 ?? ()
 dbus_connection_dispatch (connection=0xf20610)
 ?? ()
 IA__g_main_context_dispatch (context=0xcdba60)
Title: rhythmbox crashed with SIGSEGV in dbus_connection_dispatch()
Uname: Linux 2.6.27-2-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare vboxusers video

Related branches

Hew (hew) wrote :

StacktraceTop:g_proxy_volume_update (volume=0x7f580c7df890, iter=<value optimized out>)
filter_function (connection=<value optimized out>, message=0xe4dd90,
dbus_connection_dispatch (connection=0xf20610) at dbus-connection.c:4406
dbus_source_dispatch (source=<value optimized out>,
IA__g_main_context_dispatch (context=0xcdba60)

Changed in rhythmbox:
importance: Undecided → Medium
Hew (hew) wrote :

Confirmed by the dupe. I also triggered this crash again, and this time it had a stacktrace starting with strcmp() (like bug 263471).

Changed in rhythmbox:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issue is a gvfs one and known upstream you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=546971

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.6svn20080903-0ubuntu1

---------------
rhythmbox (0.11.6svn20080903-0ubuntu1) intrepid; urgency=low

  * New upstream snapshot:
    - doesn't crash when eject an audio player (lp: #263268)
  * debian/patches/80_new_libmtp_build.patch:
    - the change is in the new version
  * debian/rules:
    - don't specify a gecko variant that's not required in the new version

 -- Sebastien Bacher <email address hidden> Wed, 03 Sep 2008 10:54:50 +0200

Changed in rhythmbox:
status: Triaged → Fix Released
Changed in gvfs:
status: Unknown → Fix Released
Changed in gvfs:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.