rhythmbox crashed with SIGSEGV in g_slice_alloc()

Bug #262466 reported by Richard Eames on 2008-08-29
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

After trying to unpause rhythmbox via my multimedia keys it took up 100% of one of my CPUs before crashing. Could be related to another bug I posted: #259602

I'll try getting a Valgrind again.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.6svn20080807-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: rhythmbox
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 g_slice_alloc () from /usr/lib/libglib-2.0.so.0
 g_array_sized_new () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgstreamer-0.10.so.0
 gst_structure_copy ()
 gst_caps_copy ()
Title: rhythmbox crashed with SIGSEGV in g_slice_alloc()
Uname: Linux 2.6.26-5-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

Richard Eames (naddiseo) wrote :
Richard Eames (naddiseo) wrote :

StacktraceTop:IA__g_array_sized_new (zero_terminated=0, clear=1149307440, elt_size=516302660,
gst_structure_id_empty_new_with_size (quark=3045, prealloc=5) at gststructure.c:119
gst_structure_copy (structure=0x26bc430) at gststructure.c:289
gst_caps_copy (caps=0x265df80) at gstcaps.c:276
gst_caps_subtract (minuend=0x1, subtrahend=0x12ee4c0) at gstcaps.c:1363

Changed in rhythmbox:
importance: Undecided → Medium
Changed in rhythmbox:
status: New → Triaged
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Triaged → Incomplete
tails2k (tails2k) wrote :

i think this is fixed, i dont know what it is sorry. i think this was a problem with pulse audio and the audigy card. now i have no problem with it

Richard Eames (naddiseo) wrote :

I agree, I think it's been fixed along the way. I haven't experienced it recently, I guess I can reopen if I experience it again.

Sebastien Bacher (seb128) wrote :

closing since that works correctly now

Changed in rhythmbox:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers