Song drag to playlist does not scroll playlist if on automatic playlist

Bug #258615 reported by Matthew Woerly on 2008-08-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Expired
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When you drag a song to a playlist, it adds it to that playlist. If the playlist that you're looking for is further down or up the list, dragging the song to the top or bottom automatically scrolls the list. But this doesn't happen if the song at the top or bottom is an automatic playlist. Since it won't let you add the song to it, I guess it doesn't register for the scroll to happen.

Ubuntu 8.04
Rhythmbox 0.11.5-0ubuntu8

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?

 This will help us to find and resolve the problem.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox:
status: Incomplete → Invalid
Matthew Woerly (nattgew) wrote :

Add some automatic playlists to your list. You may want to add some non-automatic ones above and below them. The idea is to have some automatic playlists at the bottom of the window, and not have it scrolled all the way to the bottom. Drag a song to the playlist pane. If you have a regular playlist at the bottom, it will scroll down. If you have an automatic playlist at the bottom, it won't.
This may have changed with the new Rhythmbox in Intrepid, I'll have to check on that.

Matthew Woerly (nattgew) wrote :

This still happens to me in Intrepid. Since you can't add a song to an automatic playlist by dragging it, the left side will not scroll down when you drag a song over if an automatic playlist is the last one you can see.

Changed in rhythmbox:
status: Invalid → Incomplete
Pedro Villavicencio (pedro) wrote :

could you please tell us some easy steps in order to reproduce it? what you said worked fine here, thanks you.

Matthew Woerly (nattgew) wrote :

The problem is basically that unless the view has a simple playlist at the top or bottom (Music and Play Queue count too, since you can also drag to those), it will not scroll the sidebar for you. I'll see if I can get some kind of video of it.

Matthew Woerly (nattgew) wrote :

Ok, gtk-recordMyDesktop wouldn't drag and drop while it was recording, so I used Istanbul to record this.

Pedro Villavicencio (pedro) wrote :

Confirming on Jaunty, will look upstream, tanks you.

Changed in rhythmbox:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in rhythmbox:
status: Confirmed → Triaged
importance: Undecided → Unknown
status: New → Unknown
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
importance: Unknown → Medium
Changed in rhythmbox:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.