Ubuntu

Rhythmbox sort by "Album Artist" for guest/compilations

Reported by Steven McCoy on 2008-07-30
342
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Confirmed
Wishlist
rhythmbox (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

For guest artists on an album or compilations Apple allows definition of an album artist and artist for each track. Rhythmnbox only allows browsing by track artists so many artists appear listed with only one track.

Example, Red Book by Texas:

1. 036 - Texas
2. Getaway - Texas
3. Can't Resist - Texas
4. What About Us - Texas
5. Cry - Texas
6. Sleep - Texas featuring Paul Buchanan
7. Get Down Tonight - Texas
8. Nevermind - Texas
9. Bad Weather - Texas
10. Master Thief - Texas
11. Just Holding On - Texas
12. Red Book - Texas

The sixth track has artist "Texas featuring Paul Buchanan" whilst all others are "Texas".

I want to browse by album artist selecting "Texas" and seeing all 12 tracks on the album, not just the 11 that match.

Steven McCoy (fnjordy) on 2008-07-30
description: updated
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Invalid
Olli Savolainen (pilpi) wrote :

This is NOT a duplicate of bug #228422, since that bug deals with CD ripping. The solution for this bug is to change the UI to make sorting possible by primarily the artist and secondarily by the album name. That solution does not fix bug #228422.

Olli Savolainen (pilpi) wrote :

Correction: Primarily the artist and secondarily by the album name, or in the case of the original bug report, the other way around.

abssorb (abssorb) wrote :

This is definitely a different requirement to bug #228422.

This is about rhythmbox listing the tracks, not about ripping from CD. There is basic need lacking in rhythmbox to list by album artist. Listing by artist shows all the "one-hit-wonders" from compilation albums and it is a PITA.

Fix:

As is:
  Edit / Preferences / Browser views:
   Artists and albums
   Genres and artists
   Genres, artists and albums

Suggested:
  Edit / Preferences / Browser views:
   Artists and albums
   Genres and artists
   Genres, artists and albums
   Genres, album artist and albums << Need this

Why? I have a collection of about 300 CDs all ripped to my server. So, approx 200 artists that I'm actually interested in. But, trying to find my music, rhythmbox shows a list of over 1000 artists. 800 of them I would NEVER seek out to play. It's a real pain!
It gets worse with remixes, where an album artist does remixes, and so it's not a compilation but their own original work in collaboration. E.g. Paul Oakenfold "A lively mind". The Album artist is Paul Oakenfold, because he did the mixing and released the album. But, each artist who wrote the original before it was remixed is listed individually in the "artist" field. Now this is NOT a compilation album, but, trying to play the album can only be done by looking up the album name. So, If I want to play all Paul Oakefold's work back-to back, the only way is to use album artist. Or, corrupt my ID3 tags as a workaround. Which I don't want to do because it works perfectly on other players.

Simon Osborne (flibblesan) wrote :

Removed duplicate as it's not related.

Is anybody working on this? Seems a bit strange that the default music player for Ubuntu does not have the ability to sort by Album Artist via a column where as other music players such as Banshee do. It cannot be that difficult to do?

This is the only serious reason why I do not stick with Rhythmbox as my main music player. When your collection is organised as Artist/Album from music ripped from original CDs, this option is a must have in a music player. As soon as you have some compilations and movie soundtrack, it is absolutly impossible to browse your collection by song "artist" only. In this case, having a 3 columns browser with artistalbum|artist|album is essential because you can tag your compilations with Various Artists in "artistalbum".

Since the UI already allows a 3 column browser with genre|artist|album, it may possible to change the "genre" column for the "artistalbum" or simply add another browser option. I'm currently giving a serious try to Rhythmbox in Ubuntu 10.04. It is a great application and I love it. But without this, it it totaly unusable, considering how my collection is built.

Changed in rhythmbox (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Paul Fisher (thetorpedodog) wrote :

Reported a dupe.

Changed in rhythmbox:
status: Unknown → Confirmed
kashmlr (maximilian-strauch) wrote :

This sorting by artists is so silly! It doesnt make any sense to anyone. Banshee, exaile and many others do the same thing, so i just browse in nautilus to the folders and play files with totem. I hope this will be fixed soon! It would make also ubuntu appear better for new users, since music player are important for personal use of computers today!

Piedro Kulman (piedro) wrote :

This way of sorting is really a pain ....!
For people just buing single mp3s from common download locations the actual "browse by artist" works allright,
though even in this case you want to get rid of the various "featuring this guy or that guy"-stuff as appendix to the artist you want to look for.

if you, like me, are an album guy, then sorting by album artist gets mandatory for the reasons stated by the op.

I believe it should even be the default setting for the browser.
iTunes does it this way for many years now and there's a lot to say against Apple but they put a huge effort into researching the best usability. Still ALL linux music management programs ignore this albumartist issues.

I strongly believe rhythmbox (as banshee / exaile / gmpd ...) should sort by "album artist" by default (like iTunes does)
and offer an easy way (by clicking on the browserbar e.g.) to choose another criteria like "artist", "composer" (to be even more usable and less restrictive than iTunes!)

This can't be that hard to do!

thx for reading,
piedro

This is actually The Main Thing that bugs me about Rhythmbox.

The way I arrange my CDs or records, I split them up into two sections. One for single-artist albums (we'll call this Group A) and one for compilations (Group B). Within Group A, I alphabetize by album artist, then sort from oldest to newest within that. For Group B, I alphabetize by album name.

Rhythmbox is a great player, but it's very difficult to organize/access my music in any sort of satisfying way given the way it blends everything together. If I want to find a Group B album, I shouldn't have to sort through all of the mixed-in Group A album titles. Especially when I have a lot more single-artist albums than compilations. And when I'm looking for a Group A album, I shouldn't have to wade through a bunch of artists I don't really care about, but who only show up in the list because of one track on a compilation.

I think fixing this organization scheme would save a lot of people a lot of time and brain cells. It's also connected to an issue I have with Rhythmbox iPod management for which I'm about to open another bug.

Changed in rhythmbox:
importance: Unknown → Wishlist
mdshort (mdshort) wrote :

Any idea on when this might be fixed? This is a bug, not a feature! Any players worth their salt know how to sort by the "BAND" id3 tag (i.e. Album Artist)--it is an unspoken standard. Dealing with the thousands of artists in my 49.6GB collection is a nightmare, might as well use nautilus.

Piedro Kulman (piedro) wrote :

>> mdshort

You're right. Only thing you're wrong about: Not all the players use it. I don't know ANY linux player using the albumartist tag "correctly" or standard-like.

rhythmbox doesn't - and the developers don't even care commenting on this, the issue is up for years
banshee handles the tag, but you can't use it to browse your music - developers don't care at all, though reported many times
exaile - the same
mpd - still buggy on that
guayadeque - YEAH!, but still in beta and not working correctly on recognizing the tag within the various formats (well: it's a mess within the formats anyway!)

there are more, but I haven't found a singel player for ubuntu able to use the AlbumArtist tag efficiently and I have filed alot of bug and wishlist and forum threads - nobody really is answering to that issue ...

It's like touchning something that shouldn't be touched ...

I don't know it's frustrating ...
cya

Michael Rooney (mrooney) wrote :

Since there is a linked upstream bug, I'll set the status to Triaged!

summary: - Rhythmnbox sort by "Album Artist" for guest/compilations
+ Rhythmbox sort by "Album Artist" for guest/compilations
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Mac (andrew-xiion) wrote :

The lack of sort by album artist is an issue and it should be resolved. Is it a bug? Well, it bugs me to see Rythmbox list music the way it does. A bug it isn't, because it isn't a software / programming error. From the above it seems to be a feature missing from Rythmbox :-( Although, it is a small issue relating to user interface, definitely a missing feature. IMHO I think it is big enough to raise it as a bug, just because IT BUGS THE HELL OUT OF ME!!!! :-D

Piedro Kulman (piedro) wrote :

Does triaged mean there's anyone working on this?

Sry for posing a probably stupid question, but I'm trying to understand this whole bug/wishlist system ...

Adding to the subject:
It seems important to note that there should be a way of organizing the filesystem hierarchy exactly the same like by the OP intended also:

Within the options:
Folder hierarchy:
>> albumartist/album (not artist/album)

Otherwise the whole issue doesn't make sense consistently!

thx for reading, p.

description: updated
Piedro Kulman (piedro) wrote :

Is there anyone working on this? It seems to be just such a little thing to change as the folder hierarhy already can use "albumartist" so why still not the browser?

If you developers here for any reason do not want to add that feature at all plz at least inform us!

thx, piedro

Ryan (nailedshut) wrote :

I'm also waiting for this feature, please :(

I like this player very much, but for example, I just wanted to play an album by Suzanne Vega, so I went to "Suzanne Vega" then "Tried an Blue" ... but there is songs missing !!! Cause on some song the artist name is "Suzanne Vega ft ..." (but the Album Artist is only Suzanne Vega)

So an "Album Artist" feature would be great !!! , please,

Thanks.

Lukas W. (lukasw) on 2011-04-17
description: updated
Piedro Kulman (piedro) wrote :

Is anyone working on that?

Matt Alexander (mattalexxpub) wrote :

This is the upstream bug (Gnome):

https://bugzilla.gnome.org/show_bug.cgi?id=318579

Eduard Grebe (eduardgrebe) wrote :

I don't see how anyone used to iTunes could be expected to accept as poor a music manager as Rhythmbox as the default music library application in Ubuntu. It is essentially unchanged in the last five years and severely lacking in features. "Album artist" support is an excellent example.

Piedro Kulman (piedro) wrote :

You are right and it's the same with banshee also.

The same issue not resolved in

- rythmbox for around 4 years ...
- banshee for around 7 years ...

p.

Gergely Gombos (gombosg) wrote :

I don't get why it was necessary to change to Rythmbox... Banshee knows more, and this is a basic feature necessary for any music player.

Piedro Kulman (piedro) wrote :

THANKS TO ALL RHYTHMBOX DEVS!!!!

2.9.7 !!!! MORE FEATURES !!!!! BUT STILL IGNORANT TO USABILITY !!! IT'S YOUR PROJECT - IGNORE WHAT OTHERS THINK ...

srsly, I don't get why you devs don't take your users serious. Not even answering to a 4 year all inconvenience that's a complete showblocker for many users ... BUT MORE FEATURES ... doesn't look like a real hard thing to fix also ... it's just a configurable browser view !!! ... but you dev guys like to impress with NEW FEATURTES ... this bug here is too big a challenge, because devs can't think usability and like to show off ...

I don't care anymore, gratz for being part of ubuntu again, go on ignoring ... nice you use musicbrainz now ... a suggestion: PLZ DELETE ANY ALBUMARTIST IN THE TAGS ALSO - NOONE CAN COMPLAIN ANY LONGER OF HAVING NO OPTION FOR IT IN THE UI !!!! ...

p.

Sparhawk (sparhawkthesecond) wrote :

To reply to comment #13,

Nightingale (the Linux port of Songbird) allows sorting by album artist.

Piedro Kulman (piedro) wrote :

Quickly installed the new version ...

No I didn't really expect this bug to be fixed ... it's too fresh ... just about 5 years ... as it is 2.98 is still not usable for albums with one albun artist but some somngs with collaborations ...

Now there is musicbrainz lookup which makes it worse cause musicbrainz enters EVERY collaboration ... many albums now have more than one artist but are no compilation ...

whatever ... devs don't understand or don't care - why should I?
It was just 5 minutes installing and uninstalling again ... but I will set rhythmbox on the wishlist of Ubntu bugs to remove from Ubuntu ...

thx, piedro

So what's left to say? Silently waiting for somebody fixing this bug for more than 2 years now. Even willing to donate some fine amount just for fixing this bug but it doesn't seem as anyone is listening. (I haven't ever learned serious coding, I'd do it myself otherwise.) Maybe the devs could at least state a little comment why this bug is completely ignored for more than 4 years now? I'd absolutely appreciate!

Phillip G. (thedimmu) wrote :

It seems that the people from GNOME are not interested in implementing this feature. They ignore all the bugreports for several years now although this can't be very difficult to implement.

About half a year ago someone submittet a patch that looks interesting but until now nothing had changed.

https://bugzilla.gnome.org/show_bug.cgi?id=678706

Perhaps someone from Ubuntu could have a look at it and apply it for the Ubuntu users if it works.

Yalçın Can (yalcin.can) wrote :

#27

I can donate some bucks to that feature too. It's very annoying to see piles of single artist albums lying there.

Piedro Kulman (piedro) wrote :

Annoying to see that still nobody cares!

It's been 5 years now with this bug with no intent to change it by the devs - I don't use rhythmbox anymore for two years now.

I cannot understand the decision by Canonical to still feature this program:
it is unflexible, not lightweight in any way, buggy, not well maintained and devs don't even care to listen to their users!

I will suggest in the Ubuntu boards to drop the program again and replace it with clementine or guayadeque.

Congratz for 5 years of ignorance,
nice attitude dudes,
thx for reading,
piedro

fossfreedom (fossfreedom) wrote :

hmmm - we'll I'm particularly interested in this

If it helps - my plugin copes better with albums and sorting by album-artist. The plugin takes into account the album-artist field if its filled.

I would welcome feedback, thoughts - patches etc.

https://github.com/fossfreedom/coverart-browser

semitones (semitones) wrote :

Any progress on this bug? Will it be moved to "in progress" or "won't fix" any time soon?

Any chance for this to be fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.