Ubuntu

Rythmbox freezes when using keyboard volume keys

Reported by Carlos Bribiescas on 2008-07-22
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Jaunty by Cristian KLEIN

Bug Description

Binary package hint: rhythmbox

Hi, I'm using Ubuntu hardy 2.6.24-19-generic. Whenever Rythmbox is the active window and i try to use my keyboard volume up/down/mute buttons to adjust the music my xserver will freeze for about 10-30 secs. However, if its in the background or minimized and I begin adjusting the volume and the little window-thing comes up telling me the current volume. and I bring Rhythmbox to the front before it goes away, I can adjust the volume and it won't freeze. I think that second part was understandable.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, do you get the same issue if you change the volume in rhythmbox using the slider? could you look at what processus use ressources while your machine hangs?

Changed in rhythmbox:
importance: Undecided → Low
status: New → Incomplete
Carlos Bribiescas (cbribiescas) wrote :

I can use the slider in rhythmbox no problem. When it hangs my system monitor doesn't say anything in particular is using more system resources than normal. Is there anything other questions I can answer to help?

I'm pretty sure it has something to do with bringing up the "window" that I circled in my screen shot. Because if i start raising and lowering my volume and while that "window" is up and switch to rhythmbox its ok. But if Rhythmbox is the active window and the the "window" is not up and i try to do it, it hangs.

Sebastien Bacher (seb128) wrote :

unconfirming, the bug is really weird, the dialog you show in your screenshot is not a rhythmbox one

Changed in rhythmbox:
status: Incomplete → New
Lysgaard (morten-klubblan) wrote :

Can confirm this bug. Ubuntu hardy, 64-bit

Pedro Villavicencio (pedro) wrote :

Which video card and driver are you using? Can you test the same with Intrepid? thanks.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in rhythmbox:
status: Incomplete → Invalid
James (purpleidea) wrote :

I can confirm i have this issue too.
The machine this happens on has been upgraded since dapper or edgy... Maybe something got left behind? In any case it shouldn't freeze anyways.

$ uname -a
Linux hostname 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686 GNU/Linux

Evan Nelson (ean5533) wrote :

Confirming that this bug exists (will leave more comments in a moment)

Changed in rhythmbox:
status: Invalid → New
Evan Nelson (ean5533) wrote :

Giving a short re-summary of the problem: when using rhythmbox, if a user changes the system volume by using function keys or "special" volume keys (such as the ones HP puts on their laptops these days), the system will temporarily hang. Sound continues to play with no problem.

When I intentionally force this bug to happen with a system resource monitor open, the resource monitor will continue to stream and show that nothing unusual is happening; that is, there are no resource hogging events going on, at least from the system monitor's report. However, this problem seems to block all non-system processes. For example, if I invoke this bug, rhythmbox will freeze, but I will still be able to switch desktops and use system menus. However, other running processes (such as firefox or gedit) will be frozen as well. All non-system processes unfreeze at the same time, somewhere around 5-15 seconds after the problem starts.

As noted before in previous bug comments (https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/144330), this problem occurs exclusively when two things are true:

1)Rhythmbox has focus (i.e. isn't minimized),
2)Rhythmbox's "Browse" window is open (accessible via View->Browse) and has never been closed.

I've noted that if you open Rhythmbox, then close the "Browse" window and re-open it, this problem goes away. However, this problem seems to randomly return every few weeks, and I cannot figure out a pattern causing it to return.

To recreate this bug yourself, do the following:

1)Open rhythmbox,
2)Ensure that the "Browse" window is open (menu: View->Browse),
3)Begin playing a song,
4)Change the volume using a function key.

Again, the problem seems to be intermittent based on the usage of the "Browse" window. The problem may also be related to the amount of songs Rhythmbox is keeping track of. I have ~5000 songs in my library, so there may be a problem related to the browse window reading a large song list.

Note that I have NOT tried running rhythmbox from the command line and invoking this bug to see what errors pop out. Why? Because whenever the problem crops up I instinctively "fix" it by closing and opening the "browse" window before I remember to try logging the error. My apologies.

jakeofspades (jack-w-rae) wrote :

I also get this bug - however for me it occurs if View->Browse is open or not.
Changing the volume using my keyboard volume key and the window temporarily freezes, and also freezes any other window. I am not using desktop effects, I am using Ubuntu Hardy 8.01. I have always had this problem since fresh install.

It does release after about two minutes.

Changed in rhythmbox:
status: New → Confirmed
Evan Nelson (ean5533) wrote :

Update:

I finally remembered to run rhythmbox from the terminal and induce this problem. Without debug set (-d option), nothing interesting at all happens. With debug mode set, something interesting happens: nothing. That is, during the bug, output to the terminal just stops.

I start playing a song, and you start seeing lines like the following:

(20:27:59) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 4:215(0)]
(20:27:59) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 4:215(0)]
(20:28:00) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 4:215(0)]
(20:28:00) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 4:215(0)]
(20:28:00) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 5:215(0)]

However, when I induce the problem and cause the system to free, output to the terminal temporarily stops and is never recovered (notice the jump in system time):

(20:28:01) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 5:215(0)]
(20:28:01) [0x80dc408] [rb_shell_window_configure_cb] rb-shell.c:1600: storing window size of 1279:750
(20:28:01) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys
(20:28:01) [0x80dc408] [rb_shell_window_configure_cb] rb-shell.c:1600: storing window size of 1279:750
(20:28:01) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 5:215(0)]
(20:28:01) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys
(20:28:26) [0x80dc408] [tick_cb] rb-shell-player.c:3223: tick: [file:///media/sda2/music/Jack%20Johnson/Brushfire%20Fairytales/Jack%20Johnson%20-%201(01)%20Inaudible%20Melodies.MP3, 31:215(0)]
(20:28:26) [0x80dc408] [window_focus_cb] rb-mmkeys-plugin.c:118: window got focus, re-grabbing media keys

Note that music DOES continue to play during this system freeze, in spite of the lack of terminal output.

Pedro Villavicencio (pedro) wrote :

is someone still facing this issue with intrepid? could the person able to reproduce this send it upstream to bugzilla.gnome.org? thanks.

Changed in rhythmbox:
status: Confirmed → Incomplete
Evan Nelson (ean5533) wrote :

I have been unable to reproduce this error in Intrepid (fresh install, not an upgrade from my Hardy install). If no one else can confirm that this problem exists in Intrepid, I'm going to close the problem as fix released. I'll reopen it if the problem ever comes back.

Evan Nelson (ean5533) wrote :

Bug seems to have vanished in Intrepid

Changed in rhythmbox:
status: Incomplete → Fix Released
Steve Zemanek (steve-zemanek) wrote :

I am still having this problem in intrepid, however I did not do a fresh install and would like to avoid doing a fresh install. Does anybody know which package generates the volume control window?

Steve Zemanek (steve-zemanek) wrote :

I did discover a work around...
remove the directory called "mmkeys" located in "/usr/lib/rhythmbox/plugins/"

Steve Zemanek (steve-zemanek) wrote :

nevermind.. i found a better work around...

delete the directory "rhythm" in "~/.gconf/apps/"

Steve Zemanek (steve-zemanek) wrote :

correction!!! delete the directory "rhythmbox" in "~/.gconf/apps/"

sorry for the typo

andreselsuave (andreselsuave) wrote :

Still got the bug in Intrepid , none of both the workarounds above work and no need to be playing a song to reproduce the bug. It is enough to have rhythmbox opened and focused. Any solution?

andreselsuave (andreselsuave) wrote :

Ok, it is solved. The workarounds worked perfectly after logging out and relogging again. Thanks

Cristian KLEIN (cristiklein) wrote :

Confirm that workarounds are working.

crjackson (crjackson) wrote :

Had the same problem using Hardy 8.04.2

The only work around that fixed the problem wah to remove the directory called "mmkeys" located in "/usr/lib/rhythmbox/plugins/"

Thanks Steve Zemanek - the .gconf workaround didn't do anything for me but the mmkeys did the trick.

Cristian KLEIN (cristiklein) wrote :

This bug is still present in Jaunty. I checked the source code, mmkeys is still active in gconf.

Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

the multimedia keys are supposed to be working yes that's not a bug

Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid
Matchu (matchu1993) wrote :

Just pointing out that the issue still exists in Karmic. Using Fn volume shortcuts while Rhythmbox has focus hangs Rhythmbox and all other apps for about 10-20 seconds, but using the same shortcuts when any other app has focus results in no problems. Currently doing something vital; will try workarounds when I have an opportunity to log off.

JP (vectorpoem) wrote :

I can confirm that this happens in Karmic (GNOME 2.28.1, Rhythmbox 0.12.5). The keys involved don't need to be any special media keys, they can be any shortcut specified with the GNOME Keyboard Shortcuts tool. And it only happens when Rhythmbox is the focused window.

My steps to reproduce:

1. Open Preferences > Keyboard Shortcuts
2. Set "volume down" to something like Ctrl+Alt+Down
3. Open Rhythmbox
4. Start a track playing
5. With Rhythmbox as the currently focused window, press Ctrl+Alt+Down or whatever you bound the volume control to
6. Observe: the volume does not change, Rhythmbox freezes (no visual updates or interactivity) for some period of time, and finally the UI becomes responsive again
7. Switch to another window or workspace
8. Use the same key binding to adjust the volume
9. Observe: the volume adjusts immediately, and Rhythmbox does not freeze

JP (vectorpoem) wrote :

The gconf fix worked for me. This appears to only affect people who have upgraded from older versions of Ubuntu.

Sebastien Bacher (seb128) wrote :

which gconf fix are you speaking about there?

JP (vectorpoem) wrote :

Hmm, actually not the exact fix(es) specified here. I just set this false in gconf:

/apps/rhythmbox/plugins/mmkeys/active

I have the same problem but the applet freezes when I use my laptop special key (a scrollable wheel). I use ubuntu 10.04 ... in ubuntu 9.10 worked fine

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers