Jamendo streaming issues: Can't skip to further back in recording; Doesn't buffer enough before playing

Bug #242289 reported by Mark Darbyshire on 2008-06-23
2
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When streaming a recording from Jamendo, I can't use the slider to rewind and continue playback (regardless of whether it's paused or playing when I move the slider). This is quite annoying, more so because of the other problem...

The Internet's running very slowly at the moment. If a song's bitrate is too high, so that it can't be downloaded quickly enough, it just keeps pausing erratically.

It would be nice if Rhythmbox would detect how download a sufficient buffer so that large files can be played continuously without breaks. Failing that, it would be nice if I could at least manually pause playback, rewind to the beginning, and wait until I guess enough will have been loaded before starting playback. On this line of thought, a nice feature would be an indicator of how much of the file has streamed (in the same way as, for example, the youtube.com player does).

ProblemType: Bug
Architecture: amd64
Date: Mon Jun 23 20:40:18 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.11.5-0ubuntu7
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.24-19-generic x86_64

Mark Darbyshire (markdarb) wrote :
Changed in rhythmbox:
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

the request is rather upstream work could you open send the bug on bugzilla.gnome.org?

Pedro Villavicencio (pedro) wrote :

any news about this? did you open a bug upstream? may you tell us the number?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Incomplete
Mark Darbyshire (markdarb) wrote :

I'm now using Intrepid 8.10 Beta. I haven't seen this happen so far (it seems to wait to buffer for long enough), but I'm not a regular user of Rhythmbox. I need to wait for the Internet to get really slow to test this.

In short, I haven't filed a bug upstream, but this may not be a problem anymore and I'll have to wait until I can test this.

If I do end up needing to file a bug upstream I'll post a link here.

Sebastien Bacher (seb128) wrote :

closing the bug since that works correctly now, you can reopen if you get the issue again though

Changed in rhythmbox:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers