First "Import Folder" reports "Operation not supported"

Bug #242013 reported by JD on 2008-06-21
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Problem occurs in:
* Ubuntu Hardy
* Ubuntu Intrepid daily live, 2008-08-26

1. Start Rhythmbox for the first time (or after deleting .gnome2/rhythmbox).
2. Choose "Music" > "Import Folder".

What happens: A filepicker appears with the error "The folder contents could not be displayed - Operation not supported".
What should happen: A filepicker appears with no error message.

This bug will give new users the wrong impression and it is a bit annoying.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you make a screenshot showing the error dialog?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
JD (jacobdorne) wrote :

I've attached the screenshot.

Remember:
If I click OK everything is fine again.

Pedro Villavicencio (pedro) wrote :

still an issue? may you please tell us a few easy steps for reproduce the behavior? did you tried to reproduce the same with a new created user on your system?

description: updated
Changed in rhythmbox:
status: Incomplete → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

confirmed with last Intrepid version (rhythmbox 0.11.6).

You can reproduce the problem installing rhythmbox in a chroot environment.

Pedro Villavicencio (pedro) wrote :

Indeed, got the same with a newly user.

Changed in rhythmbox:
status: Confirmed → Triaged
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at http://bugzilla.gnome.org/show_bug.cgi?id=551035 ; thanks all for reporting.

Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
status: New → Incomplete
Michael Terry (mterry) wrote :

Here's a debdif for Jaunty. I also attached the patch to the upstream bug.

Changed in rhythmbox:
status: Incomplete → Fix Released
Pedro Villavicencio (pedro) wrote :

This has been fixed upstream, thanks for reporting.

Changed in rhythmbox:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the jaunty version is a svn snapshot which has this change

Changed in rhythmbox:
status: Fix Committed → Fix Released
jasonq (jason-quinn) wrote :

I don't think this is fixed.

I have Rhythmbox 0.12.0 on a fully updated Ubuntu 9.04. Starting Rhythmbox fresh (that is after deleting the rhythmbox directory in .gnome2) I get the error that it "the folder contents could not be displayed". The reason is that it is looking in my home directory for a folder called "music". It keeps looking in the "music" directory regardless of the folder I spectify for my music in Preferences. My music is stored in a directory called "Music", with the capital 'M' as is the current Gnome naming convention.

Wingman (mikywing) wrote :

Indeed that's not fixed. I've just done a fresh, updated ubuntu 8.04.2 LTS installation today and the bug is still there!

Wingman (mikywing) wrote :

See last comment.

Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed
Michael Terry (mterry) wrote :

@Wingman, it was only ever fixed for Jaunty and above. Although jasonq reported he had a problem even with Jaunty (though it sounds like that problem is subtly different). But there was not the expectation that it would be fixed for Hardy.

@jasonq, what locale are you in? Can you tell me the output of the following?
echo $LANG

Sebastien Bacher (seb128) wrote :

the hardy version is outdated the bug should be fixed in the current karmic version reopen if you still get the issue using that version though

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
Wingman (mikywing) wrote :

Ok sorry if i did something wrong :)

But isn't 8.04 supported till april 2011? Shouldn't bugs be fixed till that date?
Or i got wrong the meaning of LTS?

Michael Terry (mterry) wrote :

LTS just means that it has a longer amount of time where it is considered for security fixes and major bug fixes. See https://wiki.ubuntu.com/StableReleaseUpdates for the criteria for updates. As far as I know, the same criteria apply to LTS as normal already-released code. Just a matter of how long they get attention.

Wingman (mikywing) wrote :

Mmm so as far as i read the fix will not be released for hardy since it's a low urgency bug, and is not worth to spend efforts on it (maybe also considering that the upgrade may bring some kind of regressions?).
Thankyou for the link, it was very clear! :)

Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.