Launcher icon is fuzzy

Bug #234754 reported by David Prieto on 2008-05-25
6
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Low
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Hi,

Ubuntu uses /usr/share/app-install/icons/rhytmbox.png as the launcher icon. For some reason it looks fuzzy and out of place in the menu. /usr/share/icons/hicolor/22x22/apps/rhythmbox.png looks crisp and fine, though, so in my opinion that icon should be used.

Related branches

Sebastien Bacher (seb128) wrote :

thank you for your bug report, what ubuntu version do you use? how you determine what icon is used? there is no directory specified in the desktop file and no reason why the app-install variant should be used there

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

I'm using Hardy. It seems I was wrong about what icon is used now: If you launch Alacarte, edit the rhythmbox launcher and click on the icon, you'll see that /usr/share/icons/hicolor/48x48/apps/rhythmbox.png is the one being used.

It seems, however, that the launcher is not using the 22x22 version but a larger one, scaled down, which makes it fuzzy.

Sebastien Bacher (seb128) wrote :

the issue is known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=524079

Changed in rhythmbox:
status: Incomplete → Triaged
Changed in rhythmbox:
status: Unknown → Confirmed

I'm working on this

This is the debdiff :)

Changed in rhythmbox:
status: Triaged → Confirmed
Pedro Villavicencio (pedro) wrote :

thanks for the diff Salvatore, but please don't change the bug from triaged to confirm. changing it back, thanks.

Changed in rhythmbox:
status: Confirmed → Triaged

Martin can you take a look at the debdiff?

Martin Pitt (pitti) wrote :

Sorry, I'm on vacation (just a quick last email check), can someone else please check and upload this?

Sebastien Bacher (seb128) wrote :

would be nice to have the change upstream rather than having the use sharutils to distro patch an icon this way

Sebastien Bacher (seb128) wrote :

I've unsubscribed the sponsor team, having icon added in distro patches is ugly and that should be fixed upstream rather

Changed in rhythmbox:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.6svn20080909-0ubuntu1

---------------
rhythmbox (0.11.6svn20080909-0ubuntu1) intrepid; urgency=low

  * New upstream snapshot:
    - fix ipod copies (lp: #263258)
    - fix launcher icon being blurry (lp: #234754)

 -- Sebastien Bacher <email address hidden> Tue, 09 Sep 2008 22:44:09 +0200

Changed in rhythmbox:
status: Triaged → Fix Released

The icon on the nautilus context menu seems to be the wrong size, too. I'm attaching a screenshot of how it looks vs. how it should.

Changed in rhythmbox:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.