rhythmbox notifications don't show album cover

Bug #229197 reported by Jan Frybort on 2008-05-11
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

[Hardy] Rhythmbox notifications of currently playing song don't show album cover although it is available. Strange is that this album cover is displayed when hoovering mouse over the Rhythmbox icon in the gnome-panel. Unfortunately I was unable to make a screenshot of this.
Don't know if it a planned change but it used to work different in Gutsy. These notifications look dull without the album cover.

Jan Frybort (jan.frybort) wrote :
Pedro Villavicencio (pedro) wrote :

thanks for your report, that works fine here i get the album cover on the notification area tooltip, not confirming, can you test the same with another new user created on your system? Are you using compiz ? does it happens without it?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Jan Frybort (jan.frybort) wrote :

Tried a different user and the notification shows the album cover. It must be something in my settings. Compiz does not influence this.

Pedro Villavicencio (pedro) wrote :

not a bug then, that might be something broken on your configuration rather, thanks.

Changed in rhythmbox:
status: Incomplete → Invalid
David Barth (dbarth) wrote :

Re-opening the bug, as it seems that rythmbox is /sometime/ sending the cover art in notifications, and sometime not... As confirmed by tracing notification requests received by notify-osd. See bug #332356.

Changed in rhythmbox:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

David why does that break notify-osd? shouldn't it display the covert art anyway in such cases?

Cameron Graham (cam-graham) wrote :

I can confim this bug. Album art is being downloaded and displayed inside rhythmbox, notifications are sent to notify-osd, but the rhythmbox icon is displayed instead of the album art.

Cameron Graham (cam-graham) wrote :

..just to confirm that I indeed have the album art in question.

Tibault Damman (tibault-damman) wrote :

It appears cover art is only shown on tracks of which you have already seen the coverart. Tracks where rhythmbox has already "installed" the coverart. It doesn't matter whether the covers are stored locally or in ~/.cache/rhythmbox/covers.

Rip a new cd to you library, add the coverart to the folder or let rhythmbox download it by playing the first track. Confirm you see the coverart in rhythmbox. Now play track 3 in rhythmbox (don't play track 2). Rhythmbox will show the coverart.
Play the first track again and iconify rhythmbox so the notifications will show. Sit back and watch (and listen ;-)).
When track 2 starts you'll see no cover art, but when track 3 starts you will.

Note: you don't have to view the coverart in the main rhythmbox window to "install" the icon, hovering your mouse over the rhythmbox icon and viewing the popup works as well.
(when track 4 starts you'll see no coverart in the notification, hover over the rhythmbox icon and you'll see the cover in the popup. Rightclick and choose "previous" (or use a mediakey on your keyboard) and wait 'till track 3 finishes: the notification for track 4 will now show the coverart)

I hope this helps track down the bug,

Tibault

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Joel Auterson (joel-auterson) wrote :

Tibault's solution does not work in Jaunty.

tekstr1der (tekstr1der) wrote :

This bug exists on a fully updated Karmic also. In combination with Bug #426329, Rhythmbox really fails to deliver on the cover art / tag front for Ubuntu 9.10. Version 12.6 should be allowed in it's entirety as an SRU or at least should be backported.

tekstr1der (tekstr1der) wrote :

This seems resolved as of rhythmbox 0.12.7 with notify-osd.

This bug still exists on a fully updated Ubuntu Karmic with Rhythmbox 0.12.7. Strangly, I didn't have this problem when I had just installed it. It started happening later that day while I was playing around with CoverGloobus. At first it would load all covers the way it should. Then later that same day it would only display covers from albums that have the cover as a separate .jpg file in the same folder (covers from ID3 tags were not displayed). And now (a few days later) it won't show any covers at all (although at times it does). DarthTibault's method also didn't change anything for me.

I added a screenshot with the bug in action.

Sebastien Bacher (seb128) wrote :

the service rhythmbox uses to download covers blocked rhythmbox from using it now because it was causing too much request on the servers, do you get the issue with local covers too or only where covers should be fetched from internet?

I only use local covers (ID3 tag and folder.jpg) and I always have the function for fetching covers from internet disabled. So the problem occurs for files that already have a cover locally (either in the ID3 tag or a separate folder.jpg in the same folder).

Sebastien Bacher (seb128) wrote :

do you get the issue when you switch track manually too or only when rhythmbox goes from one track to the next one?

This is getting really strange.. first I was testing to see if the issue happens when Rhythmbox goes from track to track. The album covers showed up the way the should. But then, after the first 5 tracks or so, covers disappeared from the notifications again. After that I couldn't get it working anymore, neither when I switched tracks manually.
I restarted Rhythmbox to see if that changes anything, but the issue remained. Then I rebooted the whole system, but still no album covers. Playing the same tracks which showed covers earlier don't show covers in the notifications anymore either, so it's not the mp3 files that are causing this.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Joe (jgsylvesterjr) wrote :

This is no longer an issue in Natty.

Pedro Villavicencio (pedro) wrote :

Closing the report then, thanks.

Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers