Ubuntu

Pressing Space key should toggle play/pause (pause when playing; play when paused)

Reported by Kurt George Gjerde on 2008-01-25
112
This bug affects 23 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Rhythmbox
Invalid
Undecided
Unassigned
Totem
Invalid
Medium
rhythmbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

1. Linux tavla 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux
     DISTRIB_ID=Ubuntu
     DISTRIB_RELEASE=7.10
     DISTRIB_CODENAME=gutsy
     DISTRIB_DESCRIPTION="Ubuntu 7.10"

2. rhythmbox 0.11.2-0ubuntu4

3.
Pressing Space, Rhythmbox starts playing the current track from the beginning. That is, it restarts playing the track.
By normal convension Space should act as a play/pause button.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, that's known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=326066

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Kurt George Gjerde (tengil) wrote :

I don't think that's the same issue. That bug deals with the play/pause software button.
I'm talking about the keyboard shortcut. Currently you have to press Ctrl-Space to do the play/pause. It should be just the space bar, like most other applications.

Pedro Villavicencio (pedro) wrote :

It's totally related. If that bug get fixed, if you press the space bar with that fix included it'll do a play/pause instead a play/stop.

Kurt George Gjerde (tengil) wrote :

Ok. Thanks!

Changed in rhythmbox:
status: Unknown → Confirmed

Pedro, bug #71228 is more closely related to the upstream bug; I think it's confusing that this bug (regarding the keyboard shortcut) also references that bug.

Changed in hundredpapercuts:
milestone: none → lucid-round-6
summary: - Keyboard shortcut Space restarts track, should be play/pause
+ Pressing Space key should toggle play/pause (pause when playing; play
+ when paused)
Vish (vish) on 2010-01-21
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Seemanta (seemanta) wrote :

I can write a patch for this. Shall I add it here or shall I raise a new rhythmbox bugzilla bug ? If yes, how shall I connect these two bugs?

Sorry if my questions sound stupid. I am new to launchpad, so please bear with me.

Pedro Villavicencio (pedro) wrote :

Seemanta you can add the patch to this report, there's no need to open a new one for that, thanks.

Seemanta, the proposed behavior is that the button no longer appears pressed under any circumstances; instead, only the icon on the button changes between "play" and "pause." To repeat, while playing the button should not appear pressed -- it should have a pause icon.

Lightbreeze (nedhoy-gmail) wrote :

Seemanta: I'd love to see this fixed for Lucid, are you still able to submit a patch?

Mihai Capotă (mihaic) wrote :

I noticed the same behavior in Totem. I found a related Gnome bug that explains this behavior:
https://bugzilla.gnome.org/show_bug.cgi?id=370732

Space is reserved to activating widgets for accessibility purposes. It can't be used for anything else. There's an entry in the Totem FAQ about this:
http://projects.gnome.org/totem/#faq

You can make Space toggle playback right now by first highlighting the Play button in the toolbar by pressing Tab.

The behavior you're seeing during playback - the song starting from the beginning - is cause by the action associated with the song list widget, which is normally the selected widget. The behavior of the song list widget could be changed to toggle playback. Or keyboard focus could switch to the play button automatically after you start a song, though I don't think that's a good idea.

Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: lucid-round-6 → maverick-round-6-sound+video
Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Changed in hundredpapercuts:
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Bilal Akhtar (bilalakhtar) wrote :

The attached branch fixes the issue.

Mihai Capotă (mihaic) wrote :

As I understand from the Totem FAQ, space cannot be used as an accelerator because it's reserved for activating regular user interface elements for accessibility reasons.

Citing from http://projects.gnome.org/totem/#faq:

Q: Why doesn't the space bar work to play/pause in windowed mode? It only works in fullscreen, and sometimes in windowed mode.
A: The space bar will work in fullscreen. But when in windowed mode, for accessibility reasons, we cannot use the space to play/pause (it is used to "push" buttons already). It will work sometimes, as the play/pause button, or the video widget might be the one with the keyboard focus. Try using "P" to play/pause instead.

The proposed patch hurts accessibility.

Bilal Akhtar (bilalakhtar) wrote :

Mihai,

So this is exactly what the proposed patch does.

Mihai Capotă (mihaic) wrote :

The patch does the opposite of what the Totem FAQ says.

I admit, the Totem FAQ may not seem the most authoritative source. So here's what the GNOME HIG [1] says about using the space key as a shortcut:

"The following shortcut keys are reserved for keyboard navigation use by the various widgets used in GNOME, and should not normally be over-ridden by your application.

"Space Toggle selected state of focused check box, radio button, or toggle button"

[1] http://library.gnome.org/devel/hig-book/stable/input-keyboard.html.en#widget-navigation

tags: added: accessibility
Bilal Akhtar (bilalakhtar) wrote :

OK, I am withdrawing my merge proposal and un-assigning me.

Changed in hundredpapercuts:
status: In Progress → Triaged
Changed in rhythmbox (Ubuntu):
status: In Progress → Triaged
assignee: Bilal Akhtar (bilalakhtar) → nobody
Changed in hundredpapercuts:
assignee: Bilal Akhtar (bilalakhtar) → nobody
Bilal Akhtar (bilalakhtar) wrote :

In fact, this bug cannot be 'triaged' because it cannot be fixed. Marking 'Won't fix'

Changed in hundredpapercuts:
status: Triaged → Won't Fix
Changed in rhythmbox (Ubuntu):
status: Triaged → Won't Fix
Vish (vish) wrote :

The upstream bug is still open.

Changed in rhythmbox (Ubuntu):
status: Won't Fix → Triaged
Changed in hundredpapercuts:
status: Won't Fix → Triaged
Changed in totem:
importance: Unknown → Medium
status: Unknown → Invalid
Changed in rhythmbox:
importance: Unknown → Medium
tags: added: a11y
removed: accessibility
Vish (vish) wrote :

 - Rhythmbox is no longer the default music player. Closing papercut
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
milestone: maverick-round-6-sound+video → none
status: Triaged → Invalid
markling (markling) wrote :

I'd second the call for SPACE to activate <play/pause> in Rhythm Box. A one-touch <play/pause> is essential.

Try this: playing your guitar, learning a song. You have to <play/pause>. You can't be fiddling around with CTRL+SPACE or whatever when you are trying to pin down a riff.

Or what happens if the phone rings when you are rocking out? Or you're eating cornflakes in your best suit?

As for accessibility, having SPACE as <play/pause> is a darn sight more accessible than having to fumble all over CTRL+SPACE or whatever.

Also regarding accessibility, if SPACE needs commandeering for accessibility applications, surely it can so be without stopping SPACE being used for <play/pause> when accessibility applications are not active.

Julien Olivier (julo) wrote :

I don't know why but, in Ubuntu Natty, pressing "space" actually does toggle play/pause although, in the menu, the shortcut appears to be CTRL-space... The major problem with this behaviour is that you can't type "space" in the search bar without toggling play/pause... Very disturbing!

Bence Lukács (lukacs-bence1) wrote :

In precise it doesn't work again. If I press Space key the song started from the beginning.
In addition to this, Rhythmbox become the default music player in ubuntu again, so I think it would be nice if this bug became an active bug in the papercut project.

Chris Wilson (notgary) on 2012-02-28
Changed in hundredpapercuts:
status: Invalid → Confirmed
importance: Low → Medium
milestone: none → precise-4-music-video
assignee: nobody → Papercuts Ninja (papercuts-ninja)
status: Confirmed → Triaged
Chris Wilson (notgary) on 2012-06-09
Changed in hundredpapercuts:
milestone: precise-4-music-video → quantal-1-audio-video
Iain Lane (laney) wrote :

The upstream bug is about a slightly different issue; the text and icon on the play/pause button toggling when you toggle between those states. It's not about the 'space' key. I'm going to unlink the bugs and mark this as Won't Fix, since I cannot see that we will change this behaviour in Ubuntu.

Changed in rhythmbox (Ubuntu):
status: Triaged → Won't Fix
Changed in rhythmbox:
importance: Medium → Undecided
status: Confirmed → New
status: New → Invalid
Changed in hundredpapercuts:
status: Triaged → Invalid
Jamie Macdonald (jamie-alban) wrote :

I haven't read the implementation for gnome accessibility w/ space bar, but could I suggest that the selection order of the widgets be changed so that play/pause widget is the first selected on window focus?

Then, so long as the user does not hit Tab while in the application, space bar will be play/pause as expected by (many?) at least me and OP.

We could even go so far as physically swapping the (previous track) widget and the (play/pause) widget? At this point, it would be a design issue.

Changed in hundredpapercuts:
assignee: Paper Cuts Ninja (papercuts-ninja) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.