Ubuntu

Does not remember current song on reopen

Reported by Lukas Sabota on 2005-06-29
70
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Banshee
New
Wishlist
Rhythmbox
Confirmed
Wishlist
banshee (Ubuntu)
Undecided
Unassigned
rhythmbox (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

If I am listening to song Foobar by band X on album Y, when I reopen,
rhythmbox's current song should be Foobar, and band X should be selected, and
album Y should be selected. This is not the case. The first song in my library
is selected, and Album and Artist are selected as All.
The current position on closing should also be restored when reopened.

http://bugzilla.gnome.org/show_bug.cgi?id=128495: http://bugzilla.gnome.org/show_bug.cgi?id=128495

Corey Burger (corey.burger) wrote :

*** Bug 18509 has been marked as a duplicate of this bug. ***

Sean D. Quinn (seandq) wrote :

Thanks for your bug report and I can reproduce, so I have confirmed the bug.

Changed in rhythmbox:
assignee: nobody → gnome
status: Unconfirmed → Confirmed
status: Unconfirmed → Confirmed
Changed in rhythmbox:
status: Unconfirmed → Confirmed
Changed in rhythmbox:
status: Unconfirmed → Confirmed
Changed in rhythmbox:
assignee: nobody → desktop-bugs
Fred (eldmannen+launchpad) wrote :

I agree.

I reported this too on bug #194828 before.

I hope they fix this, because if I listen same song everyday, I get tired of it...

Changed in rhythmbox:
status: Confirmed → Triaged
imachine (m-jedrasik) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=128495#c17 <- this guy claims to have created a plugin. it seems it could be incorporated into ubuntu rhythmbox package, or a rhythmbox-plugins package could be created, or so :)

Innocent Bystander (galaxtri) wrote :

After 4+ years, this is not solved. May be this is an intentional design? Can the Dev team add an option somewhere to allow people who still want to resume their last played album / playlist and song position ?

Hew McLachlan (hew) wrote :

This issue is a feature request, which is already known upstream. If you look at the linked report (or even the comment above your own), you can see progress has been made.

Michalxo (michalxo) wrote :

This is a must for any player, especially with big library :-/
Another step away for me from RB :-(

Changed in rhythmbox:
importance: Unknown → Wishlist
danizmax (danizmax) wrote :

I would appreciate this function since I listen to same internet radio every day...

Will this eventually be fixed after 5 years? :(

Owais Lone (loneowais) wrote :

I created a plugin for this. Checkout https://launchpad.net/~loneowais/+archive/ppa

Fred (eldmannen+launchpad) wrote :

Nice.
But I think this is such a minor but essential functionality that it should be in the main application.
Push it upstreams.

summary: - Rhythmbox Does Not Remember Current Song on Reopen
+ Does not remember current song on reopen
Owais Lone (loneowais) wrote :

Ok, I added support to remember genre, artist, album and playlist too. :)

Fred (eldmannen+launchpad) wrote :

Awesome! Good job!
I hope the plugin gets accepted upstreams.

But it would be better if it was part of main functionality and standard behavior since this is so essential that it should not require a plugin.

Changed in banshee:
importance: Unknown → Medium
status: Unknown → Invalid

I'm in Ubuntu 12.04 beta. Seven years after first reported, this bug remains.
Rhythmbox is a great player, but this feature lacks a lot.

apt-get remove rhythmbox
apt-get install (guayadeque|banshee| ...)

Changed in banshee:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in banshee:
importance: Unknown → Wishlist
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.