rythmbox switching radio streams brings up error "Couldn't start playback: Unknown playback error"

Bug #183825 reported by AlainODea on 2008-01-17
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Launch Rhythmbox
Click Radio in sidebar
Double-click "HBR1.com - Dream Factory"
> stream buffers and then plays
Double-click "HBR1.com - I.D.M Tranceponder"
>Error dialog "Couldn't start playback: Unknown playback error"
Click Ok to dismiss dialog
Double-click "HBR1.com - Dream Factory"
>Error dialog "Couldn't start playback: Unknown playback error"
Double-click "Virgin Radio Classic Rock"
> stream buffers and then plays
Double-click "HBR1.com - Dream Factory"
> stream buffers and then plays
Double-click "HBR1.com - I.D.M Tranceponder"
>Error dialog "Couldn't start playback: Unknown playback error"

It appears to be a issue with switching radio streams on the same host.

ProblemType: Bug
Architecture: i386
Date: Thu Jan 17 14:21:39 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.11.2-0ubuntu4
PackageArchitecture: i386
ProcCmdline: rhythmbox
ProcCwd: /home/alain
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux alainodea 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

Related branches

AlainODea (alain-odea) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your report, What's the URL of that radio you're trying to listen?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
AlainODea (alain-odea) wrote :

Here are the stream URLs:

HBR1.com - Dream Factory:
http://ubuntu.hbr1.com:19800/ambient.ogg

HBR1.com - I.D.M Tranceponder:
http://ubuntu.hbr1.com:19800/trance.ogg

HBR1.com - Tronic Lounge
http://ubuntu.hbr1.com:19800/tronic.ogg

Virgin Radio Classic Rock
http://www.smgradio.com/core/audio/ogg/live.pls?service=vcbb

These appeared in the Radio section of Rhythmbox automatically in my Gutsy Gibbon install.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

I will give this a test as soon as I get Ubuntu on my new work
machine. I am still trying to work out how to get X.org to handle dual
display with the weird dual DVI splitter connector it has. As soon as
I get it set up I will try to reproduce this bug and report my
findings. Thanks.

On 20-Feb-08, at 10:44 AM, Pedro Villavicencio wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? Thanks in advance.
>
> --
> rythmbox switching radio streams brings up error "Couldn't start
> playback: Unknown playback error"
> https://bugs.launchpad.net/bugs/183825
> You received this bug notification because you are a direct subscriber
> of the bug.

slowtrain (pmuhl830) wrote :

I haven't been able to access the hbr1 radio station on any channel for several weeks. I get the 'couldn't start playback' unknown error as well.

I've tried to directly to to http://ubuntu.hbr1.com, and my browser says it can't find the server. I suspected there's something wrong w/ the station.

I went to the hbr1 site and clicked Ogg Vorbis SF. This installs a different address in my Rhythmbox, which does work!

Ubuntu should update these addresses because they come pre-installed w/ Rhythmbox.

Cheers!

Changed in rhythmbox:
milestone: none → ubuntu-8.04
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.5-0ubuntu2

---------------
rhythmbox (0.11.5-0ubuntu2) hardy; urgency=low

  * debian/control.in,
    debian/patches/01_lpi.patch:
    - updated to the new launchpad integration version
  * debian/patches/06_oggradios.patch:
    - updated the initial ogg stations list using the redhat one,
      should fix the playback issues due to not responding servers (lp: #183825)

 -- Sebastien Bacher <email address hidden> Thu, 10 Apr 2008 00:51:43 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
slowtrain (pmuhl830) wrote :

Thanks Sebastien! While we're at it, another(?) rhythmbox problem: I can be listening to a radio station for an hour or more and then suddenly the audio stream stops. When I click that station or another one I get the playback error message. The problem disappears when I restart rhythmbox. Sometimes have to restart several times while I'm working.

Cheers
Peter

Sebastien Bacher (seb128) wrote :

don't use the same bug to describe different issue, the one you describe there could be a duplicated, there is several bugs about chained ogg creating such issues for example

igi (igor-cali) wrote :

Updating my rhythmbox to 0.12.5-0ubuntu5.1 the bug started affecting my pc.

Changed in rhythmbox (Ubuntu):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs because you have a similar issue open a new one rather

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers