rhythmbox crashed with SIGSEGV in rhythmdb_entry_allocate()

Bug #183797 reported by Nic on 2008-01-17
94
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Rhythmbox was reading my Music folder and importing the metadata in the database for the first time when it crashed. I was also playing an mp3 file at the time. I was NOT using the crossfading engine by the way,

ProblemType: Crash
Architecture: i386
Date: Thu Jan 17 15:54:31 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.11.4-0ubuntu2
PackageArchitecture: i386
ProcCmdline: rhythmbox
ProcCwd: /home/nt271
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=C
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 rhythmdb_entry_allocate ()
 rhythmdb_entry_new () from /usr/lib/librhythmbox-core.so.0
 ?? () from /usr/lib/librhythmbox-core.so.0
 ?? ()
 ?? ()
Title: rhythmbox crashed with SIGSEGV in rhythmdb_entry_allocate()
Uname: Linux constantines 2.6.24-4-generic #1 SMP Mon Jan 14 17:30:39 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy fuse kvm lpadmin netdev plugdev powerdev pulse pulse-access pulse-rt scanner video

Related branches

Nic (ntetreau) wrote :

StacktraceTop:rhythmdb_entry_new (db=0x828e000, type=0x0,
rhythmdb_add_import_error_entry (db=0x828e000,
rhythmdb_process_metadata_load_real (event=0x8da5a70)
rhythmdb_process_one_event (event=0x8da5a70, db=0x828e000)
rb_async_queue_watch_dispatch (source=0x81f4bb8,

Changed in rhythmbox:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=510236

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
status: New → Fix Released
Kow (kow) wrote :

Same problem here. Looks like upstream fixed this in SVN, can we backport this fix?

Sebastien Bacher (seb128) wrote :

hardy will likely get a new version

Changed in rhythmbox:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

there is a new version in hardy now which fixes the issue

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: Fix Released → New
sam tygier (samtygier) wrote :

Bug 254168 has been marked a duplicate of bug. so it is still present in intrepid. reopening.

Changed in rhythmbox:
status: Fix Released → Confirmed
Changed in rhythmbox:
status: Confirmed → Triaged
Pedro Villavicencio (pedro) wrote :

this has been fixed upstream already, thanks for reporting.

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.0-0ubuntu2

---------------
rhythmbox (0.12.0-0ubuntu2) jaunty; urgency=low

  * debian/patches/90_svn_change_fix_crasher.patch:
    - svn change to fix a crasher (lp: #346877, #346514)
  * debian/patches/91_svn_change_decodebin2_fix_chained_ogg.patch:
    - svn change to use decodebin2 that should fix the playing of chained ogg
      (lp: #127374)
  * debian/patches/92_svn_change_fix_psp_nokia770_crasher.patch:
    - svn change to fix a crash with psp and nokia770 devices (lp: #183797)
  * debian/patches/93_svn_change_fix_device_change_crasher.patch:
    - svn change to fix a crash on device change (lp: #73059)

 -- Sebastien Bacher <email address hidden> Wed, 01 Apr 2009 21:50:31 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
status: New → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.