"Open" button in Import Folder in Rhythmbox does nothing if pressed immediately in certain folders

Bug #164586 reported by Tristan Schmelcher on 2007-11-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Rhythmbox
New
Unknown
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
vlc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rhythmbox

I have a fresh, up-to-date gutsy i686 installation.

In Rhythmbox, when choosing Import Folder, the Gnome open folder dialog will open in the last folder that was opened (as expected). For certain folders, if the user clicks Open immediately (i.e., that folder is already the one that the user wants to import), then nothing happens. The dialog does not close and there is no error message. In order to open the folder, the user must navigate to a different folder, navigate back, and then click Open. For me, this happens with "~/Untagged Music", but not with ~/Music, ~/Desktop, or ~/. As a test, it also happens for me with "~/Folder with Spaces", "~/FolderWithoutSpaces", and "~/Folderwithoutcapitals". For the folders with which this occurs, it is 100% reproducible.

Note that I have also seen this bug in Debian.

Repro steps:

Try the following steps with a variety of different folders (recommended to try creating the ones I named above).

1) Open rhythmbox.
2) Choose File -> Import Folder. Navigate to a folder of your choice and click Open.
3) Choose File -> Import Folder again. (The dialog begins in the same folder that you opened in (2).)
4) Click Open without navigating anywhere.

Results: Eventually, you should find a folder for which step (4) consistently does nothing.
Expected: The folder should be imported.
Workaround: Navigate to a different folder, navigate back, and click Open.

Note that since Rhythmbox doesn't track additions to imported folders, users may frequently be re-importing the same folder, so particular users may see this bug a lot.

I have recently discovered that the workspace picker in Eclipse has the exact same problem with my workspace path. Accordingly, this bug should be re-targeted to whatever might be responsible for a cross-app problem such as this (libgtk?).

Pedro Villavicencio (pedro) wrote :

thanks for your report, rhythmbox doesn't import the same directory at least on Hardy. To test it, follow the steps you just wrote and then quit rhythmbox and try to import the same directory, according to your thoughts it should do it, but it doesn't and that's the right way to work, closing this bug since isn't a bug. thanks.

Changed in rhythmbox:
status: New → Invalid

I have upgraded Rhythmbox to the Hardy version and tried what you described, but you seem to be mistaken. Rhythmbox _does_ support re-importing the same directory. If you import a directory and then later put a new music file there and re-import the directory, then the file is correctly added to your music library. The bug though, as I describe in my report, is that if you press Open immediately (i.e., the dialog comes up in the very directory that you want to import), then (for some directories) the button doesn't do anything and the dialog stays open.

No matter what the right design for the app is, leaving the dialog up without even showing an error message is definitely a bug.

Changed in rhythmbox:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

To send upstream by somebody having the issue

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

May someone having the issue send this upstream? For details about how to forward it you may want to look at https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; setting this as incomplete until someone send it upstream, thanks.

Changed in rhythmbox:
status: New → Incomplete

Opened with Gnome at http://bugzilla.gnome.org/show_bug.cgi?id=527654

Changing back to New.

Changed in rhythmbox:
status: Incomplete → New
Changed in rhythmbox:
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Lightbreeze (nedhoy-gmail) wrote :

Marking Incomplete 'paper cut' until we know whether Rhythmbox will be included in Karmic.

Changed in hundredpapercuts:
status: New → Incomplete
Nocturne (frederic-mueller) wrote :

I have the same problem with File Roller. So I guess it is a problem in the gnome dialog. You are simply unable to open the folder that this dialog has selected from history. I don't know if that is by design to prevent selecting the folder from history accidentally but if so this behavior just #?!'!$$%.

PrototypeX29A (preineke) wrote :

I have the same problem with rhythmbox (Ubuntu 9.10, and rhythmbox: 0.12.5-0ubuntu5)
I also encounter this problem with the very same directory, so it might be related:
https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/500534

Vish (vish) on 2009-12-27
Changed in hundredpapercuts:
status: Incomplete → New
Omer Akram (om26er) on 2010-02-01
Changed in hundredpapercuts:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.