upnp doesn't work out of the box, need python-coherence which is not installed due to CD constrains

Bug #160592 reported by Marc Luethi
126
This bug affects 11 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

With gutsy (live CD as well as on upgraded install from Feisty and a blank fresh install on an SPARC box), rhythmbox does not load the UPnP sharing plugin.

python-louie is installed (Bug #132992), but running "rhythmbox -d" from commandline reveals this:

(19:05:15) [0x80fb408] [rb_plugins_engine_load] rb-plugins-engine.c:108: Loading plugin: /usr/lib/rhythmbox/plugins/upnp_coherence/coherence.rb-plugin
(19:05:15) [0x80fb408] [rb_plugins_engine_load] rb-plugins-engine.c:197: Could not find 'Icon' in /usr/lib/rhythmbox/plugins/upnp_coherence/coherence.rb-plugin
(19:05:15) [0x80fb408] [rb_plugins_engine_load_cb] rb-plugins-engine.c:271: Plugin UPnP sharing support loaded
(19:05:15) [0x80fb408] [rb_python_module_init] rb-python-module.c:368: Init of python module
(19:05:15) [0x80fb408] [rb_python_object_get_type] rb-python-plugin.c:254: Registering python plugin instance: CoherencePlugin+RBPythonPlugin
(19:05:15) [0x80fb408] [rb_python_module_new_object] rb-python-module.c:343: Creating object of type CoherencePlugin+RBPythonPlugin
(19:05:15) [0x80fb408] [rb_python_object_init] rb-python-plugin.c:190: Creating python plugin instance
(19:05:15) [0x80fb408] [CoherencePlugin.get_coherence] /usr/lib/rhythmbox/plugins/upnp_coherence/__init__.py:132: Coherence not found
(19:05:15) [0x80fb408] [CoherencePlugin.activate] /usr/lib/rhythmbox/plugins/upnp_coherence/__init__.py:23: Coherence is not installed or too old, aborting

After activating the UPnP checkbox in the "Plugins..." dialog box, the "Configure" button remains greyed-out - but that's the case with other plugins, too. Similar to the DAAP plugin, I would expect to be able to configure some options here, such as the name my share should use on the network.

There actually are some .py scripts in /usr/lib/rhytmbox/plugins/upnp_coherence/, but something still goes wrong. A package named python-coherence as mentionned in Bug #128205 (regarding package elisa) is not available in the repos. If the UPnP sharing plugin depends on this - why isn't the package available and why does Rhythmbox offer to use the UPnP plugin when it's dependencies don't seem to be met by the repos?

regards

Marc

Related branches

Marc Luethi (netztier)
description: updated
Marc Luethi (netztier)
description: updated
description: updated
description: updated
Revision history for this message
Basilio Kublik (sourcercito) wrote :

Confirmed in hardy i386 too, without python-coherence installed, the plugin doesn't do anything, after install python-coherence package, the plugin load and show the shares

There's no reference to the python-coherence package in rhythmbox, similar to what happened at bug #132992

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Juergen Beckmerhagen (juergen-beckmerhagen) wrote : Re: UPnP plugin fails to load: missing python-coherence

Same here:

Gutsy version: 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Rhythmbox version: 0.11.2-0ubuntu4

Python Coherence not in Repository!

Revision history for this message
Chris Jones (cmsj) wrote :

Unless python-louie and python-coherence can be promoted to main, presumably the best option here is to move the upnp plugin into its own package which is at most Recommends and can Depend on those two things.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

python-coherence is now in hardy.

Revision history for this message
Brian Pitts (bpitts) wrote :

Can python-coherence be marked as recommends for the rhythmbox package, like was done with avahi-daemon?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.4-0ubuntu4

---------------
rhythmbox (0.11.4-0ubuntu4) hardy; urgency=low

  * debian/control.in:
    - recommends on python-coherence (LP: #160592)
    - use the new libsoup version
  * debian/patches/81_from_redhat_use_new_libsoup_version.patch:
    - change from redhat, update the code to the new libsoup version
  * debian/patches/82_from_bugzilla_use_new_key_naming.patch:
    - change from bugzilla to get multimedia key working (LP: #188702)

 -- Sebastien Bacher <email address hidden> Wed, 06 Feb 2008 18:49:12 +0100

Changed in rhythmbox:
status: Triaged → Fix Released
Revision history for this message
Marc Nieper-Wißkirchen (marc-nieper-wisskirchen) wrote :

In the LTS release of Hardy, the bug is still there. I had to manually install python-coherence and python-louie in order to be able to activate the UPnP plugin.

Revision history for this message
Daniel Lombraña González (teleyinex) wrote :

I have to manually install python-coherence in order to enable rhythmbox upnp plugin. After the installation I can enable the plugin but I cannot configure it.

Revision history for this message
Dominik Baumeler (baumeler) wrote :

This problem still exists in Ubuntu intrepid alpha 6.
You can not activate the rhythmbox upnp plugin till you have installed the python-coherence package.

Revision history for this message
Sebastien Bacher (seb128) wrote :

right, recommends are installed by default but python-coherence doesn't fit on the CD so it's not recommended in intrepid

Revision history for this message
Dominik Baumeler (baumeler) wrote :

i understand why phyton-coherence is not installed by default.

so it shouldnt be selectable as a plugin or an info box should inform that the user needs to install python-coherence first in order use this plugin

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

This bug is not fixed. If you install Intrepid, you will see the Upnp plugin available in Rhythmbox. If you try to enable it, you will get an error and no indication on how to fix it.

Worst of all : you will get this error each time you launch Rhythmbox with no way to disable it (except by installing python-coherence which is completely not intuitive).

Changed in rhythmbox:
status: Fix Released → New
Revision history for this message
Schelfhout (schelf404) wrote :

Confirmed on Intrepid, amd64 arch with Rhythmbox 0.11.06svn20081008-0ubuntu4.2,
DLNA/UPnP sharing and control support is listed under plugins.
When you try to enable it the error is:
Plugin error: Unable to activate plugionDLNA/UPnP sharing and control support

Then I run rhythmbox --sync --debug:

Traceback:
File "/usr/lib/rhythmbox/plugins/upnp_coherence/__init__.py", line 13, in <module>
    import louie
ImportError: No module named louie

(rhythmbox:7742): Rhythmbox-WARNING **: Could not load plugin upnp_coherence

(15:17:09) [0x836500] [rb_python_module_finalize] rb-python-module.c:402: Finalizing python module (null)

(rhythmbox:7742): Rhythmbox-WARNING **: Error, impossible to activate plugin 'DLNA/UPnP sharing and control support'
(15:17:09) [0x836500] [plugin_manager_set_active] rb-plugin-manager.c:296: Could not activate DLNA/UPnP sharing and control support.

Revision history for this message
Schelfhout (schelf404) wrote :

Was able to reproduce

Changed in rhythmbox:
status: New → Confirmed
summary: - UPnP plugin fails to load: missing python-coherence
+ upnp doesn't work out of the box, need python-coherence which is not
+ installed due to CD constrains
Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

Does the absence of this package affect Banshee in a similar fashion? If not, we will not consider this a paper cut as Rhythmbox is being replaced with Banshee.

Changed in hundredpapercuts:
status: New → Incomplete
Revision history for this message
Ruud Koot (ruudkoot) wrote :

No, it only affects Rhythmbox.

Changed in hundredpapercuts:
status: Incomplete → Invalid
Revision history for this message
benste (benste) wrote :

@ David I didn't find any DLNA ability in Banshee yet so shifting is no option

@ Bug:

meantime for Karmic python-coherence package is only a placeholder for coherence package, that's why I added a duplicate requesting to add coherence package as depency of rhytmbox.
https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/407162

PS: also filed a bug against rhytmbox on bugzilla.gnome, asking for adding "coherence package may be missing" to the error message, but this one was declined as "it's a depency thing of distributions"
http://bugzilla.gnome.org/show_bug.cgi?id=590322

2nd PS: I talked to some devs of coherence team today, the included coherence package seems to be broken but they're working on it - I hope DLNA will be ready for Karmic otherwise Win7 with native DLNA support in WMP ..... :-(

Revision history for this message
benste (benste) wrote :

With the introduction of Windows 7 which supports DLNA by default this bugs becomes more and more.

Does so else subscribed now what the next steps could be ?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.6-1ubuntu9

---------------
rhythmbox (0.12.6-1ubuntu9) lucid; urgency=low

  * debian/control.in:
    - only recommends python-webkit and python-mako since those are not
      strictly required
    - recommends the cdrecord option rather than suggests, that's something
      users probably expect to see working on the default installation
  * debian/rules:
    - updated with some of the debian changes
  * Backported Debian change
  * Split plugins in a separate rhythmbox-plugins package, plus another
    one for the coherence plugin and one for the cdrecorder plugin.
    Mostly based on a patch by Yves-Alexis Perez. Closes: #566711. (lp: #160592)
  * rhythmbox-plugins depends on python-webkit and python-mako.
    Closes: #558203. (lp: #498816)
 -- Sebastien Bacher <email address hidden> Tue, 16 Feb 2010 17:22:09 +0100

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
no longer affects: hundredpapercuts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.