rhythmbox uses 100% CPU time when using crossfading

Bug #151514 reported by Cpt-Falcon on 2007-10-11
6
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

This is Ubuntu 7.10 beta, fresh install with all updates at the moment.

When you activate the "use crossfading backend" in Rhythmbox, (and then restart it), the player uses 100% CPU time when playing. It causes the sound to be laggy when you switch to another window or you do anything else. (My CPU is burning !!! lol)

Cpt-Falcon (sebn) wrote :

To activate it go Edition > Preferences > Lecture (in french, maybe "Playing" tab in english)

Cpt-Falcon (sebn) wrote :

Ok I found that the issue appear with AAC files and maybe other files (from bad and/or ugly codec), but not mp3 or ogg files.

Cpt-Falcon (sebn) wrote :

Well in fact with ogg files, the crossfading doesn't work at all ! Need to report another bug "Crossfading doesn't work with ogg files" ??

Sebastien Bacher (seb128) wrote :

that might be the same issue than bug #138728

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
William F Pearson (wfpearson) wrote :

I can confirm. This is affecting mp3's including shoutcast streams. Disabling the crossfade plugin eliminates the problem. This is serious problem because the crossfade plugin corrects choppy playback on some mp3 streams. bug 116990

Cpt-Falcon (sebn) on 2007-10-12
Changed in rhythmbox:
status: New → Confirmed
Philipp Kohlbecher (xt28) wrote :

I might be having the same problem. While playback of mp3 and ogg files works fine, enabling the crossfader (and restarting rhythmbox) increases rhythmbox's CPU usage from single digits to about 20 or 30%. This is more pronounced for certain audio files than for others--though I haven't been able to discern a pattern yet. Also, starting other applications or opening other windows sometimes causes audio playback to stutter.

I am using hardy with rhythmbox 0.11.5-0ubuntu6.

Sebastien Bacher (seb128) wrote :

do you still get the issue in hardy? could you attach an example to the bug?

Changed in rhythmbox:
status: Confirmed → Incomplete
Cpt-Falcon (sebn) wrote :

With Hardy the problem is solved. No more 100%.

Sebastien Bacher (seb128) wrote :

closing the bug since that works correctly now

Changed in rhythmbox:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers