Sync preferences not visible in device properties window

Bug #1513251 reported by Sandro on 2015-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
High
rhythmbox (Ubuntu)
High
Unassigned
Wily
High
Unassigned

Bug Description

* Impact
the Sync Preferences list tree box appears empty

* Test Case
- open rhythmbox
- connect a device (phone, player, etc)
- select it in the sidebar
- click on the "properties" tab at the top of the screen
- open the sync tab

* Regression potential
- check the layout of the sync dialog

-----------------

After upgrading to wily the Sync Preferences list tree box appears empty. Resizing the window does not help. The same problem occurs when booting Ubuntu GNOME 15.10 from a live CD. The device I want to sync music to is an Ipod shuffle model xC323. I also tried resetting it to factory to no avail.

I was expecting to see a list tree with my Music library on top and all my playlists as child nodes.

The problem could in fact be a GTK problem, but I've only seen it in Rhythmbox so far.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: rhythmbox 3.2.1-1ubuntu3
ProcVersionSignature: Ubuntu 3.19.0-31.36-generic 3.19.8-ckt7
Uname: Linux 3.19.0-31-generic x86_64
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Nov 4 23:03:31 2015
EcryptfsInUse: Yes
SourcePackage: rhythmbox
UpgradeStatus: Upgraded to wily on 2015-10-27 (8 days ago)

Sebastien Bacher (seb128) wrote :
Changed in rhythmbox (Ubuntu):
importance: Undecided → High
status: New → In Progress
Changed in rhythmbox:
importance: Unknown → High
status: Unknown → Fix Released
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 3.2.1-1ubuntu5

---------------
rhythmbox (3.2.1-1ubuntu5) xenial; urgency=medium

  * debian/patches/restore-traditional-menubar.patch:
    - use correct keybinding label for play/pause (lp: #1274726)
  * debian/patches/git_sync_option.patch:
    - don't have the sync option area having a 0 height (lp: #1513251)
  * debian/patches/git_sync_grid.patch:
    - sync: replace the sync state GtkTable with a grid

 -- Sebastien Bacher <email address hidden> Thu, 05 Nov 2015 16:50:08 +0100

Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Released

Hello Sandro, or anyone else affected,

Accepted rhythmbox into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/rhythmbox/3.2.1-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in rhythmbox (Ubuntu Wily):
importance: Undecided → High
status: New → Fix Committed
tags: added: verification-needed

Thanks, I can confirm that the issue is fixed with rhythmbox 3.2.1-1ubuntu3.1.

tags: added: verification-done
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 3.2.1-1ubuntu3.1

---------------
rhythmbox (3.2.1-1ubuntu3.1) wily; urgency=medium

  * debian/patches/restore-traditional-menubar.patch:
    - use correct keybinding label for play/pause (lp: #1274726)
  * debian/patches/git_sync_option.patch:
    - don't have the sync option area having a 0 height (lp: #1513251)
  * debian/patches/git_sync_grid.patch:
    - sync: replace the sync state GtkTable with a grid

 -- Sebastien Bacher <email address hidden> Thu, 05 Nov 2015 16:50:08 +0100

Changed in rhythmbox (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for rhythmbox has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.