rhytmbox player not display cp1251 tags on playlist

Bug #149765 reported by blackliteon on 2007-10-06
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Won't Fix
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Just run it & you see invalid letters in russian songs-names.

ProblemType: Bug
Architecture: i386
Date: Sat Oct 6 13:38:57 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: video
Package: rhythmbox 0.11.2-0ubuntu4
PackageArchitecture: i386
ProcCmdline: rhythmbox
ProcCwd: /home/dima
ProcEnviron:
 PATH=/home/dima/mono-1.2.4/bin:/home/dima/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux dima-desktop 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT 2007 i686 GNU/Linux

blackliteon (blackliteon) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you attach an example to the bug? Does other software like totem display the correct title, it's possible that the tags encoding is not correct

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox:
status: Incomplete → Invalid

I give you example file & rsult screenshots. It's general problem. Why you
close this bug ?

2007/11/7, Pedro Villavicencio <email address hidden>:
>
> We are closing this bug report as it lacks the information, described in
> the previous comments, we need to investigate the problem further.
> However, please reopen it if you can give us the missing information and
> don't hesitate to submit bug reports in the future.
>
> ** Changed in: rhythmbox (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> rhytmbox player not display russian letters in playlist
> https://bugs.launchpad.net/bugs/149765
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Дмитрий Николаев, http://dn-live.blogspot.com
icq: 226430404
skype: faustmen

there is no comment about an example or an screenshot to the bug, could you try to attach those again?

Divius (lord-divius) wrote :

As far as I understand the thing is that a lot of mp3's id3 tags are encoded in windows-1251 not in unicode. and most players do not detect local encodings. this is also valid for at least amarok, totem and nautilus (file properties, "Audio" tab). Audacious has an option to autodetect local encodings and it also allows to input default encoding.

Divius (lord-divius) wrote :

Forgot to say, this is valid for Ubuntu 8.10, Rhythmbox 0.11.6

Divius (lord-divius) wrote :

I've provided required information. Still valid for Ubuntu 8.10

Changed in rhythmbox:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the bug should be sent to bugzilla.gnome.org

Pedro Villavicencio (pedro) wrote :

did somebody sent this upstream? may you tell us the bug number there? could you try with latest version of rhythmbox on jaunty and see if the issue is fixed there? thanks.

Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Dmitry Tantsur (divius) wrote :

The bug is valid for Jaunty,
And it at least was upstream but in vain. They are not interested in compatibility with large amount of music created for Windows player's. Of course there is a possibility to convert all id3 tags to Unicode but they in turn will be incompatible with almost all portable players. So Russian users have these ways:
1) Use players like Audacious which provide support for implicit defining an encoding;
2) Convert tags. Then the tags won't be displayed in portable players.
3) Convert files to ogg. Then there will be a significant loss in quality (because source files quality is already bad) and not all portable players will read these files.

A patch to provide an entry with encoding settings should be simple but I'm totally out of time now...

Dmitry Tantsur (divius) on 2009-08-01
Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed

Still valid for 9.10 karmic, and rhythmbox 0.12.5

Here's some free samples with Russian tags for download: http://www.last.fm/music/Invisible+Border/Так+Свободы+Гасло+Солнце...

Sebastien Bacher (seb128) wrote :

The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Please read my comments. Upstream considers this a "local" problem.
Their reaction was "convert your media collection". I would be a nice
(though troublesome) decision but then portable mp3-players won't
understand such converted id3 tags.

2009/10/27, Sebastien Bacher <email address hidden>:
> The issue is an upstream one and it would be nice if somebody having it
> could send the bug the to the people writting the software
> (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)
>
> --
> rhytmbox player not display russian letters in playlist
> https://bugs.launchpad.net/bugs/149765
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “rhythmbox” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: rhythmbox
>
> Just run it & you see invalid letters in russian songs-names.
>
> ProblemType: Bug
> Architecture: i386
> Date: Sat Oct 6 13:38:57 2007
> DistroRelease: Ubuntu 7.10
> ExecutablePath: /usr/bin/rhythmbox
> NonfreeKernelModules: video
> Package: rhythmbox 0.11.2-0ubuntu4
> PackageArchitecture: i386
> ProcCmdline: rhythmbox
> ProcCwd: /home/dima
> ProcEnviron:
> PATH=/home/dima/mono-1.2.4/bin:/home/dima/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=ru_RU.UTF-8
> SHELL=/bin/bash
> SourcePackage: rhythmbox
> Uname: Linux dima-desktop 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT
> 2007 i686 GNU/Linux
>

the bug should probably be closed if the issue is buggy encoding on your side and not a bug in rhythmbox

There is a difference between "buggy" and "unexpected". ~90% of music
in Russian is encoded in cp1251, portable players with Russian mp3
support also assume that is's in cp1251. But it's expected by
Rhythmbox to be in Unicode. It may be not very good but it's the case.
And it's much simplier to patch Rhythmbox then to patch all mp3
players sold in Russia.

Actually, encoding in Russian is a "special-case".

2009/10/27, Sebastien Bacher <email address hidden>:
> the bug should probably be closed if the issue is buggy encoding on your
> side and not a bug in rhythmbox
>
> --
> rhytmbox player not display russian letters in playlist
> https://bugs.launchpad.net/bugs/149765
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “rhythmbox” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: rhythmbox
>
> Just run it & you see invalid letters in russian songs-names.
>
> ProblemType: Bug
> Architecture: i386
> Date: Sat Oct 6 13:38:57 2007
> DistroRelease: Ubuntu 7.10
> ExecutablePath: /usr/bin/rhythmbox
> NonfreeKernelModules: video
> Package: rhythmbox 0.11.2-0ubuntu4
> PackageArchitecture: i386
> ProcCmdline: rhythmbox
> ProcCwd: /home/dima
> ProcEnviron:
> PATH=/home/dima/mono-1.2.4/bin:/home/dima/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=ru_RU.UTF-8
> SHELL=/bin/bash
> SourcePackage: rhythmbox
> Uname: Linux dima-desktop 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT
> 2007 i686 GNU/Linux
>

could you attach an example to the report for testing purposes ? otherwise is hard for us to try to reproduce the issue. Thanks.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Dmitry Tantsur (divius) wrote :

Here you are

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=600559

summary: - rhytmbox player not display russian letters in playlist
+ rhytmbox player not display cp1251 tags on playlist
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Pedro Villavicencio (pedro) wrote :

comment from an upstream developer:
"cp1251 is not a valid encoding for id3v2 tags, rhythmbox won't support randomly
broken tags (there's already a duplicate bug report about that). The
GST_ID3_TAG_ENCODING environment variable can be used to workaround this issue
if you really don't want to fix your tags."

closing this as wontfix too, please comment on the upstream report if you're not agreed with that.

Changed in rhythmbox (Ubuntu):
status: Triaged → Won't Fix
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Won't Fix
Sasa Stamenkovic (umpirsky) wrote :

Bug exists in latest version. It does not happens only for mp3's, but for Russian radio stations as well.

You can try to play http://188.127.243.169/nashe-64.m3u, and you'll see invalid chars like in attachment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.