transfering songs to iPod incorrectly modifies the year id3 tag

Bug #144273 reported by Zachary Berry on 2007-09-23
8
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Unassigned

Bug Description

When files are transferred to an iPod, the 'year' part of the tag is copied incorrectly onto the device. It appears to use a fragment of the unix time instead. For example, 2007 becomes 11781, 2008 becomes 12146, etc.

This issue has been experienced both on Ubuntu 8.04 with rhythmbox 0.11.5-0ubuntu7 and an iPod shuffle 1GB, as well as Ubuntu 7.04 with rhythmbox 0.10.0 and a 4G iPod 40GB.

Related branches

Pedro Villavicencio (pedro) wrote :

Thanks for your report, i don't get those modifications in my files with Gutsy. Can you attach the output of "rhythmbox -d" to the report?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox:
status: Incomplete → Invalid
Hew (hew) wrote :

This bug is still present in Ubuntu Hardy with rhythmbox 0.11.5-0ubuntu7 when transferring to my iPod shuffle. To clarify the original report; the file on the computer does not change, but the year field is incorrect for the copy created on the iPod.

Years seem to be based on the beginning of the corresponding unix time: 2005 -> 11051; 2006 -> 11416; 2007 -> 11781; 2008 -> 12146.

To reproduce: Copy a file to an iPod with rhythmbox
What should happen: File on the iPod has the same year as on the computer (eg. 2008)
What actually happens: File on the iPod has a silly number as the year (eg. 12146)

Changed in rhythmbox:
status: Invalid → New
Hew (hew) on 2008-05-31
description: updated
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs only because you have a similar issue

Changed in rhythmbox:
status: New → Invalid
Hew (hew) wrote :

I'm sorry? This is the same issue. You said "please reopen it if you can give us the missing information", as the first reporter left it incomplete. I have that information, which is a clarification of the meaning of "modified" (modified on the iPod, not modified on the computer). That is why I reopened the bug. If you are still not convinced that this is the same bug, please point out the information that conflicts with our issues. Thank you.

Changed in rhythmbox:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

you didn't attach the requested information no, did you read the comments before reopening the bug?

Changed in rhythmbox:
status: New → Incomplete
Hew (hew) wrote :

My apologies. I thought that the information would only be required if the bug existed with the file on the computer as it was originally interpreted, not with the file on the iPod. I have attached the output of rhythmbox -d with a clean rhythmbox and clean iPod.

Hew (hew) wrote :
Hew (hew) wrote :
Changed in rhythmbox:
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

confirmed, the submitter meant in the rhythmbox ipod view which was not clear reading the description, the bug has been sent on http://bugzilla.gnome.org/show_bug.cgi?id=536194 now

Changed in rhythmbox:
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in rhythmbox:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.11.5-5ubuntu2

---------------
rhythmbox (0.11.5-5ubuntu2) intrepid; urgency=low

  * debian/patches/70_from_svn_fix_incorrect_shuffle_detection.patch:
    - change from svn, correctly detect the new ipod shuffle devices
  * debian/patches/71_from_svn_fix_ipod_aac_copies.patch:
    - change from svn, don't convert aac when they are copied to an ipod
      (lp: #164265)
  * debian/patches/72_from_svn_ipod_correct_set_year_tag.patch:
    - change from svn, correctly set the year when copying a song to an ipod
      (lp: #144273)

 -- Sebastien Bacher <email address hidden> Thu, 12 Jun 2008 10:44:02 +0200

Changed in rhythmbox:
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in rhythmbox:
importance: Undecided → Low
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in rhythmbox:
status: Confirmed → Fix Committed
Hew (hew) wrote :

I can confirm that with this version, the issue has been resolved, and I have not experienced any regressions. Thank you :-)

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in rhythmbox:
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.