rhythmbox crashed with SIGSEGV in totem_pl_parser_parse_with_base()

Bug #1392389 reported by Andrew J. Wippler on 2014-11-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
High
Unassigned

Bug Description

I am behind a firewall that requires me to login before I can use the internet. When rhythmbox checks podcast feeds when I am not logged in, I am greeted with a crash report with "rhythmbox crashed with SIGSEGV in totem_pl_parser_parse_with_base()" as the title.

It would be nice if the function threw an exception when did not get what it expected and present an error rather than a crash. I would submit a patch, but do not have the coding expertise to do so :/

When I am logged into our filter to access the internet, I do not get this crash. It only happens when I am not logged into the filter.

Description: Ubuntu 14.04.1 LTS
Release: 14.04
rhythmbox:
  Installed: 3.0.2-0ubuntu2
  Candidate: 3.0.2-0ubuntu2
  Version table:
 *** 3.0.2-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.0.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Sebastien Bacher (seb128) wrote :

Could you get a backtrace of the segfault using gdb? It could be the issue fixed by https://git.gnome.org/browse/rhythmbox/commit/?id=df6a04a

Changed in rhythmbox (Ubuntu):
importance: Undecided → High

The patch solved the issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
rithik g (gkrithi) on 2017-11-01
Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers