Rythym Box Stops playing

Bug #138359 reported by kwan on 2007-09-09
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I'm not sure when this happens, but from time to time (I think especially after manually skipping songs in the playlists), Rhythmbox stops playing the next track in the list. It does highlight it, and it's not set on pause, however the timer remains at 0:00. Once I click on the seek-button, the song starts playing. When I skip through my playlist, it plays some songs automatically, while at others the aforementioned problem occurs. The songs which are not playing seem to be kind of random, there's usually one which never works, while others sometimes play and sometimes don't.

I think this problem does not occur, if I let Rhythmbox play through one complete album. But if I add specific songs from that album to my own playlist, they start making trouble. Does anyone know what could cause this?

kwan (cbruner) wrote :

Sorry, but the above description is a copy of a previously reported bug that was not responded to in 15 days, so removed. I am also experiencing this exact same bug with Ubuntu 7.04 and Rythym Box 0.10.0-Oubuntu2.

At the time this happened (not that I think it should matter?) I had multiple copies of Firefox open, and Synapitc open.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Can you send us as an attachment the output of rhythmbox -d ? thanks in advance. Also a couple of easy steps for reproduce the bug would be nice.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete

Pedro:

Below is the output:

(19:34:06) [0x80f4028] [rb_debug_init_match] rb-debug.c:141: Debugging
enabled
(19:34:06) [0x80f4028] [main] main.c:206: initializing Rhythmbox 0.10.0
(19:34:06) [0x80f4028] [rb_threads_init] rb-util.c:460: GMutex isn't
recursive
(19:34:06) [0x80f4028] [main] main.c:215: going to create DBus object
(19:34:06) [0x80f4028] [main] main.c:402: THE END

The error is random, or seems to be. Once it starts, it doesn't seem to
stop, but after logoff, restart it isn't an issue.

I can't get it consistently. The above output is not while this problem was
occurring ... if it comes up, I'll run it then too.

Regards,

Cal

On 9/13/07, Pedro Villavicencio <email address hidden> wrote:
>
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Can you send us as an attachment the output of rhythmbox
> -d ? thanks in advance. Also a couple of easy steps for reproduce the
> bug would be nice.
>
> ** Changed in: rhythmbox (Ubuntu)
> Importance: Undecided => Medium
> Assignee: (unassigned) => Ubuntu Desktop Bugs
> Status: New => Incomplete
>
> --
> Rythym Box Stops playing
> https://bugs.launchpad.net/bugs/138359
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pedro Villavicencio (pedro) wrote :

Is your DBus service running?

kwan (cbruner) wrote :

I don't know what it is, but yes, it is running. The problem reported isn't
currently occurring however? Seemed to be an intermittent event?

On 9/20/07, Pedro Villavicencio <email address hidden> wrote:
>
> Is your DBus service running?
>
> --
> Rythym Box Stops playing
> https://bugs.launchpad.net/bugs/138359
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pedro Villavicencio (pedro) wrote :

Seems to be more a problem related to dbus rather than a rhythmbox one, which version of Ubuntu are you using? is that reproducible with Gutsy?

kwan (cbruner) wrote :

I had the issue on 7.04. I haven't attempted it with Gutsy (that would
require me, the newbie, figuring out how to install a new version without
just hitting the update button ;)

This error isn't easily reproducible, unfortunately.

It happens or it doesn't. Fortunately it doesn't happen a lot.

On 10/4/07, Pedro Villavicencio <email address hidden> wrote:
>
> Seems to be more a problem related to dbus rather than a rhythmbox one,
> which version of Ubuntu are you using? is that reproducible with Gutsy?
>
> --
> Rythym Box Stops playing
> https://bugs.launchpad.net/bugs/138359
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pedro Villavicencio (pedro) wrote :

Closing this bug for now, feel free to re open it if you can reproduce it with Gutsy, thanks.

Changed in rhythmbox:
status: Incomplete → Invalid
TheSilencer (da-silencer) wrote :

This is dumped from "rhythmbox -d" on Ubuntu 7.10
Stops playing when skipping forward in a song. Happens almost every time I try.

The "*********************" is the song I am playing. Wiped out by me.

(10:51:02) [0x6c9500] [slider_moved_callback] rb-header.c:548: slider is not dragging
(10:51:02) [0x6c9500] [rb_shell_window_configure_cb] rb-shell.c:1568: storing window size of 1390:969
(10:51:02) [0x6c9500] [rb_shell_window_configure_cb] rb-shell.c:1568: storing window size of 1390:969
(10:51:02) [0x6c9500] [rb_shell_window_configure_cb] rb-shell.c:1568: storing window size of 1390:969
(10:51:02) [0x6c9500] [slider_release_callback] rb-header.c:590: setting time to 15
(10:51:02) [0x6c9500] [tick_cb] rb-shell-player.c:3148: tick: [file:///media/Lagring/Musik/Album/********************************, 25:185(0)]
(10:51:02) [0x6c9500] [rb_shell_player_error] rb-shell-player.c:2962: playback error while playing: Internt fel i dataflöde.
(10:51:02) [0x6c9500] [error_cb] rb-shell-player.c:3109: exiting error hander
(10:51:02) [0x6c9500] [slider_moved_callback] rb-header.c:548: slider is not dragging
(10:51:03) [0x6c9500] [slider_moved_callback] rb-header.c:548: slider is not dragging
(10:51:03) [0x6c9500] [slider_moved_callback] rb-header.c:548: slider is not dragging

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions