Rhythmbox zeitgeist plugin doesn't activate when selected in Rhythmbox plugin preferences

Bug #1313914 reported by Nicola Jelmorini on 2014-04-28
80
This bug affects 18 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

When I open the Rhythmbox plugin's preferences dialog, and I click on the check-box for the zeitgeist plugin, an error icon is displayed instead of the regular check-box mark.
Attached to this bug report there is a screenshot of the plugins dialog with the error for the zeitgeist plugin.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: rhythmbox-plugin-zeitgeist 3.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Apr 28 22:40:36 2014
InstallationDate: Installed on 2014-04-23 (5 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Nicola Jelmorini (jelmorini) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Mehdi Sadeghi (mehdix) wrote :

I tried to investigate this problem a little bit, the problem is about importing zeitgeist module in python. In python 2.7 you can import zeitgeist with no error, but in python 3 you will get import error.
I tried to install python3 version of zeitgeist but it seems that upstream has not released an stable version of zeitgeist module for python.

tags: added: xenial yakkety
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
tags: added: yakety
removed: yakkety
Khurshid Alam (khurshid-alam) wrote :

Why was it set to low importance? Because of missing zeitgeist-python3 plugin searching music from Unity simply doesn't work. I guess, upstream has no interest fixing this as Unity 7 desktop is going down.

Pander (pander) on 2016-06-01
tags: added: yakkety
removed: yakety
vrishab (vrishab-in) wrote :

Rhythmbox 3.3 / Ubuntu 16.04 LTS:

rhythmbox error log when enabling the zeitgeist plugin:

(rhythmbox:3257): libpeas-WARNING **: Error importing plugin 'rbzeitgeist':
Traceback (most recent call last):
  File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 986, in _gcd_import
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 958, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 673, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 665, in exec_module
  File "<frozen importlib._bootstrap>", line 222, in _call_with_frames_removed
  File "/usr/lib/rhythmbox/plugins/rbzeitgeist/rbzeitgeist.py", line 35, in <module>
    from zeitgeist.client import ZeitgeistClient
ImportError: No module named 'zeitgeist'

(rhythmbox:3257): libpeas-WARNING **: Error loading plugin 'rbzeitgeist'

Jörg Eichhorn (jeichhor) wrote :

rhythmbox-plugin-zeitgeist Version: 3.4.2-4ubuntu1

(rhythmbox:19124): libpeas-WARNING **: 13:13:45.483: Error importing plugin 'rbzeitgeist':
Traceback (most recent call last):
  File "/usr/lib/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 678, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/lib/rhythmbox/plugins/rbzeitgeist/rbzeitgeist.py", line 35, in <module>
    from zeitgeist.client import ZeitgeistClient
ModuleNotFoundError: No module named 'zeitgeist'

(rhythmbox:19124): libpeas-WARNING **: 13:13:45.483: Error loading plugin 'rbzeitgeist'

tags: added: bionic
Jeremy Bicha (jbicha) on 2019-02-04
Changed in rhythmbox (Ubuntu):
importance: Low → Medium
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers