Update to bug-fix release 3.0.2 in Trusty

Bug #1296334 reported by fossfreedom on 2014-03-23
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
High
Unassigned

Bug Description

Upstream has released 3.0.2 of Rhythmbox.

This is just a bug-fix release - see the NEWS for the release.

 - https://github.com/GNOME/rhythmbox/commit/72b998294cba6af6d6a1b8077482a9df1c787ac4

Overview of changes in Rhythmbox 3.0.2
======================================

* Assorted bug fixes

Bugs fixed:

678938 - Selectable text for playing song interferes with dragging by toolbar
692485 - application hangs clicking on devices with undefined playlist_path
701598 - rhythmbox seems to always be compiled with --enable-uninstalled-build
705105 - Rhythmbox while playing disables automatic screen lock
707144 - Rhythmbox doesn't support itmss:// links
707525 - Last.fm radio stations can't be properly deleted
707618 - Trying to play a file missing on disk crashes rhythmbox in
         rb-player-gst.c:516
708084 - podcast: Local file name is not escaped
708201 - Core dumped when running on Wayland
708341 - Transfer to mass storage player hangs after last song
710493 - Gdk assertion failed: invalid cairo image surface format
710832 - Removing a song from the Play Queue removes it from the Library
711285 - Cannot play remote files (sftp/gvfs) in library
712237 - Rhythmbox segfaults on broken cover images
712699 - Take into account the size of header button for column width
715177 - running rhythmbox-client --play-uri file:///path/to/song with
         rhythmbox closed only starts the app, not the song
719514 - cairo crash on playback whenever coverart search plugin is enabled
719777 - data: Add audio/mp4 as a supported mime-type
720116 - app menu: standardize Help/About/Quit
720217 - If transfer to device fails with non-sanitized filename, try with
         sanitized one
720819 - header: vertically centralize the "Not playing" label
721550 - License text contains obsolete FSF postal address
721758 - Please add search by genre
722069 - Incorrect links to the website
722782 - link to Rhythmbox Home Page is invalid
723839 - audioscrobbler: Invalid path passed to g_settings_new_with_path()
724931 - rhythmbox crashed with SIGSEGV in rb_list_model_find()
725625 - Absolute Radio Stations Should No Longer Be Included as Default
         (not streaming outside of UK)
726167 - .linked class is set on toolbar buttons instead of their container

Translation updates:

- cs, courtesy of Marek Černocký
- de, courtesy of Christian Kirbach
- es, courtesy of Daniel Mustieles
- fr, courtesy of Claude Paroz
- gl, courtesy of Fran Dieguez
- hu, courtesy of Gabor Kelemen
- it, courtesy of Milo Casagrande
- lt, courtesy of Aurimas Černius
- pl, courtesy of Piotr Drąg
- pt_BR, courtesy of Rafael Ferreira
- pt, courtesy of Tiago S.
- ru, courtesy of Yuri Myasoedov
- sl, courtesy of Matej Urbančič
- sr, courtesy of Мирослав Николић
- sr@latin, courtesy of Miroslav Nikolić
- zh_CN, courtesy of YunQiang Su

As such, it is a perfect candidate to allow this in for an exception for Trusty given that we are still over a month away from release.

I've confirmed that all current git patches included in Rhythmbox v3.0.1 in Trusty are included in this v3.0.2 release.

Also I've confirmed that the Ubuntu specific patch work also works in v3.0.2 that is as follows:

The debian/series file needs only contain the following entries - everything else in the v3.0.1 version can be removed from this file and the associated patches folder:

02_use_escaped_podcast_uri.patch
03_magnatune_partner.patch
05_hide_on_quit.patch
07_quicklists.patch
10_encoding_use_ubuntu_profiles.patch
make-shuffle-repeat-proper-toggle-actions.patch
restore-traditional-menubar.patch

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: rhythmbox 3.0.1-1ubuntu16
ProcVersionSignature: Ubuntu 3.13.0-19.39-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 23 16:54:24 2014
InstallationDate: Installed on 2014-02-22 (29 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140220.1)
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

fossfreedom (fossfreedom) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
tags: added: upgrade-software-version
summary: - please SRU and package rhythmbox v3.0.2 for Trusty
+ Update to bug-fix release 3.0.2 in Trusty
description: updated
Amr Ibrahim (amribrahim1987) wrote :

Could this be packaged for Trusty?

It simplifies software contents, bug fixing or development.

Changed in rhythmbox (Ubuntu):
importance: Undecided → High
amano (jyaku) wrote :

"Removing a song from the Play Queue removes it from the Library"

That sounds like a bummer. I think that 3.02 should go into the LTS, if possible, as it is a pure bugfix release

Subscribing Sebastian Bacher, in case he doesn't know already about the minor release.

Sebastien Bacher (seb128) wrote :

Thanks, we know about this update, some of the fixes are in trusty but it seems like it would still be a good one to do

amano (jyaku) wrote :

If you are at it, you could consider if you want to update VLC as well. There has been an update to 2.1.3 at the end of February (Trusty ships 2.1.2): http://www.videolan.org/developers/vlc-branch/NEWS

 * Fix a crash with the simple volume widget
 * Fix a crash in the audio menu building

 * Fix encrypted DVD playback

Those fixes sound like we would like to have them in the LTS.

Sebastien Bacher (seb128) wrote :

> If you are at it, you could consider if you want to update VLC as well.

Sorry but no, I've never touched vlc/I don't use it/we don't ship it by default/I've already enough to work on

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 3.0.2-0ubuntu1

---------------
rhythmbox (3.0.2-0ubuntu1) trusty; urgency=medium

  * New upstream bugfix version (lp: #1296334)
  * Clean patches included in the update
  * debian/librhythmbox-core8.symbols:
    - new version update
 -- Sebastien Bacher <email address hidden> Thu, 03 Apr 2014 17:23:01 +0200

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers