Rhythmbox displays the wrong album art

Bug #1295925 reported by Mike Doherty on 2014-03-22
60
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Undecided
Unassigned

Bug Description

Rhythmbox displays album art itself at the top of the window, among the controls. It also sends album art to notify-osd for display in notification bubbles, and in indicator-sound. Rhythmbox is using the wrong album art much of the time. In the instant case, the mp3 files have no embedded album art, so I would expect either the correct album art is downloaded, or none is displayed (default image or blank). Instead, album art is apparently picked randomly from my music collection.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: rhythmbox 2.99.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-18.32-generic 3.11.10.4
Uname: Linux 3.11.0-18-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Fri Mar 21 23:17:25 2014
InstallationDate: Installed on 2013-01-12 (433 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: rhythmbox
UpgradeStatus: Upgraded to saucy on 2013-10-23 (149 days ago)

Mike Doherty (doherty) wrote :
Mike Doherty (doherty) wrote :
M Oberhauser (zomtir) wrote :

A workaround is to clear this folder.
~/.cache/rhythmbox/album-art

No idea how the files were named the way the are, but RB assignes them to songs that don't have an album cover and somehow fit into the criteria.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better.

It would be useful if any of the affected users could test if the issue is be reproducible with the live environment of the Desktop ISO of the development release - Trusty Tahr. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu.

You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Mike Doherty (doherty) wrote :

Yes, this is still present in 14.04.

Changed in rhythmbox (Ubuntu):
status: Incomplete → Confirmed
Shane Synan (digitalcircuit) wrote :

I can confirm this happens quite often to me, on both desktop and laptop 14.04 installs. As suggested in #3, clearing the cached album art folder fixes it, then in a short period of time it degrades into a mess for FLAC and MP3 files.

While I have not tested this solution, the bug might be related to the problem mentioned here (random album art): https://askubuntu.com/a/454692/3406

I'm willing to help with any sort of testing needed.

This issue seems to be an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please report here the number of the upstream bug (or the link), so it can be added as a bugwatch that will inform us about its status. Thanks in advance.

Hi,
As I am also affected by the bug I reported it upstream, link https://bugzilla.gnome.org/show_bug.cgi?id=743493

Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → New
Changed in rhythmbox:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.