rhythmbox crashed with SIGSEGV in rb_list_model_find()

Bug #1273260 reported by Simon Déziel on 2014-01-27
110
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Critical
rhythmbox (Ubuntu)
Medium
Unassigned

Bug Description

This crash occured when trying to import my music collection (contains many formats: mp3, ogg, etc).

$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

$ apt-cache policy rhythmbox
rhythmbox:
  Installed: 3.0.1-1ubuntu8
  Candidate: 3.0.1-1ubuntu8
  Version table:
 *** 3.0.1-1ubuntu8 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: rhythmbox 3.0.1-1ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic x86_64
ApportVersion: 2.13.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Jan 27 09:24:14 2014
ExecutablePath: /usr/bin/rhythmbox
InstallationDate: Installed on 2014-01-26 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140124)
ProcCmdline: rhythmbox
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f00ee828827 <rb_list_model_find+119>: cmp (%rax),%rsi
 PC (0x7f00ee828827) ok
 source "(%rax)" (0xffffffff) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 rb_list_model_find () from /usr/lib/librhythmbox-core.so.8
 rb_list_model_remove_item () from /usr/lib/librhythmbox-core.so.8
 ?? () from /usr/lib/librhythmbox-core.so.8
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: rhythmbox crashed with SIGSEGV in rb_list_model_find()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Simon Déziel (sdeziel) wrote :
information type: Private → Public

StacktraceTop:
 rb_list_model_find (model=model@entry=0x7f00cc012b80, item=0x7f00b4060fa0) at rb-list-model.c:179
 rb_list_model_remove_item (model=0x7f00cc012b80, item=<optimized out>) at rb-list-model.c:277
 task_expired (expiry=0x25a2190, expiry@entry=<error reading variable: value has been optimized out>) at rb-task-list.c:138
 g_timeout_dispatch (source=0x15371a0, callback=<optimized out>, user_data=<optimized out>) at /build/buildd/glib2.0-2.39.3/./glib/gmain.c:4452
 g_main_dispatch (context=0xa69da0) at /build/buildd/glib2.0-2.39.3/./glib/gmain.c:3068

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
John Leach (johnleach) wrote :

Same for me under saucy with 3.0.1-1ubuntu6~saucy1 - importing process scans files for a bit and then crashes.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7b7b8d7 in rb_list_model_find () from /usr/lib/librhythmbox-core.so.8
(gdb) bt
#0 0x00007ffff7b7b8d7 in rb_list_model_find () from /usr/lib/librhythmbox-core.so.8
#1 0x00007ffff7b7bb49 in rb_list_model_remove_item () from /usr/lib/librhythmbox-core.so.8
#2 0x00007ffff7af2769 in ?? () from /usr/lib/librhythmbox-core.so.8
#3 0x00007ffff725cf53 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007ffff725c3f6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5 0x00007ffff725c748 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6 0x00007ffff725c7ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7 0x00007ffff1a38acc in g_application_run () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#8 0x00007ffff7ad72e2 in rb_application_run () from /usr/lib/librhythmbox-core.so.8
#9 0x0000000000400d22 in main ()

Same looking report in Fedora here too: https://bugzilla.redhat.com/show_bug.cgi?id=1013858

Changed in rhythmbox:
importance: Unknown → Critical
status: Unknown → New
Changed in rhythmbox:
status: New → Fix Released
Adam Smith (adam-disc0tech) wrote :

I just had this crash while importing (on the point of a file dialog opening), in Trusty daily from March 13th.

Michael Foord (mfoord) wrote :

Importing from what used to be an iTunes library from a network location.

Changed in rhythmbox:
status: Fix Released → New
Changed in rhythmbox:
status: New → Fix Released
LAZA (laza74) wrote :

Got this crash today - either the fix is no in the actual release or it is not fixed!

Version: 3.0.2-0ubuntu2

LAZA (laza74) wrote :

Status?

I can confirm this bug TODAY in Trusty 64 bit and it is NOT FIXED!

Or should i open up a new bug report?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.