Rhythmbox 2.99.1 bug

Bug #1242806 reported by Tamburrino Roberto on 2013-10-21
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
High
Unassigned

Bug Description

Rhytmbox bugs , crush after a song, the side covers riquedro the word artist and song list
[code][rhythmbox

(rhythmbox:9451): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid). Unable to remove object from construction_objects list, so memory was probably just leaked. Please use GInitable instead.
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 88, in do_activate
    self.save_status ()
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 193, in save_status
    self.saved_purple = self.get_purple_status ()
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 255, in get_purple_status
    except gi._glib.GError as e:
AttributeError: 'module' object has no attribute 'GError'
ERROR:root:Could not find any typelib for Secret
ERROR:root:Could not find any typelib for SecretUnstable

(rhythmbox:9451): Rhythmbox-WARNING **: Could not open device /dev/radio0
Unable to open ~/.mtpz-data for reading, MTPZ disabled.Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 112, in playing_entry_changed
    self.set_entry (entry)
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 134, in set_entry
    self.save_status ()
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 193, in save_status
    self.saved_purple = self.get_purple_status ()
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 255, in get_purple_status
    except gi._glib.GError as e:
AttributeError: 'module' object has no attribute 'GError'
Traceback (most recent call last):
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 105, in playing_changed
    self.set_entry (sp.get_playing_entry ())
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 134, in set_entry
    self.save_status ()
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 193, in save_status
    self.saved_purple = self.get_purple_status ()
  File "/usr/lib/rhythmbox/plugins/im-status/im-status.py", line 255, in get_purple_status
    except gi._glib.GError as e:
AttributeError: 'module' object has no attribute 'GError'
Errore di segmentazione (core dump creato)
[/code]

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed

After crashing with the same error as the one reported, I used to not be able to run rhythmbox again at all. Therefore, I have been using "rhythmbox --disable-plugins" to do so, but no plugins though.

This should be fixed in rhythmbox >= 3.0
If the error is still occurring in Ubuntu 14.04/Trusty, please let me know.
Thanks.

summary: - Rhytmbox 2.99.1 bug
+ Rhythmbox 2.99.1 bug
Changed in rhythmbox (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.