Rhythmbox sound problems (clicking/snapping/crackling) when not using crossfading backend

Bug #116990 reported by Benjamin_L on 2007-05-26
204
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ALSA Libraries
Fix Released
Unknown
Rhythmbox
Unknown
High
alsa-lib (Debian)
Fix Released
Unknown
alsa-lib (Ubuntu)
High
Unassigned
rhythmbox (Mandriva)
Fix Released
Medium
rhythmbox (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

This may not be related to rhythmbox at all, maybe to the sound driver so let me describe my system:

Running latest gutsy, Audigy2 soundcard, 2.6.22 kernel

After upgrading to rhythmbox 0.10.90 I get clicks, glitches, cracks, don't know whats exactly the right way to describe the strange noises. It doesn't happen on all tracks but is reproducible all the time.

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does it happen while playing? Do you get the bug if you use gst-launch-0.10 playbin uri=file:///path/to/file?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Benjamin_L (benjamin-lebsanft) wrote :

Yeah, otherwise it wouldn't be that annoying. Seems to happen only with vorbis files as far as I noticed.

By using your command I get:
benni@ubuntu:~$ gst-launch-0.10 playbin /home/benni/Musik/Harvey\ Danger-Little\ by\ Little/music/Harvey\ Danger_Little\ by\ Little_05.\ Happiness\ Writes\ White.ogg
Pausiere Leitung ...
FEHLER: Leitung möchte nicht pausiert werden.
FEHLER: Von Element /playbin0: Keine URI zum Abspielen angegeben.
Zusätzliche Debugginginformation:
gstplaybasebin.c(1550): gen_source_element (): /playbin0
Setze Pipeline auf NULL...
BEREINIGE Pipeline...

Sebastien Bacher (seb128) wrote :

you have to use "uri="

Benjamin_L (benjamin-lebsanft) wrote :

Too stupid to read... sorry

No strange sounds this way

Sebastien Bacher (seb128) wrote :

could you get a log using "rhythmbox -d &>log", play a file having the bug and attach the log to the bug?

Benjamin_L (benjamin-lebsanft) wrote :

Here is the concerning part

Benjamin_L (benjamin-lebsanft) wrote :

can't find something special while playing the song

Benjamin_L (benjamin-lebsanft) wrote :

musepack files also suffer, mp3 and flac is fine

DarkMageZ (darkmagez) wrote :

this may be related to gnome bug 436192. if you're up for it, you can either pull the gusty rhythmbox sources and remove lines 553 - 607 from rhythmbox/backends/gstreamer/rb-player-gst.c or pull svn and do an installed build with those lines removed.

Changed in rhythmbox:
status: Needs Info → Confirmed
Changed in rhythmbox:
status: Unknown → Unconfirmed
VF (vfiend) wrote :

Easy temporary workaround from GNOME bug: Open Preferences, then check 'Use crossfading backend' on the Playback tab

I can also confirm this bug. It also happens with MP3's by the way. Its
Using the crossfading plugin also fixes the issue for me.

The word I would use to describe it is choppyness. Like it gets amplified beyond its reach.
The fact that the crossfading makes it go away, suggests it not related to file-type, but rather with the output plugin. It isn't (directly) a gstreamer issue, because Totem does not have the same issue.

Thom Pischke (thom-pischke) wrote :

Can confirm. Awful sound coming out of Rhythmbox after upgrading to Gutsy. So much chop that rhythmbox is so annoying as to be unusable.

00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

Thom Pischke (thom-pischke) wrote :

Can also confirm that using the Crossfading backend workaround from VF does improve the situation and that files play fine from Totem.

Changed in rhythmbox:
importance: Low → Medium

New install of Gusty Gibbon Tribe 4 - same crackly sound when playing
Mp3. To temporarily resolve this issue, turn the volume in Rhythmbox
down, it is located in the upper right hand corner. By default the
program is putting the volume at max, which is send too high of a signal
to the sound card, causing the distortion. I was able to turn the
Rhythmbox volume down and turn up my Master System volume, and Speaker
volume, and had no distortion.

Matti Lindell (mlind) wrote :

I have this problem with alsa. There's no distortion if I use pulse sink instead.
Workaround for alsa is to lower the volume slightly from Rhythmbox itself or use crossfading backend.

Same problem over here, solution with crossfading checkbox did wonders. Have got an audigy soundcard.

freqk (freqk79) wrote :

Confirming bug here also, using gusty.
Crossfading fixes the issue.

Changed in rhythmbox:
status: Confirmed → Triaged
Changed in rhythmbox:
importance: Medium → High
8200 (8200) wrote :

The workaround "in Rhythmbox --> Preferences --> Playback --> 'Use crossfading backend'" seems to fix my posted problem.

I think it would be better when Rhythmbox has this setting default.

Thank you!

Benjamin_L (benjamin-lebsanft) wrote :

I didn't have any of these problems anymore for quite some time now and I'm not using the crossfade backend.

description: updated

Hmm...

Maybe you haven't heard a loud OGG/MP3?

I can send you a 2,5MB if you like to test it - via email?

Arthur

On Die, 2007-09-04 at 18:38 +0000, Benjamin_L wrote:
> I didn't have any of these problems anymore for quite some time now and
> I'm not using the crossfade backend.
>
> ** Description changed:
>
> Binary package hint: rhythmbox
>
> This may not be related to rhythmbox at all, maybe to the sound driver
> so let me describe my system:
>
> Running latest gutsy, Audigy2 soundcard, 2.6.22 kernel
>
> After upgrading to rhythmbox 0.10.90 I get clicks, glitches, cracks,
> - don't know whats exactly the right way to describe the starnge noises.
> + don't know whats exactly the right way to describe the strange noises.
> It doesn't happen on all tracks but is reproducible all the time.
>

Benjamin_L (benjamin-lebsanft) wrote :

I certainly don't suffer the original bug anymore as it was very obvious with almost every track I played. That doesn't imply others don't have this problem anylonger :)

xDieStarDiex (accounts-kyle) wrote :

The 'Use crossfading backend' work around has also worked for me.

Michael Rooney (mrooney) wrote :

I had this issue too in Tribe 5, though a fix for me was making the volume in Rhythmbox anything but 100% (the other system volume levels seemed irrelevant). So now I just have it at slightly less than max.

Mattias (mattiaslovkvist) wrote :

I just experienced this issue, using Rhythmbox 0.11.2, getting the problem with and without the crossfade on, i don't know any solution...
the sound works fine in all other applications, i tried at first with both audigy 1 and HDA Intel soundcard on my asus p5k deluxe mobo.
still same problem...
it only seems to happen on high bass, so songs with no bass plays fine...
its a fresh gutsy install...

ermes (matteo-pirro) wrote :

I can also confirm this bug!

unggnu (unggnu) wrote :

I can confirm this bug and the workaround with current Gutsy. It mostly happens on basses.
I am using Audigy 2 ZS Notebook.

Alex (flying-sad) wrote :

confirming.
using gutsy with kernel 2.6.22-12-generic on acer 5052, rhythmbox 0.11.2.
sound defects appear mostly on basses.
not encountered on other players (mpd).

urho (vonturha) wrote :

'Use crossfading backend' fixed this BUT can't play m4a files when crossfading backend is enabled ( https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/138728 )

AlunJ (alunjames) wrote :

Confirmed here too using gutsy beta, 2.6.22-12-generic.

Really awful clicking in mp3's, fixed by enabling crossfading plugin.

Kyle M Weller (kylew) wrote :

confirmed, I also use Ubuntu Gutsy Beta, when I play mp3's it crackles and snaps

Kyle M Weller (kylew) wrote :

yes the crossfading option seems to fix this issue for me as well, just crossfade like .1 second and its fixed.. lol that is crazy, I hope it is fixed so others dont decide to ditch rhythmbox because it rocks

Jon Leighton (jonleighton) wrote :

Same here in Gutsy Beta.

Changed in rhythmbox:
status: Unknown → Confirmed
Rodrigo Donado (frezeeer) wrote :

Hi:

crossfading option solved my problem here too. Thanks, for the help, it was kind of annoying.

EXC300 (arthur-kozek) wrote :

The first time I installed Ubuntu 7.10 on some AMD64 PC which I did not
know very well. Then I listened to music and thought "oh the soundcard
is amiss" and bought a good new one for 75€. I installed it and the same
problem was there again - damn it fucking software-problem
:D

On Mon, 2007-10-01 at 17:50 +0000, Rodrigo Donado wrote:
> Hi:
>
> crossfading option solved my problem here too. Thanks, for the help, it
> was kind of annoying.
>

Matti Lindell (mlind) wrote :

Could this be gstreamer related ? (sample.ogg is from upstream bug report 436192, comment #1)

Distorted sound:
gst-launch -v filesrc location=/tmp/sample.ogg ! decodebin ! audioconvert ! audioresample ! alsasink

Normal sound:
gst-launch -v filesrc location=/tmp/sample.ogg ! decodebin ! audioconvert ! audioresample ! volume volume=1.0 ! alsasink

8200 (8200) wrote :

@mlind:

Your related sample.ogg is a dead link, but I have tested your commands with another ogg-file:

gst-launch-0.10 -v filesrc location=Rihanna\ -\ Music\ Of\ The\ Sun\ -\ 01\ -\ Pon\ De\ Replay.ogg ! decodebin ! audioconvert ! audioresample ! alsasink
The same problem as playing it with rhythmbox - bad sound when the song is loud.

You second command works fine - good sound:
gst-launch-0.10 -v filesrc location=Rihanna\ -\ Music\ Of\ The\ Sun\ -\ 01\ -\ Pon\ De\ Replay.ogg ! decodebin ! audioconvert ! audioresample ! volume volume=1.0 ! alsasink

Pascal Schwarz (iso-thinktux) wrote :

I also have the problem, the crossfading option fixes it, but also reducing the volume (in rythmbox!) did.

Ubuntu Gutsy
IBM/Lenovo Thinkpad Z60m
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)

databoy2k (databoy2k) wrote :

Just to add in, I'm running 0.11.2 and getting the same issue
My tweak: I'm still on Feisty (Ubuntu Ultimate distro)

So it's not just something that's been broken with gutsy!
--Databoy2k

AboSamoor (abosamoor) wrote :

i confirm this BUG, the crossfading option did not solve the problem
i got this error message
ramy@ramy-desktop:~$ gst-launch-0.10 playbin uri=/media/hda5/MyMusic/AbdAL_Haleem/internet/abdelhaleem21.rm
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /playbin0: Invalid URI "/media/hda5/MyMusic/AbdAL_Haleem/internet/abdelhaleem21.rm".
Additional debug info:
gstplaybasebin.c(1579): gen_source_element (): /playbin0
Setting pipeline to NULL ...
FREEING pipeline ...

AboSamoor (abosamoor) on 2007-10-06
Changed in rhythmbox:
status: Triaged → Confirmed
Basilio Kublik (sourcercito) wrote :

Hi AboSammor
When a bug is marked as triaged means that has been confirmed by a member of Ubuntu QA and have all the required information for the developers to start working on the issue, so it's somehow higher priority/status than confirmed.
At https://wiki.ubuntu.com/Bugs/Status you can find a better explanation of this. Thank for taking the time to comment this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in rhythmbox:
status: Confirmed → Triaged
Bubblegum (louitrilobite) wrote :

turning down the volume in app as sugested by ejs7597 above sorted it out for me..

Loïc Minier (lool) wrote :

Could someone reproducing the bug please compare (or attach) the output of:
LC_ALL=C gst-launch -v filesrc location=xyz.ogg ! decodebin ! audioconvert ! audioresample ! alsasink
and:
LC_ALL=C gst-launch -v filesrc location=xyz.ogg ! decodebin ! audioconvert ! audioresample ! volume volume=1.0 ! alsasink
(note -v flag)

as I wonder whether different caps are negociated in the two cases. The first pipeline should produce the problematic sound and the second shouldn't.

In my case -- I don't get the crackling sound -- I see the second pipeline negociated with 32-bits audio samples instead of 16-bits on the whole pipeline:
-/pipeline0/audioconvert0.src: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)32, depth=(int)32, rate=(int)44100, channels=(int)2
+/pipeline0/audioconvert0.src: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
...

I guess this could be a GStreamer or Alsa issue for specific sample sizes; this is also suggested by the indication that using "pulsesink" instead of alsa seems to help some persons.

If you see a difference, then please try replacing "volume volume=1.0" in the second pipe line with:
'audio/x-raw-int,endianness=(int)1234,signed=(boolean)true,width=(int)16,depth=(int)16,rate=(int)44100,channels=(int)2'
(mind the quotes as otherwise your shell might be unhappy)

if it doesn't crack with neither volume volume=1.0 or the above caps filter, then it's likely specific to the output mode and it would be useful to check with alsa output directly instead of GStreamer.

Matti Lindell (mlind) wrote :

Loïc, here's the output of above commands.

Sound doesn't crack with neither volume volume=1.0 or your magic caps filter, so I guess you're on to something here :)

Matti Lindell (mlind) wrote :

What DarkMageZ proposes in comment #9 (https://bugs.edge.launchpad.net/ubuntu/+source/rhythmbox/+bug/116990/comments/9) seems to fix/workaround this issue for me. Can only one else confirm this by compiling rhythmbox with attached patch?

DarkMageZ (darkmagez) wrote :

before you go ahead and implement that solution. i've gone ahead and asked the rhythmbox dev's about the sideeffects of that fix...
it WILL break any plugins that attempt to add filters or additional sinks into the pipeline. luckily there are none of those already in rhythmbox itself yet tho.

so this will break rhythmbox in the future when such a plugin is released to the mainstream or break it for those playing with experimental plugins.

Same here.

Gutsy Beta, 2.6.22.13-generic Kernel.
Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07) Subsystem: Creative Labs SBLive! Player 5.1

Seems a Rhythmplayer issue, as Movie Player plays files fine. 'Crossfading' solution seems to the trick here as well.

Somebody give 'doc' a beer and tell him he forgot to implement the equalizer, while were there.

Dirk

Changed in rhythmbox:
status: Unknown → New
Simon Booth (sgb-ubuntu) wrote :

Same here; Gutsy beta, 2.6.22-13-generic kernel, NVidia MCP51 audio. Also heard in flash video.

Crossfading workaround fixes rhythmbox, but there's no equivalent fix for flash.

Matti Lindell (mlind) wrote :

Loïc, FWIW alsaplayer plays same .ogg (and affected mp3's) without problems. There's also no problems if using gstreamer playbin component.

Johnathon (kirrus) wrote :

Diito this problem. Totem plays the files fine. Activating crossfading fixes this.

8 days left.. time to think about dropping rhythmbox version back to feisty?

Sebastien Bacher (seb128) wrote :

downgrading rhythmbox to the 0.10 version is not on the table, it'll bring back lot of bugs which have been fixed and got no testing on gutsy and that for an issue which has a known workaround and might be fixed in a stable update

This issue does *not* really have a workaround, because enabling the crossfading backend can trigger other bugs. See Launchpad bug 149389 and upstream bugs. Either or should really be fixed. Besides RB 0.11.x is an unstable series.

Loïc Minier (lool) wrote :

This is not really a fix, but we could set caps or add a volume element in the pipe, just like in the gst-launch command lines above.

Loïc Minier (lool) wrote :

Can someone please try the attached debdiff of the packages from my ppa (pending creation):
deb http://ppa.launchpad.net/lool/ubuntu gutsy main restricted universe multiverse
deb-src http://ppa.launchpad.net/lool/ubuntu gutsy main restricted universe multiverse

(I don't have the bug but Rhythmbox doesn't output crackling noise for me with the fix in place, so at least it causes no regression here.)

Loïc Minier (lool) on 2007-10-11
Changed in rhythmbox:
status: Triaged → In Progress

> Can someone please try the attached debdiff of the packages from my ppa (pending creation):
> deb http://ppa.launchpad.net/lool/ubuntu gutsy main restricted universe multiverse
> deb-src http://ppa.launchpad.net/lool/ubuntu gutsy main restricted universe multiverse

Using your "rhythmbox_0.11.2-0ubuntu5_i386.deb " the crakling problem seems to be fixed here.

Matti Lindell (mlind) wrote :

Loïc's patch fixes the issue here as well.

Martin Pitt (pitti) wrote :

Wouldn't it be safer at this stage of the release to set the default rhythmbox volume to 90%, instead of enabling crossfade by default? That works wonders here, at least, and avoids the clipping noise.

Loïc Minier (lool) wrote :

@Martin: but then people would still get the bug when augmenting the output volume. The issue is caused by 32 versus 16-bits samples on the output device, so I think a hack that helps prefer a mode and still allows for the other modes to be selected is better than one that keeps the bad mode but reduces the volume.

I'll attach some test cases for us to track whether this is really an ALSA bug or perhaps a GStreamer bug.

Loïc Minier (lool) wrote :

Could people experiencing the bug please test:
aplay test-16.wav
aplay test-32.wav
and confirm whether one of the command outputs crackling while the other
doesn't?

If that's the case, what's your alsa driver? (lsmod | grep snd)

NB: I checked with ltrace, and aplay successfully sets 16 and 32-bits sample
sizes as returned by snd_pcm_format_physical_width().

Matti Lindell (mlind) wrote :

Output is fine with both 16bit&32bit .wav files when using aplay or even the affected (gutsy's) rhythmbox. Maybe sample needs to have certain frequencies, because not all mp3's suffer the same problem as described by the original submitter.

Martin Pitt (pitti) wrote :

aplay works fine here with both files. (snd_intel8x0)

Loïc Minier (lool) wrote :

@Martin: I'm afraid the files had too low sound (amplitude didn't reach the maximum) and hence are improper test cases.

To create a proper test case, people with a sound file exposing the problem should convert it to wav with this command:
gst-launch -v filesrc location=Music/foo.ogg ! decodebin ! audioconvert ! "audio/x-raw-int, width=(int)16, depth=(int)16" ! wavenc ! filesink location=16.wav

(replace Music/foo.ogg with the path to your sound file)

and the same command with "16" replaced by "32" at the 3 places

then "aplay 16.wav" and "aplay 32.wav".

(I don't get the bug, so it's not easy for me to attach a fixed test file.)

Matti Lindell (mlind) wrote :

I can reproduce the bug with aplay (and rhythmbox) using Loïc's instructions to convert affected .ogg file to 32-bit .wav. 16-bit .wav file doesn't expose the bug. The .ogg file is from upstream bug report (http://bugzilla.gnome.org/attachment.cgi?id=87621).

I guess bug now seems to be in alsa somewhere. My alsa driver is snd_emu10k1.
(btw. Totem is not affected)

Matti Lindell (mlind) wrote :

Jonathan Matthew in upstream bug report (http://bugzilla.gnome.org/show_bug.cgi?id=436192#c34) might have found the cause.

Using Loic's instructions, I converted one of my ogg files. I don't get the bugwith the 16 bits sample, but I do with the 32 bits one. My driver is snd_hda_intel.

John Nelson (skyfalcon866) wrote :

this is also happening to me too. I dont know what sound card i have but it is the one with the 815e chipset

Loïc Minier (lool) wrote :

Jonathan Matthew from Rhythmbox upstraeam identified the exact bug in ALSA so we'll be fixing that soon: thanks to all!

Jonathan Matthew (jmatthew) wrote :

What I was trying to say there before my lack of browser skills interrupted me was that I've added some notes about this problem to the ALSA bug tracker. In the short term, this can be fixed by reverting this change to alsa-lib: http://hg-mirror.alsa-project.org/alsa-lib/diff/23c4c0f5de40/src/pcm/plugin_ops.h

Longer term, the idea behind that change is good (it improves the output quality), but the implementation has a slight problem.

Gutsy RC1. The workaround does NOT work for me. Could it be the way Rhythmbox handles the Codecs?

Loïc Minier (lool) wrote :

@Basil: this wasn't uploaded as the workaround was discovered too close to the RC release; the fix in alsa or the workaround in RB should get in gutsy before release.

Loïc Minier (lool) on 2007-10-14
Changed in alsa-lib:
importance: Undecided → High
milestone: none → ubuntu-7.10
status: New → In Progress
Loïc Minier (lool) wrote :

alsa-lib (1.0.14-1ubuntu8) gutsy; urgency=high

  * New patch, fix-sampling-bit-shifts, revert HG r2264 (changeset
    23c4c0f5de40) as the bit shifts overflow when the volume is high for 32
    bits to 16 bits resampling; Alsa #3360; GNOME #436192; LP: #116990;
    Mandriva #33908.

 -- Loic Minier <email address hidden> Sun, 14 Oct 2007 19:28:45 +0200

Changed in alsa-lib:
status: In Progress → Fix Released
Steve Langasek (vorlon) on 2007-10-15
Changed in rhythmbox:
status: In Progress → Invalid
Changed in alsa-lib:
status: Unknown → New
Changed in rhythmbox:
status: New → Invalid
rich.bradshaw (rich-bradshaw) wrote :

I can confirm in Gutsy RC.

Crossfading on does fix it, but really it shouldn't happen at all!

vincewebb (vincewebb) wrote :

I have just upgraded my AMD 64 box from Feisty to Gutsy and I now get poor quality sound when playing ogg and mp3 using either Rythmbox, Amarok or Totem Movie Player.

In Rythmbox I tried:
Edit ->Preferences -> Playback -> Player Backend
Check: Use Crossfading backend
Crossfade Duration =2.1 seconds
Quit and restart Rythmbox

It made no difference, the sound is very poor

DarkMageZ (darkmagez) wrote :

vok, your problem is not related. feel free to open up a question in the answers section.

Changed in alsa-lib:
status: Unknown → Fix Released
Götz Christ (g-christ) wrote :

Anybody knows why ALSA doesn't fix this bug?
Or is this bug fixed in 1.0.15?

Enrico Gueli (e-gueli) wrote :

Christ, I have the same problem in 1.0.15 (and half-solved with crossfade too).

Loïc Minier (lool) wrote :

This should be fixed since 1.0.14-1ubuntu8. It has been fixed upstream differently in 1.0.15.

Changed in alsa-lib:
status: Fix Released → New
Benjamin_L (benjamin-lebsanft) wrote :

this bug just returned in latest hardy

Kjell Braden (afflux) wrote :

I reopened the alsa-lib bug as it is still reproducible for me and for others in hardy. (alsa-lib 1.0.15-2ubuntu1). The patch mentioned in debian's #437827 works for me.

Changed in alsa-lib:
status: Fix Released → New
Changed in alsa-lib:
status: New → Fix Released
Daniel T Chen (crimsun) wrote :

alsa-lib (1.0.15-3ubuntu1) hardy; urgency=low

  * Merge from Debian unstable.
  * Ubuntu-specific changes:
    - debian/libasound2.p{ostinst,rerm}: Install,remove update-notifier
      file, respectively;
    - debian/control: Add lpia to supported arches, adhere to
      DebianMaintainerField, add Vcs-Bzr URI.
  * Included patch addresses clicking/snapping/crackling, LP: #116990.

alsa-lib (1.0.15-3) unstable; urgency=medium

  [ Jordi Mallach ]
  * Switch to now official Vcs-* control fields.
  * New patch fix-sampling-bit-shifts.patch, provided by Loïc Minier
    which reverts broken bit shifts introduced in alsa-lib HG r2264,
    which were causing lots of clicks and creaking on at least
    GStreamer-based audio. Closes: #452282 and countless others.

 -- Daniel T Chen <email address hidden> Tue, 11 Dec 2007 21:41:52 +0000

Changed in alsa-lib:
status: New → Fix Released
Changed in alsa-lib:
status: New → Fix Released
Daniel_SJ (daniel-jackson) wrote :

Reproducable in Gutsy with Audiophile 2496 sound card.

Gaurav (pranami) wrote :

I recently installed Ubuntu 7.10 and I have been using Rhythmbox music player. The sound was perfect on it; no cracking sound at the maximum volume possible. Then I was fiddling with the volume control properties (Ubuntu desktop, not the Rhythmbox volume) by right clicking on the volume icon at the top-right corner of my desktop. All of a sudden I noticed strong cracking sounds. This happens even at low volumes, I tried lowering the master volume and player volume but to no avail. I am 100% sure that there was no cracking earlier. Moreover there is no cracking when I tried playing this song in Totem. Clearly something went wrong with Rhythmbox. Does anyone of you have a clue? I am trying to play mp3 music files. I am using Ubuntu 7.10 so I have alsa-1.0.14 installed and I am using the default version of Rhythmbox that came with Ubuntu 7.10

My problem seems to be different that what others have reported because sound on Rhythmbox was fine but suddenly it started cracking. Could this be another bug?

Changed in rhythmbox:
status: Confirmed → In Progress
Changed in rhythmbox:
status: In Progress → Fix Released
ubunturox (ubunturox-kk) wrote :

I can confirm the problem in the latest Hardy x86. If crossfade is enabled, the sound becomes choppy instead of the more annoying clicking/snapping/crackling. This seems to happen every time a menu is clicked, any window is resized, any window is minimized or maximized.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

rhythmbox:
  Installed: 0.11.4-0ubuntu6
  Candidate: 0.11.4-0ubuntu6
  Version table:
 *** 0.11.4-0ubuntu6 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
     0.11.2-0ubuntu4~feisty1 0
        500 http://us.archive.ubuntu.com feisty-backports/main Packages

ubunturox (ubunturox-kk) wrote :

The problem exists regardless of crossfading. When volume level is changed, sometimes the disturbance comes back.

mihai.ile (mihai.ile) wrote :

I can confirm that on Hardy using rhythmbox or totem the sound is clicking/snapping/crackling. This seems to happen every time a menu is clicked, any window is resized, any window is minimized or maximized.
Even worse if using 3d desktop effects.
I really need some help on this, I am using an Audigy2ZS and some very good headphones (Senheiser hd 595) and want a clean sound.
Happens in flac/mp3/ogg...

unggnu (unggnu) wrote :

@mihai007
I guess it is a pulseaudio problem. Just close Rhythmbox, run in Terminal the command "killall pulseaudio" and start Rhythmbox again. If pulseaudio is the reason it is probably fixed with the new Kernel in proposed.

stormzen (stormzen) wrote :

I noticed this problem in Gutsy, as well. One day (sorry I can't be more specific) I started hearing a burst of static at the login screen. Didn't put it all together until I was trying to figure something out in Hardy and triggered the exact same sound (playback of the startup .ogg sound from within administration -> login window -> accessibility).

In addition, killing all of pulseaudio does not fix the problem.

I was going to report that Rhythmbox wasn't working at all, because songs would start and then not play. There'd be like a second or two of audio, then crackling-ness or silence.

I saw this bug and turned on the crossfading backend, and now it works! So, I'm marking myself as affected too, and thanking whoever reported it. ^.^

PhoneixS (phoneixsegovia) wrote :

I'm also confirm that in Jaunty with 0.12.0 Rhythmbox and alsa (creative x-fi fatalyt1 pro), and that if you enable crossfading it is fixed.

I think it is becouse this option active the buffer.

Changed in rhythmbox:
importance: Unknown → High
status: Invalid → Unknown
Changed in rhythmbox (Mandriva):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.