Rhythmbox not reading 'year' tag

Bug #1155575 reported by Keith Drummond
182
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Undecided
Unassigned
rhythmbox (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Ubuntu 13.04

Attempting to create an automatic playlist sorted by year.

Rhythmbox does not seem able to see the 'year' tag and does not fill out the playlist.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: rhythmbox 2.98-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-12.21-generic 3.8.2
Uname: Linux 3.8.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
Date: Fri Mar 15 11:18:02 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-03-10 (5 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130309)
MarkForUpload: True
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Keith Drummond (kd353) wrote :
Revision history for this message
Doug McMahon (mc3man) wrote :

Year is always shown as "Unknown" in RB & also the same seen in nautilus > properties on any properly tagged audio file (13.04

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Revision history for this message
JC (nothingness) wrote :

I can confirm this on Ubuntu 13.04 x64 stable.

Revision history for this message
Dimitrios Charalampidis (d-s-charalampidis) wrote :

same here ubuntu 13.04 x64

Revision history for this message
janto@gmx.net (janto-gmx) wrote :

me too (same here Ubuntu 13.04 x64).

Revision history for this message
Alastair Gilfillan (alastair-a) wrote :

I'm using libmp3lame under 13.04 amd64 but this dosn't seem to be Rhythmbox-specific. As stated, it affects Nautilus as well.

* avconv -i *.mp3 also does **not** list year, if it ever did
* id3v2 -l *.mp3 displays `year` and all other fields (as does tagging software like Puddletag)

Revision history for this message
Aleksander Śmierciak (aleksander-smierciak) wrote :

I can confirm this bug. Rhythmbox sees any track from my library as having "Unknown" year, even though this tag is present (verified with Puddletag).

Revision history for this message
oldmaga (oldmaga) wrote :

Same for me (Ubuntu 13.04, 32 AND 64).
Rather annoying.....

Revision history for this message
Josué Barroso (josue-s-barroso) wrote :

Why does it remain unassigned?
The bug was reported on March and no solution so far!
Please someone look into it
I really miss listen my albums sorted by year

Revision history for this message
Jenne_87 (jenne-mail-87) wrote :

I have re-read my complete library today.
Here, I have the same problem.

All "Year" tags are displayed as "Unknown".

ubuntu 13.04 x64
rythembox 2.98

The program is unusable without "year" tags.

Revision history for this message
Strelok (who-) wrote :

This is known Rhythmbox bug: https://mail.gnome.org/archives/rhythmbox-devel/2013-June/msg00013.html
Here is fix commit: https://git.gnome.org/browse/rhythmbox/commit/?id=d78b2db2762becc2556c454e8ae7f12521eb8f1f

In attachment cherry-picked patch from upstream to fix this issue in Ubuntu version of Rhythmbox. Maintainers, please send patched version to repository.

To test it:
1) Download Rhythmbox source for Ubuntu:
apt-get source rhythmbox
2) Copy patch:
copy fix_metadata_read.patch (from attachment) to debian/patches/ and append to debian/patches/series line:
fix_metadata_read.patch
3) Install dependences:
sudo apt-get build-dep rhythmbox
4) Build .deb:
sudo debuild -uc -us
5) Install patched version:
sudo dpkg -i librhythmbox-core6_2.98-0ubuntu5_amd64.deb

Be careful, this instruction not full. You must know that are you doing.

This patch works for me perfectly.

Changed in nautilus:
status: New → Invalid
Revision history for this message
Strelok (who-) wrote :

After install patched version, you need refresh database (readd music).

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Cherry-picked upstream patch for 2.98 version" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Josué Barroso (josue-s-barroso) wrote :

Why the status is invalid for Nautilus?
Is there any hint about when the patched version will be on the repository?

Revision history for this message
Strelok (who-) wrote :

> Why the status is invalid for Nautilus?
Because this bug Rhythmbox-specific. You need to open new bug to Nautilus. See Reporting Bugs rules: https://help.ubuntu.com/community/ReportingBugs
> "The rule of thumb is one report, per person, per hardware combination, per bug."
> "Please do not stack multiple issues into one report"

Sorry for this, i suppose it's obvious.

Revision history for this message
David Henningsson (diwic) wrote :

Hi Strelok,
Thanks for finding the patch, I've submitted a merge proposal which I hope will be reviewed soon.

Changed in rhythmbox (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is fixed in the current Ubuntu version. Btw, you should subscribe ubuntu-sponsors if there is something to review

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: In Progress → Fix Released
Revision history for this message
Danillo (danillo) wrote :

By current Ubuntu version you mean Trusty or Saucy? I'm using Saucy and the bug's still here.

Revision history for this message
Fredda (wiegner) wrote :

I can confirm this. Not fixed in saucy. It's still rhythmbox version 2.99.1-0ubuntu1 from May this year.
Only version rhythmbox 3.0.1-1ubuntu5 for trusty seems to be updated as this is from November 15th.

Please backport, this bug is really annoying.

Revision history for this message
Danillo (danillo) wrote :

I confirm it working on Rhythmbox 3.0 on Ubuntu 13.10. I guess for now we can install the newer version from the fossfreedom PPA: http://xpressubuntu.wordpress.com/2013/10/06/how-to-install-rhythmbox-3-0-in-saucy/

Plugins for the newer version can be installed from another PPA: http://xpressubuntu.wordpress.com/2013/10/26/installing-rhythmbox-3-0-plugins-the-easy-way/

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers