Unable to add podcasts in rhythmbox

Bug #1143282 reported by Robin Sheat on 2013-03-04
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Undecided
Unassigned

Bug Description

I am unable to add a podcast in rhythmbox.

Procedure:
1) Open rhythmbox
2) select "Podcasts" under "Library" on the left
3) Press the "Add" button
4) Enter a URL from a podcast feed that you know should work because you can see it in firefox, e.g. http://feeds.feedburner.com/Rsaudio (typing or copy/pasting appears to make no difference.)
5) Note that the "subscribe" button isn't lit up, so click "search"
6) You get a message saying "Unable to load the feed. Check your network connection." and the podcast URL is
7) Subscribe is now enabled, so press that.

Result:
8) the feed URL disappears from the list, but you aren't subscribed to it

Expected result:
8) you are subscribed to it.

Notes:
* My network connection is active
* It is managed by network manager, although my desktop is xmonad and I don't have the applet visible (but apparently it is running)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: rhythmbox 2.97-1ubuntu6.1
ProcVersionSignature: Ubuntu 3.5.0-23.35-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Mon Mar 4 14:45:43 2013
MarkForUpload: True
SourcePackage: rhythmbox
UpgradeStatus: No upgrade log present (probably fresh install)

Robin Sheat (eythian) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
aamadis (aamadis) wrote :

Restarting the computer seems to have fixed the problem, at least temporarily. I think a previous restart may have also fixed the problem once before. Not completely sure, but I do know that Rhythmbox has a lot of updates/upgrades, some to plugins and such, so maybe these just need a full restart.

Robin Sheat (eythian) wrote :

It is still occuring for me, and rhythmbox has been restarted.

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in rhythmbox (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for rhythmbox (Ubuntu) because there has been no activity for 60 days.]

Changed in rhythmbox (Ubuntu):
status: Incomplete → Expired
Pedro Cunha (sidner-7) on 2015-01-15
Changed in rhythmbox (Ubuntu):
status: Expired → Confirmed
Robin Sheat (eythian) wrote :

This still happens in 14.10.

Marco van Zwetselaar (zwets) wrote :

This problem still persists in Xenial (16.04), but I may have spotted the cause. Checking my apt log, a libc upgrade had taken place before I tried to update my podcast feeds, and I hadn't since rebooted. Libc upgrades prompt for a system reboot - which I usually defer. As for #3, a reboot fixed the problem.

rithik g (gkrithi) wrote :

works fine with the RSS feed in bug description.

might have been fixed in subsequent releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers