Rhythmbox encoder missing plugin

Bug #1086806 reported by Gabor Toth on 2012-12-05
162
This bug affects 41 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
High
Unassigned

Bug Description

I am on Ubuntu 12.10, upgraded from 12.04. Dell Inspirion 17R with 2GB RAM.
Rhythmbox works just fine or so I thought until today. I was attempting to rip a CD and put it in Ogg Vorbis format. When I clicked on EXTRACT, I got a dialog window telling me that "Additional software is required to encode media in your preferred format:
Vorbis encoder"
When I click on "Install" to get the plugin, it searches for it and says "Python (v2.7) requires to install plugins to create media files of the following type: Vorbis encoder" then says "Required plugin could not be found"
Same thing with MP3 except there finds a plugin but that is only for I386 and not for x64 so I can not isntall either.
I can actually not encode any music in any format.
I can play any music in any format (tried Ogg and MP3) and that works just fine without a problem. Can not rip CDs at the moment as the encoding does not work as above.
It is probably since upgrade from 12.04 as on 12.04 it was working. I have not used this for some time and just tried to do it today with the above fail.
It is reproducible every time for me.

Tried manually installing packages to handle that without success. Let me know if more data is needed.

Gabor

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: rhythmbox 2.97-1ubuntu5
ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
Uname: Linux 3.5.0-19-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CheckboxSubmission: 6b64e7968cc8e732e5ad2595b83d27cf
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Wed Dec 5 14:40:43 2012
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-09-26 (69 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
UpgradeStatus: Upgraded to quantal on 2012-10-28 (37 days ago)

Gabor Toth (gabor-me) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Chris Morgan (chris.morgan) wrote :

I confirm that this used to work for me (probably in 11.10, don't think I tried ripping any CDs in 12.04) but I discovered today that it is broken in 12.10. I am also using a 64-bit installation.

This is rather a nuisance, as it means I can't use Rhythmbox to rip CDs for use on another device without a CD drive.

Likewise, I am quite willing to provide any information which may be helpful to identifying and fixing the problem.

Chris Morgan (chris.morgan) wrote :

This seems highly likely to be related to #1084843. That bug has listed a workaround: http://ubuntuforums.org/showpost.php?p=12337687&postcount=3

That workaround seems to be working for me. (I'm now in the process of ripping a CD.)

Jonah Bron (jonahbron) wrote :

Definitely a bug. Easy solution on AskUbuntu here:

http://askubuntu.com/a/211390/18764

Just a configuration change.

Thanks. It works with that solution.

Best regards,

*Gabor Toth*

Birkedommervej 4, 3 TH
<http://maps.google.com/maps?q=Birkedommervej+4%2C+3+TH%2CCopenhagen+2400%2CDenmark&hl=en>
Copenhagen 2400 Denmark
  *Mobile:* +45-2163-4983
*Email:* <email address hidden> <mailto:<email address hidden>>
*IM:* gabor.me (Skype)
 *Professional Profile <http://dk.linkedin.com/pub/gabor-toth/1a/7a0/549>*

   Want a signature like this?
<http://www.linkedin.com/e/sig/67641609/?hs=false&tok=0HVzHlVV1hw5w1>

On 01/18/2013 02:23 AM, Jonah Bron wrote:
> Definitely a bug. Easy solution on AskUbuntu here:
>
> http://askubuntu.com/a/211390/18764
>
> Just a configuration change.
>

Adam Niedling (krychek) wrote :

Rhythmbox can't install Vorbis encoder for me either in Ubuntu 13.04.

Jezza (balingupjer) wrote :

This bug affects me also on 13.04 64 bit.
Its a pity these little bugs aren't fixed, sot the application works "out of the box" as it should.
They build up and then you spend all your time trawling for workarounds and patches.

My test is, would this work for my mom or grandma?
In this case, no..

Thanks in advance.

can post logs etc if needed.

izar (izar00) wrote :

@ 7 & 8:
there is a vary simple workaround. please read above.

Adam Niedling (krychek) on 2013-11-01
tags: added: saucy
Changed in rhythmbox (Ubuntu):
importance: Undecided → High
Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Israel Dahl (israeldahl) wrote :

Still present in trusty

tags: added: trusty
Changed in rhythmbox (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 3.0.1-1ubuntu12

---------------
rhythmbox (3.0.1-1ubuntu12) trusty; urgency=medium

  * debian/patches/10_encoding_use_ubuntu_profiles.patch,
    debian/patches/GstLameMP3Enc,GstVorbisEnc.prs:
    - use a consistent naming for the ogg/mp3 preset profiles, rename it
      "Ubuntu" rather than ("ubuntu-default") since that's the string used
      in the selector. That should fix the issue where rhythmbox reports
      some missing plugins errors when copying cds (lp: #1086806)
 -- Sebastien Bacher <email address hidden> Wed, 05 Mar 2014 16:03:40 +0100

Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Released

I experience this with rhythmbox 3.0.2-0ubuntu2. Is this a regression?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers