[apport] rhythmbox crashed with SIGSEGV in g_hash_table_lookup()

Bug #104547 reported by finalbeta on 2007-04-08
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

Rhythmbox's library has to lists files over SMB(cifs) for me. I shut Rhythmbox down while listing, and sometimes it crashes while shutting down.

ProblemType: Crash
Architecture: i386
Date: Sun Apr 8 22:30:36 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.10.0-0ubuntu1
PackageArchitecture: i386
ProcCmdline: /usr/bin/rhythmbox
ProcCwd: /
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 g_hash_table_lookup () from /usr/lib/libglib-2.0.so.0
 rb_refstring_new ()
 ?? ()
 ?? ()
 ?? ()
Uname: Linux finalbeta-laptop 2.6.20-14-386 #2 Mon Apr 2 20:34:35 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

finalbeta (j-greenhouse) wrote :
Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Medium

StacktraceTop:rb_refstring_new ()
?? ()
?? ()
?? ()

StacktraceTop:rb_refstring_new (
rhythmdb_execute_stat (db=0xb708b790, uri=0x7aba568 <Address 0x7aba568 out of bounds>, event=0xb342b700) at rhythmdb.c:2066
rhythmdb_add_uri_with_type (db=0x823b018,
rhythmdb_add_uri (db=0x823b018,

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Could you try to get a valgrind log for it when crashing (you can follow the instructions from https://wiki.ubuntu.com/Valgrind for that)?

Changed in rhythmbox:
status: Unconfirmed → Needs Info
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in rhythmbox:
status: Needs Info → Rejected
zenith (lasse-bigum) wrote :

I encountered this problem as well.

I am attaching a valgrind log as per the link.

My way to reproduce the error is to load a playlist in Rhythmbox. The music in the playlist is located in ~/Download/mp3/ (Download is my mount directory and "trash" directory, so it is only ripped music that I have mounted via FUSE from my server).
The music should be in place, but it crashes rhythmbox regardless. I am not sure if it is caused by an old format of the playlist, FUSE or something else.

zenith (lasse-bigum) wrote :

I have attached a valgrind log, hoping this will make it possible to trace the bug.

Changed in rhythmbox:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in rhythmbox:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in rhythmbox:
status: Incomplete → Invalid
zenith (lasse-bigum) wrote :

I just tried this once again, and it still crashes.

The gdb stack this is this:
(gdb) bt 40
#0 0x084ece5b in ?? ()
#1 0x0807b364 in playlist_load_ended_cb (parser=0x8cfdb60,
    uri=0x8e80b68 "iPod Run List", metadata=0x84ece40, mgr=0xb710da63)
    at rb-playlist-manager.c:576
#2 0xb71182ca in g_cclosure_marshal_VOID__STRING ()
   from /usr/lib/libgobject-2.0.so.0
#3 0xb710b759 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4 0xb711ff8b in ?? () from /usr/lib/libgobject-2.0.so.0
#5 0xb7121c1f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6 0xb7121f69 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7 0xb7a388bb in ?? () from /usr/lib/libtotem-plparser.so.10
#8 0xb7a3d951 in ?? () from /usr/lib/libtotem-plparser.so.10
#9 0xb7a3da7e in ?? () from /usr/lib/libtotem-plparser.so.10
#10 0xb7a39556 in ?? () from /usr/lib/libtotem-plparser.so.10
#11 0xb7a3a049 in totem_pl_parser_parse_with_base ()
   from /usr/lib/libtotem-plparser.so.10
#12 0xb7a3a0e3 in totem_pl_parser_parse ()
   from /usr/lib/libtotem-plparser.so.10
#13 0x0807bc43 in rb_playlist_manager_parse_file (mgr=0x84ece40,
    uri=0x8cfe0b8 "file:///home/zenith/Desktop/iPod%20Run%20List.pls",
    error=0xbf8d6128) at rb-playlist-manager.c:621
#14 0x0807d85e in load_playlist_response_cb (dialog=0x8342c80, response_id=-3,
    mgr=0x84ece40) at rb-playlist-manager.c:1314
---Type <return> to continue, or q <return> to quit---
#15 0xb711884a in g_cclosure_marshal_VOID () from /usr/lib/libgobject-2.0.so.0
#16 0xb710b759 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#17 0xb711ff8b in ?? () from /usr/lib/libgobject-2.0.so.0
#18 0xb7121c1f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#19 0xb7121f69 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#20 0xb74da861 in gtk_dialog_response () from /usr/lib/libgtk-x11-2.0.so.0
#21 0xb7118aff in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#22 0xb710b759 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#23 0xb711ff8b in ?? () from /usr/lib/libgobject-2.0.so.0
#24 0xb7121c1f in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#25 0xb7121f69 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#26 0xb748d01a in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#27 0xb748e9c5 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#28 0xb748ea03 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#29 0xb73a981b in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#30 0xb6f52546 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb6f51dd6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#32 0xb6f55193 in ?? () from /usr/lib/libglib-2.0.so.0
#33 0xb6f55577 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#34 0xb7561264 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#35 0x08062a50 in main (argc=Cannot access memory at address 0x6c656873
) at main.c:327

And the playlist I am trying to load is attached.

zenith (lasse-bigum) wrote :

While not proficient in GTK, I am a programmer, so if you could point me in the right directions as to how to debug this, I will try to help out as well as I can.

Changed in rhythmbox:
status: Invalid → New
zenith (lasse-bigum) wrote :

Apparently this has been fixed in SVN, 0.11.6 still crashed, but the SVN version did not.

Closing as this has been fixed.

Changed in rhythmbox:
status: New → Fix Committed
Sebastien Bacher (seb128) wrote :

closing the bug since intrepid has a recent svn version

Changed in rhythmbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers