rhythmbox crashes when deleting file from ipod

Bug #103654 reported by René on 2007-04-06
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox (Ubuntu)
High
Sebastien Bacher

Bug Description

Binary package hint: rhythmbox

connect ipod, auto mount, start rhythmbox, open ipod, try to delete a file

ProblemType: Crash
Architecture: amd64
Date: Fri Apr 6 11:22:57 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/rhythmbox
Package: rhythmbox 0.10.0-0ubuntu1
PackageArchitecture: amd64
ProcCmdline: rhythmbox
ProcCwd: /home/rene
ProcEnviron:
 LANGUAGE=de_DE.UTF-8@euro
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=de_DE.UTF-8@euro
 SHELL=/bin/bash
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 itdb_get_mountpoint () from /usr/lib/libgpod.so.1
 itdb_write () from /usr/lib/libgpod.so.1
 ?? ()
 g_closure_invoke ()
 ?? () from /usr/lib/libgobject-2.0.so.0
Uname: Linux Earth 2.6.20-13-generic #2 SMP Sat Mar 24 23:12:02 UTC 2007 x86_64 GNU/Linux
UserGroups: adm audio cdrom dialout dip fax floppy lpadmin plugdev scanner tape video

René (pirateking) wrote :
Changed in rhythmbox:
importance: Undecided → Medium

StacktraceTop:?? ()
?? ()
?? ()
?? ()

Sebastien Bacher (seb128) wrote :
Download full text (50.8 KiB)

4947 return itdb->device->mountpoint;
(gdb) thread apply all bt full

Thread 7 (process 6747):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb6fa4893 in poll () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0xb7c9f80b in _dbus_poll (fds=0xb37fb140, n_fds=1, timeout_milliseconds=15000) at dbus-sysdeps-unix.c:1474
No locals.
#3 0xb7c981b9 in socket_do_iteration (transport=0xb3913730, flags=6, timeout_milliseconds=15000)
    at dbus-transport-socket.c:1028
        auth_state = <value optimized out>
        poll_fd = {fd = 29, events = 1, revents = 0}
        poll_res = -1282328784
        poll_timeout = 15000
#4 0xb7c9690c in _dbus_transport_do_iteration (transport=0xb3913730, flags=6, timeout_milliseconds=15000)
    at dbus-transport.c:778
No locals.
#5 0xb7c82a8d in _dbus_connection_do_iteration_unlocked (connection=0xb3913000, flags=6, timeout_milliseconds=15000)
    at dbus-connection.c:1139
No locals.
#6 0xb7c84a04 in _dbus_connection_block_pending_call (pending=0x8771c10) at dbus-connection.c:2263
        start_tv_sec = 1175856124
        start_tv_usec = 576076
        end_tv_sec = 1175856139
        end_tv_usec = 576076
        tv_sec = <value optimized out>
        tv_usec = <value optimized out>
        status = <value optimized out>
        connection = (DBusConnection *) 0xb3913000
        client_serial = 201
        timeout_milliseconds = 15000
#7 0xb7c90cd1 in dbus_pending_call_block (pending=0xfffffffc) at dbus-pending-call.c:707
        __FUNCTION__ = "dbus_pending_call_block"
#8 0xb7c83e61 in dbus_connection_send_with_reply_and_block (connection=0xb3913000, message=0x88cc5f8,
    timeout_milliseconds=15000, error=0xb37fb304) at dbus-connection.c:3186
        reply = <value optimized out>
        pending = (DBusPendingCall *) 0x8771c10
        __FUNCTION__ = "dbus_connection_send_with_reply_and_block"
#9 0xb7f0c474 in rb_metadata_load (md=0x907a680, uri=0x8b69784 "file:///media/mybook1/music/Roger%20Waters/desktop.ini",
    error=0x8977c18) at rb-metadata-dbus-client.c:378
        message = (DBusMessage *) 0x88cc5f8
        response = (DBusMessage *) 0x0
        iter = {dummy1 = 0xb72515e1, dummy2 = 0x8200130, dummy3 = 144145416, dummy4 = -1283476728, dummy5 = -1222400096,
  dummy6 = 136315184, dummy7 = 0, dummy8 = -1283476712, dummy9 = 142026352, dummy10 = 142023632, dummy11 = 142026240,
  pad1 = 20821915, pad2 = -1208734836, pad3 = 0x8200130}
        dbus_error = {name = 0x0, message = 0x0, dummy1 = 0, dummy2 = 0, dummy3 = 0, dummy4 = 0, dummy5 = 0,
---Type <return> to continue, or q <return> to quit---
  padding1 = 0x0}
        ok = <value optimized out>
        fake_error = (GError *) 0x0
        __FUNCTION__ = "rb_metadata_load"
#10 0x080abffb in action_thread_main (db=0x81ff828) at rhythmdb.c:2183
        action = <value optimized out>
        result = <value optimized out>
        __FUNCTION__ = "action_thread_main"
        __PRETTY_FUNCTION__ = "action_thread_main"
#11 0xb70adb7f in g_thread_create_proxy (data=0x8ba9050) at gthread.c:591
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#12 0xb7d0431b in start_thread () from /lib/tls/i686/cmov/li...

Sebastien Bacher (seb128) wrote :

Thank you for your bug

Changed in rhythmbox:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

(gdb) p *itdb->device
Cannot access memory at address 0x2107e0

Sebastien Bacher (seb128) wrote :

confirmed, due to 80_from_upstream_fix_ipod_update.patch.level-1.log

Changed in libgpod:
assignee: nobody → seb128
importance: Medium → High
Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 rhythmbox (0.10.0-0ubuntu2) feisty; urgency=low
 .
   * debian/patches/80_from_upstream_fix_ipod_update.patch:
     - dropped, the patch requires an other SVN change (Ubuntu: #103654)

Changed in rhythmbox:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers