Rhythmbox crashes when 'Preferences' is clicked

Bug #1030295 reported by Alan Morgan on 2012-07-28
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
d-conf (Ubuntu)
High
desrt
rhythmbox (Ubuntu)
Medium
Iain Lane

Bug Description

I am using Rhythmbox 2.97-1ubuntu2, in Ubuntu 12.10.

I open Rhythmbox, go to Edit and then Preferences, and Rhythmbox crashes. This happens every time I have tested it.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: rhythmbox 2.97-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Sat Jul 28 22:50:54 2012
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
ProcCmdline: rhythmbox /home/username/Music/Christopher\ Tin/Calling\ All\ Dawns/01\ Baba\ Yetu\ (feat.\ Soweto\ Gospel\ Choir).mp3
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: rhythmbox
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: rhythmbox crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Alan Morgan (alanmorgan) wrote :
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2012-07-30
visibility: private → public
Iain Lane (laney) wrote :

I just incrementally updated between alpha-2 (when RB worked) and alpha-3 (when it did not) and tracked the breakage down to d-conf.

dconf-gsettings-backend 0.12.1-2: edit→preferences functions correctly.
dconf-gsettings-backend 0.13.4-0ubunu1: crash as in this bug.

Adding a d-conf task accordingly.

Changed in d-conf (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: apport-request-retrace
Changed in d-conf (Ubuntu):
assignee: nobody → Ryan Lortie (desrt)
Iain Lane (laney) on 2012-07-30
Changed in rhythmbox (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.97-1ubuntu3

---------------
rhythmbox (2.97-1ubuntu3) quantal; urgency=low

  [ Sebastien Bacher ]
  * debian/patches/09_keywords.patch:
    - backport upstream patch to set keywords in the desktop entry,
      it makes easier to find totem in the unity dash or gnome-shell
      (lp: #1029964)

  [ Iain Lane ]
  * debian/*.prs, debian/patches/10_encoding_use_ubuntu_profiles.patch: Add an
    OGG and MP3 preset with improved defaults to use when encoding. Patch
    rhythmbox.gep to work with user-supplied custom settings (LP: #945987)
  * debian/patches/dont_free_consumed_floating_gvariant.patch: Take patch from
    upstream bug#680842 (by Ryan Lortie) to not crash when opening preferences
    dialog by trying to free an already consumed value. (LP: #1030295)
  * Add Breaks and Replaces on versions of transmageddon which shipped the
    .prs files we are now shipping in -data.
 -- Iain Lane <email address hidden> Mon, 30 Jul 2012 17:46:42 +0100

Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Released
Iain Lane (laney) on 2012-07-30
Changed in d-conf (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers