rhythmbox crashed with SIGSEGV in monitor_entry_file()

Bug #1029333 reported by Alberts Muktupāvels on 2012-07-26
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
High
Michael Terry
Quantal
High
Michael Terry

Bug Description

...

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: rhythmbox 2.97-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu5
Architecture: amd64
Date: Thu Jul 26 12:20:04 2012
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: rhythmbox
SegvAnalysis:
 Segfault happened at: 0x7f857e9d50e0: mov (%rax),%rsi
 PC (0x7f857e9d50e0) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 ?? () from /usr/lib/librhythmbox-core.so.6
 ?? () from /usr/lib/librhythmbox-core.so.6
 ?? () from /usr/lib/librhythmbox-core.so.6
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
Title: rhythmbox crashed with SIGSEGV in start_thread()
UpgradeStatus: Upgraded to quantal on 2012-07-21 (4 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

StacktraceTop:
 monitor_entry_file (db=0x207a290, entry=<optimized out>) at rhythmdb-monitor.c:165
 monitor_entry_file (entry=<optimized out>, db=0x207a290) at rhythmdb-monitor.c:156
 rhythmdb_tree_entry_foreach (rdb=<optimized out>, foreach_func=0x7f857e9d5080 <monitor_entry_file>, user_data=0x207a290) at rhythmdb-tree.c:2422
 _monitor_entry_thread (db=0x207a290) at rhythmdb-monitor.c:251
 g_thread_proxy (data=0x2e9ab20) at /build/buildd/glib2.0-2.33.6/./glib/gthread.c:801

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
summary: - rhythmbox crashed with SIGSEGV in start_thread()
+ rhythmbox crashed with SIGSEGV in monitor_entry_file()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
tags: added: running-unity
Omer Akram (om26er) wrote :

rhythmbox is crashing like crazy, everytime I start it would first crash and on the next attempt will work fine.

visibility: private → public
Changed in rhythmbox (Ubuntu):
importance: Medium → High
Ursula Junque (ursinha) wrote :

This happened to me today after dist-upgrading from precise to quantal. Once the machine returned from reboot, I logged in and hit this bug. I actually didn't run any commands for this to happen.

Michael Terry (mterry) on 2012-09-18
Changed in rhythmbox (Ubuntu Quantal):
assignee: nobody → Michael Terry (mterry)
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → New
Michael Terry (mterry) on 2012-09-18
Changed in rhythmbox (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in rhythmbox:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 2.97-1ubuntu5

---------------
rhythmbox (2.97-1ubuntu5) quantal; urgency=low

  [ Martin Pitt ]
  * debian/source_rhythmbox.py: Fix package name, it's rhythmbox-ubuntuone
    now.

  [ Jeremy Bicha ]
  * debian/rhythmbox.gsettings-override:
    - Dropped, override moved to ubuntu-settings

  [ Michael Terry ]
  * debian/patches/git_crash_during_monitor.patch:
    - Backport git patches to guard against crashing due to monitoring
      files outside library (by moving a g_strfreev and also just stopping
      monitoring such files at all). LP: #1029333
 -- Michael Terry <email address hidden> Wed, 19 Sep 2012 14:30:03 -0400

Changed in rhythmbox (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.