track duplication from RB-U1

Bug #934206 reported by Dave Morley on 2012-02-17
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu One for Rhythmbox
Status tracked in Trunk
Stable-3-0
High
dobey
Trunk
High
dobey
rhythmbox-ubuntuone (Ubuntu)
High
dobey
Precise
High
dobey

Bug Description

I am seeing duplicated tracks from U1 music however when clicking on the Purchased from Ubuntuone library source none show up at all see screenshots attached

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: rhythmbox-ubuntuone 2.99.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Fri Feb 17 13:56:01 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120117)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox-ubuntuone
UpgradeStatus: Upgraded to precise on 2012-02-13 (4 days ago)

Related branches

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
dobey (dobey) on 2012-02-22
Changed in rhythmbox-ubuntuone (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Rodney Dawes (dobey)
Franck (alci) wrote :

Notice the source of duplicate entries :

each track I have purchased from Ubuntuone music store appears :
Once with path ~/.local/share/ubuntuone/Achetée avec Ubuntu One/artist/album
Once with path ~/.ubuntuone/Purchased from Ubuntu One/artist/album

Looking in the filesystem, directory '~/.local/share/ubuntuone/Achetée avec Ubuntu One' is effectively a link to '~/.ubuntuone/Purchased from Ubuntu One'

Joe Mooring (toomanypets) wrote :

I'm having the same problem. Each track downloaded has two entries in Rhythmbox:

- Once with path ~/.local/share/ubuntuone/Purchased from Ubuntu One/artist/album
- Once with path ~/.ubuntuone/Purchased from Ubuntu One/artist/album

~/.local/share/ubuntuone/Purchased from Ubuntu One is a link pointing to ~/.ubuntuone/Purchased from Ubuntu One

Neal Gamradt (ngamradt-d) wrote :

I was seeing the same issue. I also wasn't able to alter my library listing to exclude the duplicate UbuntuOne purchased music, I did, however, find a workaround for now. I did the following:

NOTE: Save you podcast locations as the following may wipe out their locations.

1. Opened Rhythmbox.
2. Went to Edit -> Plugins
3. I disabled the "Ubuntu One" plugin.
4. Went to Edit -> Preferences
5. Changed my library location to only be my main local music folder.
6. Created a symlink to the purchased music folder in my music folder: ln -s ../.ubuntuone/Purchased\ from\ Ubuntu\ One/ ~/Music/UbuntuOne
7. Close Rhythmbox
8. Went into ~/.local/share/rhythmbox
9. Removed the following files: playlists.xml, podcast-timestamp, rhythmdb.xml
10. Logged out of my user.
11. Logged back in.
12. Restarted Rhythmbox.

I no longer have duplicates. So was I figure is happening is the following. The "Ubuntu One" plugin has a bug causing it to list purchased music twice. This plugin also prevents you from changing your library location (even through dconf editor). Unfortunately, I haven't found a way to get Rhythmbox to clean up its index onces the duplicates are in there. That is why it is needed to delete those files in step nine.

I am guessing none of this will be much of an issue once they fix that plugin.

dobey (dobey) wrote :

Neal, that "solution" will only work until you re-enable the plug-in. Yes it's a bug. And yes we're fixing it. That's why the status is "In Progress" :)

dobey (dobey) wrote :

While this fix will prevent duplicates appearing, if you are just upgrading to Precise, it will not remove existing duplicates from your library. To do this, you'll need to do it manually, either by removing them from the library in rhythmbox, which can be a bit tedious, or by quitting rhythmbox, deleting the ~/.local/share/rhythmbox/rhythmdb.xml file, and starting rhythmbox again, to let it re-scan your entire music library. Of course, you'll want to make sure you have the new version of rhythmbox-ubuntuone installed first. This fix will be in the 2.99.91 release, which should be uploaded to Precise tomorrow, or will appear very shortly in ppa:ubuntuone/nightlies if you are using the nightlies PPA.

Joe Mooring (toomanypets) wrote :

Rodney,

Thank you for the information and progress! Very much appreciated.

Question: will the fix prevent duplicates from appearing after _new_ U1 downloads, or will the fix also eliminate duplicates resulting from priot U1 downloads?

Joe

Joe Mooring (toomanypets) wrote :

Rodney,

Disregard previous question. I just re-read post #7. After applying the update, I will deelte ~/.local/share/rhythmbox/rhythmdb.xml file, and then start rhythmbox to let it re-scan.

Joe

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox-ubuntuone - 2.99.91-0ubuntu1

---------------
rhythmbox-ubuntuone (2.99.91-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fix handling of plug-in disabling/enabling (LP: #951425)
    - Avoid creating duplicate tracks in the library (LP: #934206)
 -- Rodney Dawes <email address hidden> Tue, 20 Mar 2012 18:05:25 -0400

Changed in rhythmbox-ubuntuone (Ubuntu Precise):
status: Confirmed → Fix Released
Joe Mooring (toomanypets) wrote :

I've applied the update and rebuilt rhythmdb.xml. There are no duplicate entries for my U1 purchases. Thanks for the fix!

Albert (albert77) wrote :

Also works for me, thank you very much!

Ned Hedrick (nedhedrick) wrote :

Also for me! Thanks!

and fixed for me

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers