rhythmbox crashes when trying to play music

Bug #1812683 reported by Götz Waschk on 2019-01-21
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
rhythmbox-plugin-alternative-toolbar (Ubuntu)
High
fossfreedom
Bionic
Low
Didier Roche
Cosmic
Low
Didier Roche
Disco
High
fossfreedom

Bug Description

Thread 1 "rhythmbox" received signal SIGSEGV, Segmentation fault.
0x00007ffff7183384 in gtk_tree_view_get_column ()
   from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
(gdb) bt
#0 0x00007ffff7183384 in gtk_tree_view_get_column () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#1 0x00007ffff6ecd5fa in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#2 0x00007ffff6ece792 in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#3 0x00007ffff6ecf445 in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#4 0x00007ffff718d1fc in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#5 0x00007ffff10bedae in ffi_call_unix64 () at /usr/lib/x86_64-linux-gnu/libffi.so.6
#6 0x00007ffff10be71f in ffi_call () at /usr/lib/x86_64-linux-gnu/libffi.so.6
#7 0x00007ffff6be3ced in g_cclosure_marshal_generic_va () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#8 0x00007ffff6be3346 in () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9 0x00007ffff6bfe9ff in g_signal_emit_valist () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#10 0x00007ffff6bff12f in g_signal_emit () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007ffff700f7fc in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#12 0x00007ffff6be6008 in g_cclosure_marshal_VOID__BOXEDv () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#13 0x00007ffff6be3346 in () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#14 0x00007ffff6bfe9ff in g_signal_emit_valist () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#15 0x00007ffff6bff12f in g_signal_emit () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#16 0x00007ffff700c78e in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#17 0x00007ffff700dcdb in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#18 0x00007ffff701099e in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#19 0x00007ffff6fde1e1 in gtk_event_controller_handle_event () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#20 0x00007ffff719d85b in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#21 0x00007ffff7b46642 in () at /usr/lib/x86_64-linux-gnu/librhythmbox-core.so.10
#22 0x00007ffff705815b in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#23 0x00007ffff6be310d in g_closure_invoke () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#24 0x00007ffff6bf605e in () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#25 0x00007ffff6bfe0af in g_signal_emit_valist () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#26 0x00007ffff6bff12f in g_signal_emit () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#27 0x00007ffff719fb04 in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#28 0x00007ffff70551ce in () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#29 0x00007ffff70572a8 in gtk_main_do_event () at /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
#30 0x00007ffff5323765 in () at /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#31 0x00007ffff5353f82 in () at /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
#32 0x00007ffff6909387 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007ffff69095c0 in () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007ffff690964c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007ffff37e7e3d in g_application_run () at /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#36 0x00007ffff7aa0b09 in rb_application_run () at /usr/lib/x86_64-linux-gnu/librhythmbox-core.so.10
#37 0x0000555555554d57 in main ()

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libgstreamer1.0-0 1.14.1-1~ubuntu18.04.1
ProcVersionSignature: Ubuntu 4.15.0-43.46-generic 4.15.18
Uname: Linux 4.15.0-43-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Jan 21 16:14:12 2019
SourcePackage: gstreamer1.0
UpgradeStatus: No upgrade log present (probably fresh install)

Götz Waschk (goetz-waschk) wrote :
Sebastien Bacher (seb128) wrote :

Could you install the dbgsym (https://wiki.ubuntu.com/Debug%20Symbol%20Packages) for glib, gtk and rhythmbox and get a debug backtrace?

Changed in gstreamer1.0 (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Götz Waschk (goetz-waschk) wrote :
Download full text (7.8 KiB)

(gdb) bt
#0 0x00007ffff7183384 in gtk_tree_view_get_column (tree_view=tree_view@entry=0x555555e847f0 [GtkTreeView], n=n@entry=16)
    at ../../../../gtk/gtktreeview.c:12343
#1 0x00007ffff6ecf5da in _gtk_tree_view_accessible_add_state (treeview=0x555555e847f0 [GtkTreeView], tree=tree@entry=0x555555f801c0, node=node@entry=0x555556aca100, state=state@entry=GTK_CELL_RENDERER_SELECTED)
    at ../../../../gtk/a11y/gtktreeviewaccessible.c:1993
#2 0x00007ffff71727f9 in gtk_tree_selection_real_select_node (selection=selection@entry=0x555555e24610 [GtkTreeSelection], tree=tree@entry=0x555555f801c0, node=node@entry=0x555556aca100, select=select@entry=1)
    at ../../../../gtk/gtktreeselection.c:1632
#3 0x00007ffff7173146 in _gtk_tree_selection_internal_select_node (selection=0x555555e24610 [GtkTreeSelection], node=0x555556aca100, tree=0x555555f801c0, path=0x555555c58500, mode=<optimized out>, override_browse_mode=0)
    at ../../../../gtk/gtktreeselection.c:1585
#4 0x00007ffff71861c8 in gtk_tree_view_real_set_cursor (tree_view=tree_view@entry=0x555555e847f0 [GtkTreeView], path=path@entry=0x555555c58500, flags=flags@entry=(CLEAR_AND_SELECT | CLAMP_NODE)) at ../../../../gtk/gtktreeview.c:13306
#5 0x00007ffff718d4e9 in gtk_tree_view_multipress_gesture_pressed (gesture=0x555555e7d430 [GtkGestureMultiPress], n_press=1, x=<optimized out>, y=<optimized out>, tree_view=0x555555e847f0 [GtkTreeView])
    at ../../../../gtk/gtktreeview.c:3379
#6 0x00007ffff10bedae in ffi_call_unix64 ()
---Type <return> to continue, or q <return> to quit---
   .so.6
#7 0x00007ffff10be71f in ffi_call () at /usr/lib/x86_64-linux-gnu/libffi.so.6
#8 0x00007ffff6be3ced in g_cclosure_marshal_generic_va (closure=0x555555e939f0, return_value=0x0, instance=<optimized out>, args_list=<optimized out>, marshal_data=<optimized out>, n_params=3, param_types=0x5555559f4940) at ../../../../gobject/gclosure.c:1604
#9 0x00007ffff6be3346 in _g_closure_invoke_va (closure=0x555555e939f0, return_value=0x0, instance=0x555555e7d430, args=0x7fffffffcd70, n_params=3, param_types=0x5555559f4940)
    at ../../../../gobject/gclosure.c:867
#10 0x00007ffff6bfe9ff in g_signal_emit_valist (instance=0x555555e7d430, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffffffcd70) at ../../../../gobject/gsignal.c:3300
#11 0x00007ffff6bff12f in g_signal_emit (instance=instance@entry=0x555555e7d430, signal_id=<optimized out>, detail=detail@entry=0) at ../../../../gobject/gsignal.c:3447
#12 0x00007ffff700f7fc in gtk_gesture_multi_press_begin (gesture=0x555555e7d430 [GtkGestureMultiPress], sequence=<optimized out>) at ../../../../gtk/gtkgesturemultipress.c:241
#13 0x00007ffff6be6008 in g_cclosure_marshal_VOID__BOXEDv (closure=0x555555ab92d0, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x5555559aa9c0) at ../../../../gobject/gmarshal.c:1950
#14 0x00007ffff6be3346 in _g_closure_invoke_va (closure=0x555555ab92d0, return_value=0x0, instance=0x555555e7d430, args=0x7fffffffd130, n_params=1, param_types=0x5555559aa9c0)
    at ../../../../gobject/gclosure.c:867
#15 0x00007ffff6bfe9ff in g_signa...

Read more...

Götz Waschk (goetz-waschk) wrote :

This might be a dupe of bug #1801436 as it only happens with the alternative-toolbar plugin that was enabled by default.

Sebastien Bacher (seb128) wrote :

Could you describe how you trigger the issue? Is that by clicking play? Does it happen on local files (any of those?) or other sources?

Since you can reproduce could you also maybe report it upstream on https://github.com/fossfreedom/alternative-toolbar/issues ?

affects: gstreamer1.0 (Ubuntu) → rhythmbox-plugin-alternative-toolbar (Ubuntu)
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: Incomplete → New
importance: Low → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks!

fossfreedom (fossfreedom) wrote :

Git Master has a suggested fix now - initial testing indicates success ...

I note there is a request for a SRU here https://bugs.launchpad.net/ubuntu/+source/rhythmbox-plugin-alternative-toolbar/+bug/1810086

So maybe should wrap the fix with the SRU?

Sebastien Bacher (seb128) wrote :

The fix commited upstream looks like more a workaround, unsure it qualifies for a SRU. Could you provide details on the gtk call/api/functions that doesn't like the non english label? Maybe we can come with a small python testcase and get the real gtk/binding issue fixed instead?

(0.18.1 as a SRU is an option, is that version a bugfix only one? unsure if the plugin has stable/unstable series?)

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Disco):
assignee: nobody → fossfreedom (fossfreedom)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox-plugin-alternative-toolbar - 0.18.3-1

---------------
rhythmbox-plugin-alternative-toolbar (0.18.3-1) unstable; urgency=medium

  * Bug fix release
    - Fix crash with german locale (LP: #1812683)
    - Latest turkish translation

 -- David Mohammed <email address hidden> Sun, 03 Feb 2019 23:17:14 +0000

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Disco):
status: In Progress → Fix Released
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Cosmic):
assignee: nobody → Sebastien Bacher (seb128)
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Bionic):
assignee: nobody → Sebastien Bacher (seb128)
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Cosmic):
importance: Undecided → Low
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Bionic):
importance: Undecided → Low
status: New → Confirmed
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Cosmic):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Didier, as discussed could you take over that one? The upstream commit of disabling column reordering in !en locale is not a fix, we should get at the bottom of it.
That's also blocking SRUing a newer bugfix version to bionic

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Cosmic):
assignee: Sebastien Bacher (seb128) → Didier Roche (didrocks)
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Bionic):
assignee: Sebastien Bacher (seb128) → Didier Roche (didrocks)
Sebastien Bacher (seb128) wrote :

(the upstream issue has some detail on the code impacted, it looks like it could be a gtk/binding issue, unless the rb-plugin is doing something stupid that gtk doesn't like)

Didier Roche (didrocks) wrote :

I'll try looking at it again tomorrow. I tried multiple combinations yesterday and no luck so far…

Sebastien Bacher (seb128) wrote :

I can easily trigger it this way on bionic (stock install, no music on disk)
$ sudo apt install language-pack-gnome-de
$ LANG= LANGUAGE= LC_ALL=de_DE.UTF-8 rhythmbox

- Click on the first item of the 3rd section on the left (the one with a star icon)
- dnd a column on the right of "Lange"
- click on some of the column headers

It segfaults every time I go to that section and click a column after those steps

Didier Roche (didrocks) wrote :

I have tried reproducing it both on disco (without the prevent-reordering patch) and stock bionic with german locale installed.

I tried adding all available columns, reordering them, click on them. I also imported some MP3 with altered metadata with umlaüt on each category and retry the above (adding, reordering columns, double clicking…)

This was my investigations so far (I didn't spot anything obvious in the code as well).

I tried as well the above step descriptions. Note that I only have a star icon in French and a generic icon in German (and French translations only for those items), compared to your description. See the video attached. Subsequent rhythmbox close/launch doesn't change anything. What am I missing?

Didier Roche (didrocks) wrote :

We need a decision if we SRU the workaround or not. After further investigations, I still can't reproduce it.
There is nothing clear in the bindings and it seems people can reproduce it without the plugin?

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Cosmic):
status: Confirmed → Incomplete
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Bionic):
status: Confirmed → Incomplete
Sebastien Bacher (seb128) wrote :

Not going to be SRUed to cosmic which is neither nor a LTS nor the current stable version

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu Cosmic):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.