rhythmbox 3.4.1 does not recognize audio-cd and no ripping possible

Bug #1733438 reported by gebi on 2017-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rhythmbox-plugin-alternative-toolbar (Ubuntu)
Undecided
fossfreedom

Bug Description

Insert a audio cd. Nothing happens in rhythmbox.
But: in nautilus the audio-cd appears in the right panel and a button on the right for opening in rhythmbox.
Pressing this button opens the audio-cd in rhythmbox with tagging.
But no ripping is possible ?
In older versions the audio-cd was opened directly in rhythmbox and there where options
for ripping.

report on 17.10 and rhythmbox 3.4.1

rithik g (gkrithi) wrote :

Audio CD should appear under "Other Sources" in the left pane.

Enable "Preferences -> View -> Show Source Toolbar" to see ripping options. ( This option is not persistent across rhythmbox restarts, which it should be )

gebi (gebi) wrote :

Thanks !
it is working now.
IMHO: from an end-user point of view, this option is very very hidden
and should be enabled by default.

That this option is not persistent is a bug (open ?)

rithik g (gkrithi) wrote :

This is not a bug in rhythmbox code. It is in "alternative-toolbar" plugin which was included by default and enabled in Ubuntu. You can file a bug for the plugin at

https://github.com/fossfreedom/alternative-toolbar/issues/new

affects: rhythmbox (Ubuntu) → rhythmbox-plugin-alternative-toolbar (Ubuntu)
fossfreedom (fossfreedom) wrote :

Added a more discoverable button to the headerbar - this should resolve this.

Available in git https://github.com/fossfreedom/alternative-toolbar

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: New → Fix Committed
assignee: nobody → fossfreedom (fossfreedom)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox-plugin-alternative-toolbar - 0.18.0-0ubuntu1

---------------
rhythmbox-plugin-alternative-toolbar (0.18.0-0ubuntu1) bionic; urgency=medium

  * New upstream release
    - Latest Translations
    - Headerbar button to toggle a source toolbar (LP: #1733438)
    - Fixes for crashes with a german locale
    - Add appdata metadata (LP: #1725457)
    - Fix for crash when connecting and selecting a blank error source
      when connecting a phone (LP: #1723129)
    - More logical help and about icons in the plugin window
    - Translate Category heading
    - Translate repeat button tooltip
  * Packaging Changes:
    - debian/{control/compat} - bump debhelper version to v11
    - debian/copyright - 2018 year change
    - debian/control - bump Standards-Version to 4.1.3 (no changes required)
    - debian/copyright - Add GPL-2+ copyright for debian/* files
    - debian/copyright - Fix year issues from running
      check-all-the-things
    - debian/upstream/metadata - fix warnings and errors from running
      check-all-the-things
    - debian/upstream - move and rename signing-key

 -- David Mohammed <email address hidden> Sun, 11 Feb 2018 20:26:47 +0000

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers