rhythmbox crashed with SIGSEGV in gtk_tree_view_get_column()

Bug #1725457 reported by Simon P. on 2017-10-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
rhythmbox-plugin-alternative-toolbar (Ubuntu)
Medium
fossfreedom

Bug Description

Rhythmbox frequently crashes while playing music using the "queue" function. Sometimes fails to show song titles until program restart.

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: rhythmbox 3.4.1-2ubuntu5
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 20 20:39:45 2017
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/rhythmbox
InstallationDate: Installed on 2017-09-30 (20 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
ProcCmdline: rhythmbox
SegvAnalysis:
 Segfault happened at: 0x7ff2d88c7424 <gtk_tree_view_get_column+84>: mov (%rax),%rax
 PC (0x7ff2d88c7424) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: rhythmbox
StacktraceTop:
 gtk_tree_view_get_column () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Title: rhythmbox crashed with SIGSEGV in gtk_tree_view_get_column()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
XorgLog: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/var/log/Xorg.0.log'

Simon P. (simpre) wrote :
Simon P. (simpre) on 2017-10-20
description: updated

StacktraceTop:
 gtk_tree_view_get_column (tree_view=tree_view@entry=0x55c047bc87c0, n=n@entry=16) at ././gtk/gtktreeview.c:12343
 _gtk_tree_view_accessible_remove_state (treeview=0x55c047bc87c0, tree=tree@entry=0x55c048e8e3a0, node=node@entry=0x55c048e98d60, state=state@entry=GTK_CELL_RENDERER_SELECTED) at ././gtk/a11y/gtktreeviewaccessible.c:2050
 gtk_tree_selection_real_select_node (selection=<optimized out>, tree=tree@entry=0x55c048e8e3a0, node=node@entry=0x55c048e98d60, select=select@entry=0) at ././gtk/gtktreeselection.c:1637
 unselect_all_helper (tree=0x55c048e8e3a0, node=0x55c048e98d60, data=0x55c048e90f30) at ././gtk/gtktreeselection.c:1194
 _gtk_rbtree_traverse_pre_order (tree=0x55c048e8e3a0, node=<optimized out>, func=0x7ff2d88b68b0 <unselect_all_helper>, data=0x55c048e90f30) at ././gtk/gtkrbtree.c:1428

Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:
* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

information type: Private → Public
Changed in rhythmbox (Ubuntu):
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Do you filter the view and then try to interact with the content while it was updating?

Simon P. (simpre) wrote :

No, I do not filter the view of my music library. And yes, on my system I can reproduce the bug:

1) Open Rythmbox
2) Add a song from the music library to the queue
3) Go to the queue and click on the song that was just added to play it.

Normally Rhythmbox will crash now. If not, repeat steps 2 and 3.

Simon P. (simpre) wrote :

The reason for my crashes of Rhythmbox seems to be the alternative appearance extension. With the extension disabled in the program settings I cannot reproduce those crashes.

affects: rhythmbox (Ubuntu) → rhythmbox-plugin-alternative-toolbar (Ubuntu)
fossfreedom (fossfreedom) wrote :

Please can you describe the exact steps how you add tracks to the queue to make this crash please?

Also, please run

rhythmbox -D alttoolbar

Then perform the action to make the crash happen. Please attach the output you see in the terminal.

Thanks.

Simon P. (simpre) wrote :
Download full text (5.1 KiB)

I add tracks to the queue by right-clicking them and then clicking the "add to queue" option.
The output of the "rhythmbox -D alttoolbar" command is:

(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: Ort
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: 11
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691:
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: Letzte Wiedergabe
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: 12
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691:
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: Hinzufügedatum
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: 13
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691:
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: BPM
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: 14
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691:
(23:48:33) [0x556d9726e410] [AltToolbarHeaderBar.move_col] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:691: Titel
(23:48:34) [0x556d9726e410] [AltToolbarHeaderBar._save_entryview_cols] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:897: entryview column changed
(23:48:34) [0x556d9726e410] [AltToolbarHeaderBar._save_entryview_cols] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:898: <__gi__.RBPlayQueueSource object at 0x7f968c04bc60 (RBPlayQueueSource at 0x556d975502d0)>
(23:48:34) [0x556d9726e410] [AltToolbarHeaderBar._save_entryview_cols] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_type.py:937: 'Genre','Interpret','Komponist','Album','Jahr','Länge','Qualität','Bewertung','Wiedergaben','Kommentar','Ort','Letzte Wiedergabe','Hinzufügedatum','BPM','Titel','Titel'
(23:48:34) [0x556d9726e410] [AltToolbarSidebar.delayed] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_sidebar.py:1021: {1: True, 2: False, 0: False, 3: False}
(23:48:36) [0x556d9726e410] [AltToolbarSidebar._set_text] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_sidebar.py:1117: Lokale Sammlung
(23:48:36) [0x556d9726e410] [AltToolbarSidebar._set_text] /usr/lib/rhythmbox/plugins/alternative-toolbar/alttoolbar_sidebar.py:1117: Lokale Sammlung
(23:48:36) [0x556d9726e410] [AltStandardOnlineController.valid_source] /usr/lib/rhythmbox/plugins/alternative-too...

Read more...

fossfreedom (fossfreedom) wrote :

I cannot make this crash as reported. If you can please can you make a short screenrecorder so that I can see what you are doing and to view your rhythmbox setup. Thanks.

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: Incomplete → New
fossfreedom (fossfreedom) wrote :

please can you go into plugin preferences - alternative toolbar and untick "enhanced sidebar". Restart Rhythmbox. Can you make rhythmbox crash after that?

Simon P. (simpre) wrote :

Yes, I can still make Rhythmbox crash with a disabled enhanced sidebar.
Noticed another little bug by the way while disabling it: When the alternative toolbar is enabled, I cannot go into plugin preferences.

Screencast of my crashes is attached.

rithik g (gkrithi) wrote :
fossfreedom (fossfreedom) wrote :
Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: New → Fix Committed
assignee: nobody → fossfreedom (fossfreedom)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox-plugin-alternative-toolbar - 0.18.0-0ubuntu1

---------------
rhythmbox-plugin-alternative-toolbar (0.18.0-0ubuntu1) bionic; urgency=medium

  * New upstream release
    - Latest Translations
    - Headerbar button to toggle a source toolbar (LP: #1733438)
    - Fixes for crashes with a german locale
    - Add appdata metadata (LP: #1725457)
    - Fix for crash when connecting and selecting a blank error source
      when connecting a phone (LP: #1723129)
    - More logical help and about icons in the plugin window
    - Translate Category heading
    - Translate repeat button tooltip
  * Packaging Changes:
    - debian/{control/compat} - bump debhelper version to v11
    - debian/copyright - 2018 year change
    - debian/control - bump Standards-Version to 4.1.3 (no changes required)
    - debian/copyright - Add GPL-2+ copyright for debian/* files
    - debian/copyright - Fix year issues from running
      check-all-the-things
    - debian/upstream/metadata - fix warnings and errors from running
      check-all-the-things
    - debian/upstream - move and rename signing-key

 -- David Mohammed <email address hidden> Sun, 11 Feb 2018 20:26:47 +0000

Changed in rhythmbox-plugin-alternative-toolbar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers