wifi permanently blocked after rebooting with wifi off

Bug #786233 reported by Christopher Barrington-Leigh on 2011-05-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
rfkill (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: rfkill

Problem began abruptly on upgrading to 11.04.
If I turn wireless off, e.g. through Fn-F5 and/or through the network applet on the task bar under Gnome and then reboot, the wireless is unusable / unavailable after rebooting.

symptoms:
(1) wireless is greyed out in the network applet
(2) Fn-F5 now cycles between bluetooth on/off, rather than the four combinations of wireless and bluetooth on/off

As far as I can tell, nothing recovers from the problem without a second reboot. Using
rfkill unblock all
rfkill unblock wifi

followed by rebooting still leaves things broken, in that the indictor light normally associated with Fn-F5 still won't come on when cycling Fn-F5.
however, at this point the applet has wifi ungreyed, and after turning wifi on there, the Fn-F5 behaviour becomes normal again.

(I'm sure I've got the package association wrong; I've put rfkill to start towards the right track)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: rfkill 0.4-1
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
Architecture: amd64
Date: Sat May 21 09:36:37 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: rfkill
UpgradeStatus: Upgraded to natty on 2011-05-03 (18 days ago)

The same thing happens on my netbook, suggesting this is an awfully wide-impact bug?!

After all the intervening updates, this bug still exists for me as described: if I reboot with wifi off, there is no way for me to get it working again without a second reboot.

This bug is still entirely unaddressed, ie still occurs reliably, in the released 11.10, after a fresh install on my HP Mini 1116NR.

tags: added: oneiric
tags: added: i386

A bit more description, under Gnome 3 on the HP Mini 1116NR:

There's a hardware switch. If I boot, find network working fine, and then turn it off by holding the hardware switch to the off position for a second or two, the hardware switch light changes from blue to orange and I lose network (as expected). If I now reboot, the hardware switch light starts in off (orange) mode. The network icon in my panel shows no network. If I look at network settings, it says wireless is Unavailavble.

If I turn on network by holding the hardware switch down, the light turns from orange to blue (usually meaning network is working) but nothing happens on the panel. It's still unavailable in the settings. "ifconfig" shows Not-Associated for access point, and zeros for everything else.

I do not know of a way to get the network to work, except for now rebooting with the blue light on. Then I'll be back to the initial state, above.

summary: - wifi permanently blocked on Lenovo T410s after rebooting with wifi off
+ wifi permanently blocked after rebooting with wifi off

This problem still exists on latest 11.10. #:(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers