Please merge revelation-0.4.11-5 (universe) from Debian unstable

Bug #520281 reported by Bart Veldstra
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
revelation (Ubuntu)
Wishlist
Stephan Rügamer

Bug Description

Binary package hint: revelation

Changes:
 revelation (0.4.11-5) unstable; urgency=low
 .
   * Added VCS information to debian/control
   * Backup file before save (Closes: #524471)
   * urldecode file names (Closes: #518085)
   * fix outdated-autotools-helper-file lintian warning
   * no longer build for python 2.4
   * fix patch-system-but-no-source-readme warning
   * New Standards-Version: 3.8.3
   * fix dh_desktop-is-deprecated warning

I have tried to do this myself, but I ran into trouble with autotools: debian/rules calls autoreconf, undoing some dpatch changes in the ./configure and aclocal.m4. Also, once installed, python cannot find the revelation module. This is a little bit over my head, so I'll leave it for someone more competent in packaging than I am.

Related branches

Hew (hew)
Changed in revelation (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Bart Veldstra (ghostonline) wrote :

After some experimenting, I found that the patches that malfunctioned by calling autoreconf appear to be obsolete with the new version of revelation. I have listed them here with the reason why I think they are obsolete:

010_intltool.dpatch: The new debian version lists the intltools as a package dependency, using the systems inittool instead of creating its own. Removing them is therefore not necessary anymore.
020_server_data.dpatch: the contents of server_DATA ('GNOME_RevelationApplet.server') is also listed in CLEANFILES, which is already being removed by the 'clean-generic' target.
093_python26_transition.dpatch: This is a workaround for a bug in autotools, which is already fixed for a while.

I have noticed that debian/rules only builds for Python 2.5 (PYVERS=2.5 in rules). This results in the error where the module cannot be found. Using a small python snippet ('PYVERS=`python -c "import sys; print '.'.join(str(i) for i in sys.version_info[0:2])"`'), this variable can be determined by the builder, although I am not sure if this is the best way to go about this.

These are my findings as an inexperienced packager. Can someone more experienced with either the revelation package or packaging in general (Hew?) check if my findings are correct? If they are, I think I can perform the merge myself.

Revision history for this message
Hew (hew) wrote :

I'm not an experienced packager unfortunately. I'd recommend preparing the merge and getting a sponsor to look over it.

Revision history for this message
Bart Veldstra (ghostonline) wrote :

I have created a debdiff for the merge and will subscribe the universe sponsors.

Revision history for this message
Stephan Rügamer (sruegamer) wrote :

working on it

Changed in revelation (Ubuntu):
assignee: nobody → Stephan Hermann (shermann)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package revelation - 0.4.11-5ubuntu1

---------------
revelation (0.4.11-5ubuntu1) lucid; urgency=low

  * Merge from debian testing. Remaining changes: (LP: #520281)
    - debian/rules:
      + Fix FTBFS with python >= 2.6
      + Include dh_icons
    - debian/patches/091_panel_category.dpatch:
      + Change GNOME panel category from "Utility" to the correct "Utilities".
    - debian/patches/092_typo_de_translation.dpatch:
      + Fix German translation typo
    - debian/patches/00list:
      + Include 040_xhtml.dpatch
  * Rename Ubuntu specific patches to avoid confusion with Debian's patches:
    - 91_panel_category.dpatch -> 091_panel_category.dpatch
    - 92_typo_de_translation.dpatch -> 092_typo_de_translation.dpatch
  * debian/patches/00list: Update with new Ubuntu specific patch names
  * Dropped changes now applied upstream:
    - debian/patches/94_url_decoding.dpatch:
      - Patches io.py to unquote file url during the normalisation process
  * Dropped changes no longer required:
    - debian/patches/010_intltool.dpatch:
      + Remove intltool files when cleaning
    - debian/patches/020_server_data.dpatch:
      + Remove GNOME_RevelationApplet.server when cleaning
    - debian/patches/93_python26_transition.dpatch:
      + Patches aclocal.m4 to return the correct value for
        cv_python_pyexecdir
  * debian/patches/100_backup_on_save.dpatch: (LP: #338138)
    Patches io.py to create a backup file before saving and restore
    the backup if saving fails

revelation (0.4.11-5) unstable; urgency=low

  * Added VCS information to debian/control
  * Backup file before save (Closes: #524471)
  * urldecode file names (Closes: #518085)
  * fix outdated-autotools-helper-file lintian warning
  * no longer build for python 2.4
  * fix patch-system-but-no-source-readme warning
  * New Standards-Version: 3.8.3
  * fix dh_desktop-is-deprecated warning
 -- Bart Veldstra <email address hidden> Sat, 16 Jan 2010 06:13:18 +0000

Changed in revelation (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers