Restricted drivers manager damages my xorg.conf [Nvidia Legacy Drivers]

Bug #92849 reported by AkumA on 2007-03-16
12
Affects Status Importance Assigned to Milestone
restricted-manager (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: restricted-manager

I've just updated Feisty. Brand new kernel, nvidia-glx-legacy package for my kernel and of course the relative linux-restricted-modules.

No problems at all 'till i've discovered a few seconds in tray bar loading.
I've seen the new feature "restricted drivers manager" and i've tried it.
I've checked the option "Enable" of my driver (nvidia-glx-legacy). I was running with nvidia driver (The nvidia logo showed up on entering gdm).

After that i've made "Log out" and ctrl+alt+backspace and i got a problem that, after herd 3, happends when i run: dpkg-reconfigure xserver-xorg.

The problem is this:
i restart gdm and i got nvidia logo, than it returns to prompt and the monitors "Click" (For resolution change i suppose), then nvidia logo again, prompt again, logo again and after that there's the nice xorg error.

It says that it can't load glx visuals.

I have Feisty upgraded from Edgy (With Herd4 update-manager -d).
I have 3D working, the new xserver-xgl and the latest compiz but i can't make 3D desktop work.
Maybe it's for the same reason.. maybe there's something wrong.
When the new xorg.conf comes (Both with dpkg-reconfigure or restricted manager) i can't see inside it some differences with my working xorg (Except the added options for XGL).

I can't understand why

ProblemType: Bug
Architecture: i386
Date: Fri Mar 16 17:36:18 2007
DistroRelease: Ubuntu 7.04
Uname: Linux magrebianware 2.6.20-11-generic #2 SMP Thu Mar 15 08:03:07 UTC 2007 i686 GNU/Linux

Martin Pitt (pitti) wrote :

I just uploaded version 0.10 with two tons of fixes. Could you upgrade to this and try again?

You can use

  sudo dpkg-reconfigure -phigh xserver-xorg

(also on a text console) to repair your configuration.

Changed in restricted-manager:
status: Unconfirmed → Needs Info
AkumA (zio-protestante) wrote :

dpkg-reconfigure -phigh xserver-xorg returned me the same results as dpkg-reconfigure WITHOUT -phigh option.

By the way, i'll retry in a few minutes.

I'm not so pratice in linux, so if you need some logs or other things just give me some locations where i should find them and i'll copy them when i get the errors. When i'll fix the problem i'll be back with a more reasonable bug reporting.. maybe.. ^_^"

AkumA (zio-protestante) wrote :

Ok. It says that i have nvidia legacy drivers (Installed) but it removes and installs nvidia-glx.
After making dpkg-reconfigure ... it doesn't work because in xorg.conf appears driver apm.
Obviously i change apm to nvidia and it doesn't work.

I hope it wouldn't be a package for recent nvidia only.. XGL in Feisty worked for me, and now there's a maintainer for xserver-xgl package in Feisty.

These are my xorgs.

the "reconf" xorg is the one from dpkg-reconfigure.
I've commented DRI section and added nvidia as driver

AkumA (zio-protestante) wrote :

Working xorg file

Darroch (darroch) wrote :

Had the same or similar problem with driver for newer nvidia cards... I did a apt-get --purge remove nvidia-glx, then a dpkg-reconfigure -phigh xserver-xorg, and rebooted and reinstalled via the manager.. it's now working fine.

Miłosz Kosobucki (mikom) wrote :

In my case the restricted-manager found that I have legacy card (GeForce2 GTS), it showed "NVIDIA accelerated graphics driver (legacy cards)", but nevertheless when I clicked "Enable" it installed the nvidia-glx package instead of nvidia-glx-legacy. Then it completely messed up the xorg.conf file setting some ridiculous driver:

Section "Device"
        Identifier "Generic Video Card"
        Driver "apm"
        BusID "PCI:1:0:0"
        VideoRam 64000
EndSection

apm is the first driver in the xorg driver list and it looks like it just picked up the first one one the list. Of course the system refused to launch X after these changes so I manually set xorg.conf to use "nv" driver again. I think this is very important to resolve this bug soon. Restricted-manager should better know which driver to install and handle modifications of xorg.conf better.

Jan Claeys (janc) wrote :

Same problem here: my Riva TNT2 Pro gets detected as a legacy nVidia card, but nvidia-glx is installed instead of nvidia-glx-legacy, and as a result (I think?) the Driver line gets set to "apm".

Jan Claeys (janc) wrote :

BTW: this is with v0.10 :)

AkumA (zio-protestante) wrote :

yeah.. that's true... i'm studing at university and i can understand something about programming and something about linux.. but i've found strange the way the package came out and the:"Ok, you have nvidia legacy, now i'll install drivers for new nvidias.."

Dunno..

I've installed Feisty to see it growing, so let's be patient anyway ^^

Martin Pitt (pitti) wrote :

Silly me, I see where the problem is.

Changed in restricted-manager:
assignee: nobody → pitti
status: Needs Info → In Progress
Martin Pitt (pitti) on 2007-03-19
Changed in restricted-manager:
importance: Undecided → High
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 restricted-manager (0.11) feisty; urgency=low
 .
   * RestrictedManager/xorg_driver.py: Do not autodetect mouse and monitor when
     reconfiguring xserver-xorg for a new driver. This avoids clobbering
     manually added undetected resolutions. (LP: #93643)
   * po/de.po: Synchronize with Rosetta.
   * RestrictedManager/nvidia.py: Enable NoLogo by default. (LP: #93306)
   * RestrictedManager/nvidia.py: Enable AddARGBVisuals to make Beryl work.
     (LP: #93262)
   * RestrictedManager/xorg_driver.py: Do not mangle xorg.conf if package
     download/installation was aborted. (LP: #92573)
   * RestrictedManager/nvidia.py: Fix passing of driver package name, so that
     the legacy driver actually installs nvidia-glx-legacy. (LP: #92849, part
     one)
   * RestrictedManager/{xorg_driver,nvidia,fglrx}.py: Do not assume that the
     kernel module name always matches the X.org driver module name
     (nvidia_legacy vs. nvidia), but instead pass the X.org driver name as a
     separate attribute. ((LP: #92849, part two)
   * RestrictedManager/modalias.override: Add NV44A [GeForce 6200] (not covered
     by nvidia_supported). (LP: #93209)
   * RestrictedManager/core.py: When loading default or special handlers, check
     that there is actually a kernel module behind. Otherwise we will display
     handlers with overrides on platforms which do not actually provide those
     modules. (LP: #93368)

Changed in restricted-manager:
status: Fix Committed → Fix Released
zeddock (zeddock) wrote :

Where is the problem?
And what is the above post for?

Thanx.

zeddock

Miłosz Kosobucki (mikom) wrote :

There is however still a little problem. When I used restricted-manager to intall driver for my GeForce2 GTS it didn't set the xorg configuration correctly. By default, composite extension is turned on in Ubuntu. But nvidia-legacy driver can't handle GLX with Composite extension without AllowGLXwithComposite option. So after installation of this driver I still didn't have 3d graphics. I think that restricted-manager should automatically turn off composite extension or add AllowGLXwithComposite option.

Martin Pitt (pitti) wrote :

Milosz, please file a new bug about this issue.

zeddock, 'above post' is the changelog of the version that fixed this problem.

So, since I am having the same issue, do I enable the restricted and then go
in and manually change xorg.conf?

And if so, what do I change within it?

Thanx!

Zeddock

On 3/22/07, Martin Pitt <email address hidden> wrote:
>
> Milosz, please file a new bug about this issue.
>
> zeddock, 'above post' is the changelog of the version that fixed this
> problem.
>
> --
> Restricted drivers manager damages my xorg.conf [Nvidia Legacy Drivers]
> https://launchpad.net/bugs/92849
>

Soul-Sing (soulzing) wrote :

after installing the nividia driver with the restricted modules in feisty herd 4 and 5. everthing was well and performing nice. glxinfo: allright, glxgears: allright.
than activating the restricted driver manager, it gave a not installed nvidia driver in the lay-out.
after that i activated the "nividia button" did a reboot and X was a mess. this should really be fixed soon,
a second experiment in herd 5 gave the same result: de restricted driver manager broke me X.
sudo dpkg-reconfigure -phigh xserver-xorg doesn't work

details: nvidia legacy drivers

ProblemType: Bug
Architecture: i386

DistroRelease: Ubuntu 7.04
herd 4 and 5 and beta!

I made an install from scratch.
My nvidia gf fx 5200 and fusi t17-1 worked well with 'nv'.
After enabling hw acceleration at Restrictid Drivers and restarting gdm I got some error. Reboot.
After that I got a us-english keyboard, 50Hz and 1024*768.
xorg.conf got the following not-really-good chages:

- Option "XkbLayout" "hu"
+ Option "XkbLayout" "us"
# WHY???

- Identifier "nVidia Corporation NV34 [GeForce FX 5200]"
- Driver "nv"
+ Identifier "Általános videó kártya"
         # this means Generic VGA card, but this unicode isn't
         # very nice... and btw the name of the card is better.

- Identifier "T17-1"
+ Identifier "Generic Monitor"
# WHY???

+ HorizSync, VertRefresh with a default value. at about 50Hz.. without these works everything well

# 6 times:
- Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
+ Modes "1024x768" "800x600" "640x480"
# WHY???

Máté Őry (orymate) wrote :

We need some more tons of bugfixes for this bug.

Changed in restricted-manager:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Ory, this bug is already fixed in current Feisty. Please upgrade your system.

Changed in restricted-manager:
status: In Progress → Fix Released

I have a Ti4600 AGP and the restricted driver manager indicates a legacy driver is needed. Just checked for updates and I'm current.

Martin,
I really do not think that it is fixed.

Clean install yesterday night, updates applied. Restricted Manager says I
do not need any restricted drivers but I do need a restricted driver for
nVidia card.

zeddock

On 4/3/07, Martin Pitt <email address hidden> wrote:
>
> Ory, this bug is already fixed in current Feisty. Please upgrade your
> system.
>
> ** Changed in: restricted-manager (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> Restricted drivers manager damages my xorg.conf [Nvidia Legacy Drivers]
> https://bugs.launchpad.net/bugs/92849
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Martin Pitt (pitti) wrote :

zeddock, this was fixed in this upload:

linux-restricted-modules-2.6.20 (2.6.20.5-14.16) feisty; urgency=low

  * Change nvidia back to 9631, add epoch for nvidia-glx packages.
  * Add nvidia-news package at version 9755. This is the path of least
    surprise.
  * Add module alias override patch from Johan Kiviniemi
    <email address hidden>.

 -- Ben Collins <email address hidden> Tue, 10 Apr 2007 00:16:00 -0400

So I'm afraid you have to update your system again to make it work. Thank you!

zeddock (zeddock) wrote :

I must have already done this because it is working.
Thanx for the help though. The whole of Feisty is becoming very stable!

zeddock

On 4/16/07, Martin Pitt <email address hidden> wrote:
>
> zeddock, this was fixed in this upload:
>
> linux-restricted-modules-2.6.20 (2.6.20.5-14.16) feisty; urgency=low
>
> * Change nvidia back to 9631, add epoch for nvidia-glx packages.
> * Add nvidia-news package at version 9755. This is the path of least
> surprise.
> * Add module alias override patch from Johan Kiviniemi
> <email address hidden>.
>
> -- Ben Collins <email address hidden> Tue, 10 Apr 2007 00:16:00 -0400
>
> So I'm afraid you have to update your system again to make it work.
> Thank you!
>
> --
> Restricted drivers manager damages my xorg.conf [Nvidia Legacy Drivers]
> https://bugs.launchpad.net/bugs/92849
> You received this bug notification because you are a direct subscriber
> of the bug.
>

zeddock (zeddock) wrote :

Now on Gusty similar problems. Please help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers