fglrx needs to be modprobed in /etc/modules

Bug #91315 reported by John Dong on 2007-03-11
2
Affects Status Importance Assigned to Milestone
restricted-manager (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: restricted-manager

On both my computer and a friend's, fglrx needs to be in /etc/modules in order for fglrx 3D acceleration to work. Unlike nvidia.ko, fglrx will NOT attempt to modprobe fglrx.ko automatically, but will rather fall back to 2D fglrx mode.

Martin Pitt (pitti) on 2007-03-13
Changed in restricted-manager:
assignee: nobody → pitti
importance: Undecided → Medium
status: Unconfirmed → In Progress
Martin Pitt (pitti) wrote :

Hm, it seems to work without this for Michael Vogt. Can you please check if you still happen to have an /etc/modprobe.d/blacklist-restricted which contains 'fglrx'? Does removing that file make fglrx load automatically again?

Changed in restricted-manager:
status: In Progress → Needs Info

Got nothing blacklisted, but removing fglrx from /etc/modules makes X
fallback to 2D.

John Dong (jdong) on 2007-03-13
Changed in restricted-manager:
status: Needs Info → Unconfirmed
Martin Pitt (pitti) wrote :

Alright, thanks for confirming. I just wanted to make sure it wasn't due to some old cruft from earlier versions.

Changed in restricted-manager:
status: Unconfirmed → In Progress
Martin Pitt (pitti) on 2007-03-13
Changed in restricted-manager:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 restricted-manager (0.7) feisty; urgency=low
 .
   [ Johan Kiviniemi ]
   * RestrictedManager/core.py: Save the module cache *after* parsing
     modalias.override.
   * debian/restricted-manager.postinst: Invalidate cache files saved by
     earlier versions.
 .
   [ Martin Pitt ]
   * RestrictedManager/fglrx.py: Add/remove fglrx to/from /etc/modules;
     reportedly it is not always autoloaded. (LP: #91315)
   * po/de.po: Completely translate GUI to discover remaining i18n problems.
   * RestrictedManager/manager.glade, restricted-manager: Move main window
     heading label text into the Python code. For some weird reason, gettext is
     not called on the string when having it in the glade data.
   * applications/restricted-manager.desktop.in: Specify .desktop file as gksu
     -D argument instead of fixed English string to re-use the .desktop's Name
     translations.

Changed in restricted-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers