Do not assume disabling fglrx reverts to ati

Bug #91311 reported by John Dong on 2007-03-11
2
Affects Status Importance Assigned to Milestone
restricted-manager (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: restricted-manager

        dc = debconf.DebconfCommunicator("restricted-manager")
        dc.set("xserver-xorg/config/device/driver", "ati")

r-m currently reverts to ati when fglrx is turned off. This is not always a true assumption -- on all X-series radeons, ati refuses to start, which would leave people with broken X.

So, we should either save the previous driver, or have logic detecting if it's an R350+ chipset that's not supported.

Martin Pitt (pitti) on 2007-03-13
Changed in restricted-manager:
assignee: nobody → pitti
status: Unconfirmed → Fix Committed
Martin Pitt (pitti) wrote :

 restricted-manager (0.5) feisty; urgency=low
 .
   [ Martin Pitt ]
   * applications/restricted-manager.desktop.in: Capitalize 'Manager'
     (LP: #90722)
   * restricted-manager: Replace deprecated egg.TrayIcon by gtk.StatusIcon
     which makes the code much simpler. Drop python-gnome2-extras dependency.
   * Added RestrictedManager/restricted22.png: 22x22 version of the small
     restricted16.png icon; scaling down the large one in the tray looked bad.
   * debian/copyright: Clean up authors a bit.
   * RestrictedManager/fglrx.py, RestrictedManager/nvidia.py: Do not hardcode
     'ati' and 'nv' as driver when disabling the restricted one; instead,
     remember the previous driver. (LP: #91311)
   * RestrictedManager/fglrx.py, RestrictedManager/nvidia.py: Call
     DefaultHandler's enable/disable functions as well, to handle module
     (un)blacklisting.
   * RestrictedManager/core.py: Add class methods {en,dis}able_etcmodules() to
     modify /etc/modules. This is needed for bugs like #91315
 .
   [ Johan Kiviniemi ]
   * restricted-manager, RestrictedManager/core.py,
     RestrictedManager/fglrx.py, RestrictedManager/nvidia.py: No longer
     running lspci and specifying hardware vendor/class IDs inside the
     code. Instead query modules themselves for hardware identification
     patterns and sysfs for connected hardware.
   * RestrictedManager/modalias.append: Patterns for modules that do not
     contain them already.
   * RestrictedManager/modalias.override: Patterns for modules that provide too
     broad patterns themselves.
   * debian/rules: Install modalias.append, modalias.override.
   * debian/restricted-manager.postinst: Remove cache files made by older
     versions, since the format has changed.
   * modalias_override: Added a script that scrapes the nVidia website for
     accurate lists of cards supported by the drivers.
   * debian/copyright: Mention modalias_override/nvidia_supported.

Changed in restricted-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers